在线检测未来函数

通达信黑马的摇篮指标公式

来源:Internet,编辑:股旁网,2018-03-21

SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:= MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3<FF1,FF1,FF3);
MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
黑马:=IF(ZDHM OR ZHM,80,0);
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
小黑马:=IF(CROSS(D1,K1),60,0);
STICKLINE(大黑马>0,0,大黑马*1.1,1,0),COLORWHITE;
STICKLINE(大黑马>0 AND 大黑马<52,30,大黑马,1,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.8,4,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.4,8,0),COLORRED;
STICKLINE(大黑马>0,0,大黑马*0.2,10,0),COLORYELLOW;
STICKLINE(大黑马>0,0,大黑马*0.1,10,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*1.1,1,0),COLORWHITE;
STICKLINE(小黑马>0 AND 小黑马<52,30,小黑马,1,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*0.8,4,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*0.4,8,0),COLORFFCC66;
STICKLINE(小黑马>0,0,小黑马*0.2,10,0),COLORFF00FF;
DRAWTEXT(CROSS(D1,K1),55,'黑马狂奔'),COLORFFCC66;
DRAWTEXT(ZDHM OR ZHM,75,'天马过桥'),COLORYELLOW;

通达信黑马的摇篮指标公式

 

相关文章