在线检测未来函数

通达信天地七线主图指标公式

来源:Internet,编辑:股旁网,2018-03-22

VAR2:=485;
VAR3:=222;
VAR4:=96;
VAR5:=MA(HHV(HIGH,VAR2),17);
VAR6:=MA(HHV(HIGH,VAR3),17);
VAR7:=MA(HHV(HIGH,VAR4),17);
VAR8:=MA(LLV(LOW,VAR2),17);
VAR9:=MA(LLV(LOW,VAR3),17);
VARA:=MA(LLV(LOW,VAR4),17);
VARB:=MA((VAR8*0.96+VAR9*0.96+VARA*0.96+VAR5*0.558+VAR6*0.558+VAR7*0.558)/6,17);
VARC:=MA((VAR8*1.25+VAR9*1.23+VARA*1.2+VAR5*0.55+VAR6*0.55+VAR7*0.65)/6,17);
VARD:=MA((VAR8*1.3+VAR9*1.3+VARA*1.3+VAR5*0.68+VAR6*0.68+VAR7*0.68)/6,17);
VARE:=MA((VARB*3+VARC*2+VARD)/6*1.738,17);
VARF:=MA((VARB*2.38+VARC*2.18+VARD*1.85+VAR5*1.05)/4,17);
VARG:=MA((VARB*2.68+VARC*2.48+VARD*2.18+VARE*1.85+VAR6*1.65)/5,17);
VAR10:=MA((VARD+VARE)*0.5,17);
安全地线: VARB,COLORWHITE,LINETHICK2;
弱势反弹: VARC,COLORCYAN,LINETHICK2;
低吸买入: VARD,COLORGREEN,LINETHICK2;
多空变盘: VAR10,COLORYELLOW,LINETHICK2;
加速上涨: VARE,COLORBLUE,LINETHICK2;
高位风险: VARF,COLORBROWN,LINETHICK2;
警戒天线: VARG,COLORRED,LINETHICK2;
DA:=(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;
X2:=(20*DA+19*REF(DA,1)+18*REF(DA,2)+17*REF(DA,3)+16*REF(DA,4)+15*REF(DA,5)+14*REF(DA,6)+13*REF(DA,7)+12*REF(DA,8)+11*REF(DA,9)+10*REF(DA,10)+9*REF(DA,11)+8*REF(DA,12)+7*REF(DA,13)+6*REF(DA,14)+5*REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)+2*REF(DA,18)+REF(DA,20))/210,COLORF0F000;
X3:=MA(X2,5),COLORYELLOW,LINETHICK1;
X1:=(C+L+H)/3;
买:=CROSS(X2,X3);
卖:=CROSS(X3,X2);
DRAWICON(买,L*0.95,1);
DRAWICON(CROSS(X2,X3),L*0.97,7);
DRAWICON(卖,H*1.04,2);
DRAWICON(CROSS(X3,X2),H*1.02,8);
STICKLINE(X2>=X3,LOW,HIGH,0,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,3.2,2),COLORRED;
STICKLINE(X2<X3,LOW,HIGH,0,1),COLORBLUE;
STICKLINE(X2<X3,CLOSE,OPEN,3.2,2),COLORBLUE;
STICKLINE(CROSS(X3,X2),OPEN,CLOSE,3.2,0),COLORBLUE;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,3.2,0),COLORRED;
STICKLINE((CLOSE>OPEN) AND (X2<X3),CLOSE,OPEN,3.2,2)COLORBLUE;
STICKLINE((CLOSE>OPEN) AND (X2>=X3),CLOSE,OPEN,3.2,2)COLORRED;
STICKLINE((CLOSE<OPEN) AND (X2<X3),CLOSE,OPEN,3.2,0)COLORBLUE;STICKLINE((CLOSE<OPEN) AND (X2>=X3),CLOSE,OPEN,3.2,0)COLORRED;
STICKLINE((CLOSE=X3),CLOSE,OPEN,3.2,0)COLORRED;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
主力成本:EMA(X,13),COLORMAGENTA,LINETHICK2;
ZZ:=(O+H+L)/3;
YC:=(H+L)/2;
YCHJX:=(EMA(ZZ,4))+(YC-REF(ZZ,3))/4;
今日买点:EMA(ZZ,3),COLORYELLOW,LINETHICK0;
明日买点:YCHJX,LINETHICK0;昨测今日买点:REF(YCHJX,1),LINETHICK0;

通达信天地七线主图指标公式

 

相关文章