在线检测未来函数

通达信卧槽马主图指标公式

来源:Internet,编辑:股旁网,2018-03-28

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
N:=30;
KK:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,KK),0));
RR:=CONST(IF(ISLASTBAR=1,LLV(L,KK),0));
KJ:=GD-RR;
A:=EMA(C,21)COLORBLUE,LINETHICK3;
B:=A<REF(A,1);
HY:=IF(B-1,A,DRAWNULL)COLORRED,LINETHICK3;
AA:=EMA(C,3) > EMA(C,21);
BB:=EMA(C,3) < EMA(C,21);
CC:= EMA(C,3) > EMA(C,8);
CC1:=EMA(C,3) < EMA(C,8);
STICKLINE(AA,L,H,0,0),COLOR0088EE;{金色}
STICKLINE(AA,CLOSE,OPEN,3,0),COLOR0055AA;
STICKLINE(AA,CLOSE,OPEN,2.8,0),COLOR0066BB;
STICKLINE(AA,CLOSE,OPEN,2.5,0),COLOR0077CC;
STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0088DD;
STICKLINE(AA,CLOSE,OPEN,1.7,0),COLOR0099EE;
STICKLINE(AA,CLOSE,OPEN,1.2,0),COLOR00AAFF;
STICKLINE(AA,CLOSE,OPEN,0.7,0),COLOR00CCFF;
STICKLINE(AA,CLOSE,OPEN,0.2,0),COLOR00FFFF;
STICKLINE(BB,H,L,0,1),COLORGREEN;{绿色}
STICKLINE(BB,C,O,3.2,0),COLOR006600;
STICKLINE(BB,C,O,2.6,0),COLOR008800;
STICKLINE(BB,C,O,1.9,0),COLOR00AA00;
STICKLINE(BB,C,O,1.1,0),COLOR00CC00;
STICKLINE(BB,C,O,0.3,0),COLOR00FF00;
STICKLINE(BB AND CC,H,L,0,1),COLORFF55FF;{紫色}
STICKLINE(BB AND CC,C,O,3.2,0),COLOR880088;
STICKLINE(BB AND CC,C,O,2.6,0),COLORAA00AA;
STICKLINE(BB AND CC,C,O,1.9,0),COLORCC00CC;
STICKLINE(BB AND CC,C,O,1.1,0),COLOREE00EE;
STICKLINE(BB AND CC,C,O,0.3,0),COLORFF44FF;
STICKLINE(AA AND CC1,H,L,0,1),COLORFF8800;{蓝色}
STICKLINE(AA AND CC1,C,O,3.2,0),COLORFF2200;
STICKLINE(AA AND CC1,C,O,2.6,0),COLORFF4400;
STICKLINE(AA AND CC1,C,O,1.9,0),COLORFF6600;
STICKLINE(AA AND CC1,C,O,1.1,0),COLORFF8800;
STICKLINE(AA AND CC1,C,O,0.3,0),COLORFFAA00;
{XS2 }
N2:=102;
M:=7;
UU:=MA((2*CLOSE+HIGH+LOW)/4,5);
买价:=((C-REF(MA5,1))/5+MA5)*1.004;
买条件:=CROSS(C,买价) AND 买价>REF(买价,1);
醉白K买进:IF(买条件,L,H),COLORWHITE,POINTDOT;
STICKLINE(买条件,H,L,0,1),COLORWHITE,LINETHICK2,;
STICKLINE(买条件,O,C,4,1),COLORWHITE,LINETHICK2;
加码价:=((C-REF(MA10,1))/20+MA10)*1.004;
加码条件:=CROSS(C,加码价) AND 加码价>REF(加码价,1);
醉黄K加码:IF(加码条件,L,H),COLORYELLOW,POINTDOT;
STICKLINE(加码条件,H,L,0,1),COLORYELLOW,LINETHICK2;
STICKLINE(加码条件,O,C,4,1),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(1,0.88,5,0,''),COLORRED;
ZK1:(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,COLORBLUE;
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000),COLOR00AAAA,LINETHICK;
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
V5:=SMA(V2*120/FROMOPEN*5,2,1);
V10:=SMA(V5,5,1);
V20:=SMA(V10,5,1);
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
DY2:=REF(V2,1)-DY;
XG2:=C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<ZK1;
B1:=HHV(HIGH,100);
B2:="BIAS.BIAS3 #WEEK";
B3:=MA(B2,10);
A1:=VOL;
A2:=REF(MA(VOL,5),1);
A3:=A1/A2;
A4:=A3>=0.001 AND A3<0.8;
买入:=CROSS(B2,B3) AND WEEKDAY=1 AND A4;
DRAWTEXT(FILTER(买入=1,5),LOW-0.15,'↖卧槽马'),COLORYELLOW;
STICKLINE(买入,O,C,3,0),COLORMAGENTA;
{高抛低吸}
VARA:=(2*CLOSE+HIGH+LOW)/4;
VARB:=IF(YEAR>=2099 AND MONTH>2,0,1);
VARC:=LLV(LOW,5);
VARD:=HHV(HIGH,4);
散户:=EMA((VARA-VARC)/(VARD-VARC)*100,4)*VARB;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VARB;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.006,'←高抛'),COLORGREEN;
{行业属性}
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORLIRED;

通达信卧槽马主图指标公式

 

相关文章