在线检测未来函数

通达信末日成交量指标公式

来源:Internet,编辑:股旁网,2018-03-30

DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);
DRAWGBK(C>0,RGB(0,0,0),RGB(00,0,0),0,'EM',0);
地量:MA(AMOUNT,5)=LLV(MA(AMOUNT,5),250),NODRAW,COLORBLUE;
STICKLINE(AMOUNT AND 地量,0,AMOUNT,6,0),COLORBLUE;
HJ_1:=AMOUNT/REF(AMOUNT,1)>2;
HJ_2:=VOL/REF(MA(VOL,5),1)>3;
HJ_3:=HHV(AMOUNT,0)=AMOUNT;
天量:IF(HJ_3=1,1,0),NODRAW,COLORYELLOW;
爆量:IF(天量=1,0,HJ_2),NODRAW,COLORWHITE;
倍量:IF(天量=1 OR 爆量=1,0,HJ_1),NODRAW,COLORMAGENTA;
堆量:MA(AMOUNT,5)/MA(AMOUNT,250),NODRAW,COLORGRAY;
STICKLINE(AMOUNT AND AMOUNT>REF(AMOUNT,1),0,AMOUNT,2.5,1),COLORRED;
STICKLINE(AMOUNT AND AMOUNT<REF(AMOUNT,1),0,AMOUNT,2.5,0),COLORCYAN;
STICKLINE(地量,0,AMOUNT,2.5,0),COLORBLUE;
STICKLINE(爆量,0,AMOUNT,2.5,0),COLORWHITE;
STICKLINE(倍量,0,AMOUNT,2.5,0),COLORMAGENTA;
STICKLINE(天量,0,AMOUNT,2.5,0),COLORYELLOW;
量比:VOL/REF(MA(VOL,5),1)COLORGREEN;
换手率:VOL/CAPITAL*100,COLORYELLOW;
AM5:MA(AMOUNT,5),COLORWHITE;
AM10:MA(AMOUNT,10),COLORYELLOW;
AM250:MA(AMOUNT,250),COLORCYAN;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:VOL,VOLSTICK;
MA5日:MA(VOLUME,5);
MA60日:MA(VOLUME,60);
LNX:EMA(V,30)*2,LINETHICK2,COLORGREEN;
XG1:=CROSS(MA5日,MA60日);
XG2:=CROSS(MA60日,MA5日);
STICKLINE(XG1,0,VOL,1,0),COLORYELLOW;
STICKLINE(XG2,0,VOL,1,0),COLORGREEN;
DRAWTEXT(XG1,AMOUNT,'★金叉'),COLORYELLOW;
MA1:=MA(AMOUNT,6);
MA2:=MA(AMOUNT,12);
MA3:=MA(AMOUNT,24);
A1:=MA1>MA2 AND MA2>MA3;
A2:=MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA3>REF(MA3,1);
XG:=A1 AND A2;
XGXG:=XG AND NOT(COUNT(REF(XG,1),2));
DRAWTEXT(XGXG,AMOUNT,'★'),COLORWHITE;

通达信末日成交量指标公式

 

相关文章