在线检测未来函数

通达信机散动向分时指标公式

来源:Internet,编辑:股旁网,2018-04-03

A1:=SUM(IF(CLOSE>REF(CLOSE,1),VOL/CAPITAL*100,IF(CLOSE<REF(CLOSE,1),-VOL/CAPITAL*100,0)),0);
成交额:=V*C/100,NODRAW;
A2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A4:=SUM((IF(((成交额/8<20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
A5:=SUM((IF(((成交额/8<20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
A6:=((A2+A3)+A4)+A5;
A7:=IF((ISLASTBAR),((100*A2)/A6),0);
A8:=IF((ISLASTBAR),((100*A3)/A6),0);
A9:=IF((ISLASTBAR),((100*A4)/A6),0);
A10:=IF((ISLASTBAR),((100*A5)/A6),0);
机构买:(A2),LINETHICK6,COLORRED;
机构卖:(A3),LINETHICK6,COLORGREEN;
机构进出:机构买-机构卖,NODRAW;
散户买:(A4),COLOR5555FF;
散户卖:(A5),COLOR55FF55;
强势:=((100*A2)/A6>50);
STICKLINE(强势,机构买*1.02,机构买*1.1,1,0),COLORYELLOW;
拉升:=((100*A2)/A6-(100*A3)/A6)>18 AND (100*A2)/A6-(100*A5)/A6>18;
STICKLINE(拉升,机构买*1.1,机构买*1.2,1,0),COLORCC00FF;
DRAWTEXT(ISLASTBAR=1,机构买*0.95,'●机构买'),LINETHICK2,COLORRED;
DRAWTEXT(ISLASTBAR=1,机构卖*0.95,'○机构卖'),LINETHICK2,COLORFFFF55;
DRAWTEXT(机构进出>0 AND REF(机构进出,1)<=0,机构买*1.02,'●机买'),COLORRED;
DRAWTEXT(机构进出<0 AND REF(机构进出,1)>=0,机构买*0.98,'○机卖'),COLORFFFF55;
Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);
Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));
DRAWICON(CROSS((C/Q2),1.03),机构买,5);
DD1:=1;
AAA1:=STRCAT(STRCAT('机构买入',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖出',CON2STR((100*A3)/A6,0)),'%');
AAA0:=STRCAT(STRCAT('机构总买入',CON2STR((100*(A2-A3))/A6,0)),'%');
AAA3:=STRCAT(STRCAT('散户买入',CON2STR((100*A4)/A6,0)),'%');
AAA4:=STRCAT(STRCAT('散户卖出',CON2STR((100*A5)/A6,0)),'%');
AAA5:=STRCAT(STRCAT('散户总买入',CON2STR((100*(A4-A5))/A6,0)),'%');
DRAWTEXT_FIX(DD1=1,0.001,0.05,0,AAA1),COLORRED;
DRAWTEXT_FIX(DD1=1,0.001,0.15,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0.001,0.25,0,AAA3),COLORRED;
DRAWTEXT_FIX(DD1=1,0.001,0.35,0,AAA4),COLORGREEN;
DRAWTEXT_FIX(DD1=1,0.001,0.45,0,AAA0),LINETHICK5,COLORYELLOW;
DRAWTEXT_FIX(DD1=1,0.001,0.55,0,AAA5),LINETHICK5,COLORCYAN;
资金流入:A2+A4,COLORRED,NODRAW;
资金流出:A3+A5,NODRAW;
资金:=资金流入-资金流出,COLORYELLOW;
资金差:资金流入-资金流出,COLORYELLOW;
WW:=资金>0;
QQ:=资金<0;
STICKLINE(资金 AND WW,资金,0,0.0011,0),COLORRED;
STICKLINE(资金 AND QQ,资金,0,0.0011,0),COLORCYAN;
换手:=VOL/CAPITAL*100;
主动买盘:=BUYVOL,COLORLIRED,NODRAW;
主动卖盘:=SELLVOL,COLORLIBLUE,NODRAW;
买卖总量:=BUYVOL+SELLVOL,COLORYELLOW,NODRAW;
主动买盘%:=BUYVOL/买卖总量*100;
主动卖盘%:=SELLVOL/买卖总量*100;
DRAWRECTREL(165,30,405,118,RGB(0,0,255));
DRAWRECTREL(165,30,165+2.4*CONST(主动买盘%),118,RGB(255,0,0));
DRAWTEXT_FIX(1,0.088,0.03,0,STRCAT(STRCAT('主动买盘',CON2STR(主动买盘%,2)),'%')),COLORYELLOW;
DRAWTEXT_FIX(1,0.41,0.03,0,STRCAT(STRCAT('主动卖盘',CON2STR(主动卖盘%,2)),'%')),COLORGREEN;
BB:=0,COLORWHITE;

通达信机散动向分时指标公式

 

相关文章