在线检测未来函数

通达信红箭出击指标公式

来源:Internet,编辑:股旁网,2018-04-09

VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,55),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
VAR9:=EMA(CLOSE,5);
VAR10:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*(-10);
VAR11:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7*(-1);
VAR12:=EMA(CLOSE,5)*(-1);
STICKLINE(VAR8>REF(VAR8,1),0,VAR8,6,1),COLOR10FFFF,LINETHICK3;
STICKLINE(VAR11>REF(VAR11,1),0,VAR11,6,1),COLORFFF810;
VA:=(2*C+H+L)/4;
VB:=LLV(L,5);
VC:=HHV(H,5);
底部红箭:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,23,0),LINETHICK2,COLORFF00FF;
DRAWICON(底部红箭=23,23,1),LINETHICK2,COLORFFFFFF;
RSV:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
QVAR1A:=((HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21)))*(100)-10;
QVAR1B:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21)))*(100);
QVAR1C:=SMA(QVAR1B,13,8);
QVAR1D:=SMA(QVAR1A,21,8);
A1 := (EMA(CLOSE,4)+MA(CLOSE,8)+MA(CLOSE,16))/3;
A2 := (EMA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/3;
A3 := (EMA(CLOSE,9)+MA(CLOSE,18)+MA(CLOSE,36))/3;
A4 := (EMA(CLOSE,13)+MA(CLOSE,26)+MA(CLOSE,52))/3;
A5 := (EMA(CLOSE,18)+MA(CLOSE,36)+MA(CLOSE,72))/3;
A6 := (EMA(CLOSE,24)+MA(CLOSE,48)+MA(CLOSE,96))/3;
OPEN<A1 AND OPEN<A2 AND OPEN<A3 AND OPEN<A4 AND OPEN<A5 AND OPEN<A6 AND
CLOSE>A1 AND CLOSE>A2 AND CLOSE>A3 AND CLOSE>A4 AND CLOSE>A5 AND CLOSE>A6;
红箭出击:(BARSLASTCOUNT(底部红箭>0)=4)*30;

通达信红箭出击指标公式

 

相关文章