在线检测未来函数

通达信庄进庄撤指标公式

来源:Internet,编辑:股旁网,2018-04-08

N:=9;
M1:=3;
M2:=3;
N0:=9;
M10:=3;
M20:=3;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLORRED;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLOR000055;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.6,0 ),COLOR000077;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0 ),COLOR000099;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,1.5,0 ),COLOR0000BB;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.9,0 ),COLOR0000DD;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.3,0 ),COLOR0000FF;
洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLORGREEN;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR005500;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.6,0),COLOR007700;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR009900;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,1.5,0),COLOR00BB00;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.9,0),COLOR00DD00;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.3,0),COLOR00FF00;
VAR12:=SMA(ABS(VAR1-H),13,1)/SMA(MAX(VAR1-H,0),10,1);
VAR13:=EMA(VAR12,10);
VAR14:=HHV(H,33);
VAR15:=EMA(IF(H>=VAR14,VAR13,0),3);
冲顶:IF(VAR15>REF(VAR15,1),VAR15,0),COLORFF00FF;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,3,0),COLORFF00FF;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,3,0 ),COLOR550055;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,2.6,0 ),COLOR770077;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,2.1,0 ),COLOR990099;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,1.5,0 ),COLORBB00BB;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,0.9,0 ),COLORDD00DD;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,0.3,0 ),COLORFF00FF;
主力出场:IF(VAR15<REF(VAR15,1),VAR15,0),COLORYELLOW;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,3,0 ),COLORYELLOW;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,3,0),COLOR005555;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,2.6,0),COLOR007777;
STICKLINE(VAR15<REF(VAR5,1),0,VAR15,2.1,0),COLOR009999;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,1.5,0),COLOR00BBBB;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,0.9,0),COLOR00DDDD;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,0.3,0),COLOR00FFFF;
A1:=REF(CLOSE,2);
A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100;
波段介入点:IF(A2<19,19,0)*5,COLORGREEN;
R1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
R2:=SMA(R1,9,1)+100;
R3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
R4:=SMA(R3,3,1);
R5:=SMA(R4,3,1)+100;
R6:=R5-R2;
短线操盘:IF(R6>0,R6-0,0),COLORRED,POINTDOT;
STICKLINE(REF(短线操盘,1)<短线操盘,短线操盘,REF(短线操盘,1),2,1),COLORRED;
STICKLINE(REF(短线操盘,1)>短线操盘,短线操盘,REF(短线操盘,1),2,1),COLORGREEN;
DRAWTEXT(短线操盘=0,-10,'操'),COLORRED;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*10;
K:SMA(RSV,M1,1),LINETHICK2,NODRAW;
D:SMA(K,M2,1),LINETHICK2,NODRAW;
J:3*K-2*D,LINETHICK2,NODRAW;
KDJ1:=REF(COUNT(J<REF(J,1),5)>=3,1) AND REF(J,1)<15;
KDJ2:=J>REF(J,1);
反转:IF(FILTER(KDJ1 AND KDJ2,3),60,0),COLORFF9900,LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARC:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARD:=BARSCOUNT(CLOSE);
底部雷达:(VARB< 20 AND VARC< 30 AND VARD> 20)*59,LINETHICK2,COLORYELLOW;
DRAWTEXT(VARB< 20 AND VARC< 30 AND VARD> 20,90,'多'),COLORWHITE;
RSV55:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K055:=SMA(RSV55,3,1);
K55:=K055;D55:=SMA(K055,2,1);
多头:(3*K055-2*D55),LINETHICK2,NODRAW;
多势:MA(多头,2),LINETHICK2,NODRAW;
MAV:=(2*C+H+L)/4;
VAR155:=LLV(LOW,21);
VAR255:=HHV(HIGH,21);
能量: EMA((MAV-VAR155)/(VAR255-VAR155)*100,8),NODRAW;
动量: EMA(0.667*REF(能量,1)+0.333*能量,1),NODRAW;
SJ:=3*能量-2*动量;
平衡:50,POINTDOT,COLORFF9999,LINETHICK2;
风险:70,POINTDOT,COLORF0F000,LINETHICK2;
卖出:90,COLORWHITE,LINETHICK1;
底部:(SJ<18)*80,COLORRED,LINETHICK2;
DRAWTEXT(SJ<18,90,'底'),COLORWHITE;
攻击:=IF(底部,0,20),LINETHICK2,COLORYELLOW;
DRAWTEXT(CROSS(多头,能量) AND 50>多头 ,多头-5,'买'),COLORYELLOW,LINETHICK2;
DRAWTEXT(CROSS(多势,多头) AND 多头>45,短线操盘+11,'卖'),COLOR00FF00,LINETHICK1;
DRAWTEXT(CROSS(多势,多头) AND 多头<45,多头,'买'),COLOR00FF00,LINETHICK1;
DRAWTEXT(CROSS(卖出,多头) AND 多头>风险,多头+18,'逃'),COLORFFFF00,LINETHICK2;
DRAWTEXT(CROSS(多头,攻击) AND 多头>能量,多头-10,'短追'),COLORWHITE,LINETHICK2;

通达信庄进庄撤指标公式

 

相关文章