在线检测未来函数

通达信高量梯主图指标公式

来源:Internet,编辑:股旁网,2018-04-11

VAR1:=CONST(HHV(REF(HIGH,1),240));
VAR2:=CONST(LLV(REF(LOW,1),240));
VAR3:=VAR1-VAR2;
VAR4:=LOW-VAR3*0.03;
VAR5:=HIGH+VAR3*0.03;
VAR6:=CLOSE>500;
VAR7:=MAX(CLOSE,OPEN);
VAR8:=MIN(CLOSE,OPEN);
VAR9:=0;
VAR10:=1;
VAR11:=IF(VAR6,HIGH,VAR7);
VAR12:=IF(VAR6,LOW,VAR8);
VAR13:=IF(CLOSE>OPEN,IF(VAR10=0,LOW,VAR12),IF(VAR10=0,HIGH,VAR11));
VAR14:=2/1000;
VAR15:=CURRBARSCOUNT;
VAR16:=120;
VAR17:=VAR15<=VAR16;
VAR18:=LOW;
VAR19:=IF(VAR9=0,VAR18,REF(VAR9,VAR9));
基准价:IF(VAR17,CONST(VAR19),DRAWNULL),DOTLINE,COLORRED;
VAR20:=基准价;
VAR21:=VAR20*VAR14;
VAR22:=ABS(LOW-VAR20)<=VAR21;
VAR23:=ABS(OPEN-VAR20)<=VAR21;
VAR24:=ABS(CLOSE-VAR20)<=VAR21;
VAR25:=ABS(HIGH-VAR20)<=VAR21;
VAR26:=VAR22 OR VAR23 OR VAR24 OR VAR25 AND VAR17 AND VAR15!=1;
VAR27:=COUNT(VAR26,VAR16);
精准点个数:IF(VAR27>0,VAR27+1,0),NODRAW,COLORRED;
VAR28:=AMOUNT/VOL/100;
VAR29:=CLOSE>OPEN AND REF(CLOSE,1)>VAR28 AND CLOSE>VAR28 AND CLOSE<300;
STICKLINE(VAR29,OPEN,CLOSE,1,0),COLORLICYAN;
VAR30:=OPEN>CLOSE AND CLOSE<VAR28 AND VAR28>REF(CLOSE,1);
STICKLINE(VAR30,OPEN,CLOSE,1,0),COLORRED;
VAR31:=VOL>REF(VOL,1)*0.95 AND VOL<REF(VOL,1)*1.05;
VAR32:=WINNER(CLOSE)-WINNER(OPEN)>=0.2 AND VAR31;
STICKLINE(VAR32,OPEN,CLOSE,1,0),COLORBLUE;
VAR33:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR34:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR33>=4.945;
VAR35:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR33<=(-4.945);
涨停价:IF(VAR34,REF(CLOSE,1)*1.05,REF(CLOSE,1)*1.1),NODRAW,COLORRED;
跌停价:IF(VAR35,REF(CLOSE,1)*0.95,REF(CLOSE,1)*0.9),NODRAW,COLORGREEN;
VAR36:=REF(CLOSE,1);
VAR37:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR37,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(VAR37,OPEN,CLOSE,1,0),COLORMAGENTA;
VAR38:=CLOSE=DTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR38,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(VAR38,HIGH,LOW,0,1),COLORGREEN;
VAR39:=HHV(VOL,10);
VAR40:=BARSLAST(VAR39=VOL);
当前高量顶价:DRAWLINE(VAR40=0 AND VAR40<=10,MIN(CLOSE,OPEN),REF(VAR40=0,1),REF(MIN(CLOSE,OPEN),1),1),COLORMAGENTA;
当前高量底价价:DRAWLINE(VAR40=0 AND VAR40<=10,MAX(CLOSE,OPEN),REF(VAR40=0,1),REF(MAX(CLOSE,OPEN),1),1),COLORBROWN;
VAR41:=OPEN-(OPEN-CLOSE)/3;
VAR42:=(OPEN+CLOSE)/2;
VAR43:=OPEN-2*(OPEN-CLOSE)/3;
STICKLINE((OPEN+CLOSE)/2 AND CLOSE/REF(CLOSE,1)>=1.035 OR REF(CLOSE,1)/CLOSE>=1.035,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,3,0),COLORBLUE;
流通市值:FINANCE(40)/100000000,NODRAW;
MA5角度:ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.142,NODRAW,COLORRED;
循环年位置:(CLOSE-LLV(CLOSE,225))/(HHV(CLOSE,225)-LLV(CLOSE,225))*100,NODRAW,COLORGREEN;
VAR44:=HHV(VOL,10);
VAR45:=BARSLAST(VAR44=VOL);
VAR46:=CROSS(REF(MAX(CLOSE,OPEN),VAR45),CLOSE);
STICKLINE(VAR46,MAX(CLOSE,OPEN)*1.02,MIN(CLOSE,OPEN)*0.98,0,1),COLORRED;
STICKLINE(VAR46,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,10,0),COLORRED;
DRAWICON(OPEN>REF(MAX(CLOSE,OPEN),1) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND CLOSE>MA(CLOSE,5),LOW*0.97,11);
VAR47:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5);
VAR48:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3) AND REFX(CLOSE,8)<REFX(CLOSE,4);
VAR49:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6);
VAR50:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3);
VAR51:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7);
VAR52:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2);
VAR53:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8);
VAR54:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1);
VAR55:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9);
VAR56:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE;
VAR57:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10);
VAR58:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1);
VAR59:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11);
VAR60:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2);
VAR61:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12);
VAR62:=REFX(CLOSE,1)<REF(CLOSE,3);
VAR63:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12) AND REF(CLOSE,9)>REF(CLOSE,13);
VAR64:=IF(PERIOD<4,LOW*(1-(PERIOD+1)/10*0.01),LOW*0.98);
VAR65:=IF(PERIOD<4,HIGH*(1+(PERIOD+1)/10*0.01),HIGH*1.05);
VAR66:=CURRBARSCOUNT-1;
DRAWNUMBER(VAR47 AND (VAR48 OR VAR66=0 OR (VAR66=1 AND VAR62) OR (VAR66=2 AND VAR60) OR (VAR66=3 AND VAR58) OR (VAR66=4 AND VAR56) OR (VAR66=5 AND VAR54) OR (VAR66=6 AND VAR52) OR (VAR66=7 AND VAR50)),VAR64,1),COLORMAGENTA;
DRAWNUMBER(VAR49 AND (VAR50 OR VAR66=0 OR (VAR66=1 AND VAR62) OR (VAR66=2 AND VAR60) OR (VAR66=3 AND VAR58) OR (VAR66=4 AND VAR56) OR (VAR66=5 AND VAR54) OR (VAR66=6 AND VAR52)),VAR64,2),COLORMAGENTA;
DRAWNUMBER(VAR51 AND (VAR52 OR VAR66=0 OR (VAR66=1 AND VAR62) OR (VAR66=2 AND VAR60) OR (VAR66=3 AND VAR58) OR (VAR66=4 AND VAR56) OR (VAR66=5 AND VAR54)),VAR64,3),COLORMAGENTA;
DRAWNUMBER(VAR53 AND (VAR54 OR VAR66=0 OR (VAR66=1 AND VAR62) OR (VAR66=2 AND VAR60) OR (VAR66=3 AND VAR58) OR (VAR66=4 AND VAR56)),VAR64,4),COLORMAGENTA;
DRAWNUMBER(VAR55 AND (VAR56 OR VAR66=0 OR (VAR66=1 AND VAR62) OR (VAR66=2 AND VAR60) OR (VAR66=3 AND VAR58)),VAR64,5),COLORMAGENTA;
DRAWNUMBER(VAR57 AND (VAR58 OR VAR66=0 OR (VAR66=1 AND VAR62) OR (VAR66=2 AND VAR60)),VAR64,6),COLORMAGENTA;
DRAWNUMBER(VAR59 AND (VAR60 OR VAR66=0 OR (VAR66=1 AND VAR62)),VAR64,7),COLORMAGENTA;
DRAWNUMBER(VAR61 AND (VAR62 OR VAR66<1),VAR64,8),COLORMAGENTA;
DRAWNUMBER(VAR63,VAR64,9),COLORGREEN;
VAR67:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5);
VAR68:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3) AND REFX(CLOSE,8)>REFX(CLOSE,4);
VAR69:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6);
VAR70:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3);
VAR71:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7);
VAR72:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2);
VAR73:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8);
VAR74:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1);
VAR75:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9);
VAR76:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE;
VAR77:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10);
VAR78:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1);
VAR79:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11);
VAR80:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2);
VAR81:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12);
VAR82:=REFX(CLOSE,1)>REF(CLOSE,3);
VAR83:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12) AND REF(CLOSE,9)<REF(CLOSE,13);
DRAWNUMBER(VAR67 AND (VAR68 OR VAR66=0 OR (VAR66=1 AND VAR82) OR (VAR66=2 AND VAR80) OR (VAR66=3 AND VAR78) OR (VAR66=4 AND VAR76) OR (VAR66=5 AND VAR74) OR (VAR66=6 AND VAR72) OR (VAR66=7 AND VAR70)),VAR65,1),COLORMAGENTA;
DRAWNUMBER(VAR69 AND (VAR70 OR VAR66=0 OR (VAR66=1 AND VAR82) OR (VAR66=2 AND VAR80) OR (VAR66=3 AND VAR78) OR (VAR66=4 AND VAR76) OR (VAR66=5 AND VAR74) OR (VAR66=6 AND VAR72)),VAR65,2),COLORMAGENTA;
DRAWNUMBER(VAR71 AND (VAR72 OR VAR66=0 OR (VAR66=1 AND VAR82) OR (VAR66=2 AND VAR80) OR (VAR66=3 AND VAR78) OR (VAR66=4 AND VAR76) OR (VAR66=5 AND VAR74)),VAR65,3),COLORMAGENTA;
DRAWNUMBER(VAR73 AND (VAR74 OR VAR66=0 OR (VAR66=1 AND VAR82) OR (VAR66=2 AND VAR80) OR (VAR66=3 AND VAR78) OR (VAR66=4 AND VAR76)),VAR65,4),COLORMAGENTA;
DRAWNUMBER(VAR75 AND (VAR76 OR VAR66=0 OR (VAR66=1 AND VAR82) OR (VAR66=2 AND VAR80) OR (VAR66=3 AND VAR78)),VAR65,5),COLORMAGENTA;
DRAWNUMBER(VAR77 AND (VAR78 OR VAR66=0 OR (VAR66=1 AND VAR82) OR (VAR66=2 AND VAR80)),VAR65,6),COLORMAGENTA;
DRAWNUMBER(VAR79 AND (VAR80 OR VAR66=0 OR (VAR66=1 AND VAR82)),VAR65,7),COLORMAGENTA;
DRAWNUMBER(VAR81 AND (VAR82 OR VAR66<1),VAR65,8),COLORMAGENTA;
DRAWNUMBER(VAR83,VAR65,9),COLORGREEN;

通达信高量梯主图指标公式

 

相关文章