在线检测未来函数

通达信左峰梯主图指标公式

来源:Internet,编辑:股旁网,2018-04-11

VAR1:=CONST(HHV(REF(HIGH,1),240));
VAR2:=CONST(LLV(REF(LOW,1),240));
VAR3:=VAR1-VAR2;
VAR4:=LOW-VAR3*0.03;
VAR5:=HIGH+VAR3*0.03;
VAR6:=CLOSE>500;
VAR7:=MAX(CLOSE,OPEN);
VAR8:=MIN(CLOSE,OPEN);
VAR9:=0;
VAR10:=1;
VAR11:=IF(VAR6,HIGH,VAR7);
VAR12:=IF(VAR6,LOW,VAR8);
VAR13:=IF(CLOSE>OPEN,IF(VAR10=0,LOW,VAR12),IF(VAR10=0,HIGH,VAR11));
VAR14:=2/1000;
VAR15:=CURRBARSCOUNT;
VAR16:=120;
VAR17:=VAR15<=VAR16;
VAR18:=LOW;
VAR19:=IF(VAR9=0,VAR18,REF(VAR9,VAR9));
基准价:IF(VAR17,CONST(VAR19),DRAWNULL),DOTLINE,COLORRED;
VAR20:=基准价;
VAR21:=VAR20*VAR14;
VAR22:=ABS(LOW-VAR20)<=VAR21;
VAR23:=ABS(OPEN-VAR20)<=VAR21;
VAR24:=ABS(CLOSE-VAR20)<=VAR21;
VAR25:=ABS(HIGH-VAR20)<=VAR21;
VAR26:=VAR22 OR VAR23 OR VAR24 OR VAR25 AND VAR17 AND VAR15!=1;
VAR27:=COUNT(VAR26,VAR16);
精准点个数:IF(VAR27>0,VAR27+1,0),NODRAW,COLORRED;
VAR28:=AMOUNT/VOL/100;
VAR29:=CLOSE>OPEN AND REF(CLOSE,1)>VAR28 AND CLOSE>VAR28 AND CLOSE<300;
STICKLINE(VAR29,OPEN,CLOSE,1,0),COLORLICYAN;
VAR30:=OPEN>CLOSE AND CLOSE<VAR28 AND VAR28>REF(CLOSE,1);
STICKLINE(VAR30,OPEN,CLOSE,1,0),COLORRED;
VAR31:=VOL>REF(VOL,1)*0.95 AND VOL<REF(VOL,1)*1.05;
VAR32:=WINNER(CLOSE)-WINNER(OPEN)>=0.2 AND VAR31;
STICKLINE(VAR32,OPEN,CLOSE,1,0),COLORBLUE;
VAR33:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
VAR34:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR33>=4.945;
VAR35:=NAMELIKE(1) OR NAMELIKE(2) OR NAMELIKE(3) AND VAR33<=(-4.945);
涨停价:IF(VAR34,REF(CLOSE,1)*1.05,REF(CLOSE,1)*1.1),NODRAW,COLORRED;
跌停价:IF(VAR35,REF(CLOSE,1)*0.95,REF(CLOSE,1)*0.9),NODRAW,COLORGREEN;
VAR36:=REF(CLOSE,1);
VAR37:=CLOSE=ZTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR37,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(VAR37,OPEN,CLOSE,1,0),COLORMAGENTA;
VAR38:=CLOSE=DTPRICE(REF(CLOSE,1),0.1);
STICKLINE(VAR38,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(VAR38,HIGH,LOW,0,1),COLORGREEN;
VAR39:=CLOSE;
VAR40:=REF(VAR39,10)=HHV(VAR39,2*10+1);
VAR41:=FILTER(VAR40,10);
VAR42:=BACKSET(VAR41,10+1);
VAR43:=FILTER(VAR42,10);
VAR44:=REF(VAR39,10)=LLV(VAR39,2*10+1);
VAR45:=FILTER(VAR44,10);
VAR46:=BACKSET(VAR45,10+1);
VAR47:=FILTER(VAR46,10);
VAR48:=REF(CLOSE,BARSLAST(VAR47));
VAR49:=REF(CLOSE,BARSLAST(VAR43));
STICKLINE(CLOSE,VAR49,VAR49,8,0),COLORMAGENTA;
STICKLINE(CLOSE,VAR48,VAR48,8,0),COLORRED;
STICKLINE(VAR43,CLOSE,OPEN,1,0),COLORBROWN;
STICKLINE(VAR43,CLOSE,OPEN,1,0),COLORBROWN;
STICKLINE(VAR47,CLOSE,OPEN,1,0),COLORBLUE;
STICKLINE(VAR47,CLOSE,OPEN,1,0),COLORBLUE;
VAR50:=OPEN-(OPEN-CLOSE)/3;
VAR51:=(OPEN+CLOSE)/2;
VAR52:=OPEN-2*(OPEN-CLOSE)/3;
STICKLINE((OPEN+CLOSE)/2 AND CLOSE/REF(CLOSE,1)>=1.035 OR REF(CLOSE,1)/CLOSE>=1.035,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,3,0),COLORBROWN;
VAR53:=MAX(CLOSE,OPEN);
VAR54:=MIN(CLOSE,OPEN);
VAR55:=VAR54-0.01>=REF(VAR53,1);
流通市值:FINANCE(40)/100000000,NODRAW;
MA5角度:ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*180/3.142,NODRAW,COLORRED;
循环年位置:(CLOSE-LLV(CLOSE,225))/(HHV(CLOSE,225)-LLV(CLOSE,225))*100,NODRAW,COLORGREEN;
VAR56:=HHV(VOL,10);
VAR57:=BARSLAST(VAR56=VOL);
VAR58:=CROSS(REF(MAX(CLOSE,OPEN),VAR57),CLOSE);
STICKLINE(VAR58,MAX(CLOSE,OPEN)*1.02,MIN(CLOSE,OPEN)*0.98,0,1),COLORRED;
STICKLINE(VAR58,(OPEN+CLOSE)/2,(OPEN+CLOSE)/2,10,0),COLORRED;
DRAWICON(OPEN>REF(MAX(CLOSE,OPEN),1) AND CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND CLOSE>MA(CLOSE,5),LOW*0.97,11);
VAR59:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5);
VAR60:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3) AND REFX(CLOSE,8)<REFX(CLOSE,4);
VAR61:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6);
VAR62:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2) AND REFX(CLOSE,7)<REFX(CLOSE,3);
VAR63:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7);
VAR64:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1) AND REFX(CLOSE,6)<REFX(CLOSE,2);
VAR65:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8);
VAR66:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE AND REFX(CLOSE,5)<REFX(CLOSE,1);
VAR67:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9);
VAR68:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1) AND REFX(CLOSE,4)<CLOSE;
VAR69:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10);
VAR70:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2) AND REFX(CLOSE,3)<REF(CLOSE,1);
VAR71:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11);
VAR72:=REFX(CLOSE,1)<REF(CLOSE,3) AND REFX(CLOSE,2)<REF(CLOSE,2);
VAR73:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12);
VAR74:=REFX(CLOSE,1)<REF(CLOSE,3);
VAR75:=CLOSE<REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12) AND REF(CLOSE,9)>REF(CLOSE,13);
VAR76:=IF(PERIOD<4,LOW*(1-(PERIOD+1)/10*0.01),LOW*0.98);
VAR77:=IF(PERIOD<4,HIGH*(1+(PERIOD+1)/10*0.01),HIGH*1.05);
VAR78:=CURRBARSCOUNT-1;
DRAWNUMBER(VAR59 AND (VAR60 OR VAR78=0 OR (VAR78=1 AND VAR74) OR (VAR78=2 AND VAR72) OR (VAR78=3 AND VAR70) OR (VAR78=4 AND VAR68) OR (VAR78=5 AND VAR66) OR (VAR78=6 AND VAR64) OR (VAR78=7 AND VAR62)),VAR76,1),COLORMAGENTA;
DRAWNUMBER(VAR61 AND (VAR62 OR VAR78=0 OR (VAR78=1 AND VAR74) OR (VAR78=2 AND VAR72) OR (VAR78=3 AND VAR70) OR (VAR78=4 AND VAR68) OR (VAR78=5 AND VAR66) OR (VAR78=6 AND VAR64)),VAR76,2),COLORMAGENTA;
DRAWNUMBER(VAR63 AND (VAR64 OR VAR78=0 OR (VAR78=1 AND VAR74) OR (VAR78=2 AND VAR72) OR (VAR78=3 AND VAR70) OR (VAR78=4 AND VAR68) OR (VAR78=5 AND VAR66)),VAR76,3),COLORMAGENTA;
DRAWNUMBER(VAR65 AND (VAR66 OR VAR78=0 OR (VAR78=1 AND VAR74) OR (VAR78=2 AND VAR72) OR (VAR78=3 AND VAR70) OR (VAR78=4 AND VAR68)),VAR76,4),COLORMAGENTA;
DRAWNUMBER(VAR67 AND (VAR68 OR VAR78=0 OR (VAR78=1 AND VAR74) OR (VAR78=2 AND VAR72) OR (VAR78=3 AND VAR70)),VAR76,5),COLORMAGENTA;
DRAWNUMBER(VAR69 AND (VAR70 OR VAR78=0 OR (VAR78=1 AND VAR74) OR (VAR78=2 AND VAR72)),VAR76,6),COLORMAGENTA;
DRAWNUMBER(VAR71 AND (VAR72 OR VAR78=0 OR (VAR78=1 AND VAR74)),VAR76,7),COLORMAGENTA;
DRAWNUMBER(VAR73 AND (VAR74 OR VAR78<1),VAR76,8),COLORMAGENTA;
DRAWNUMBER(VAR75,VAR76,9),COLORGREEN;
VAR79:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)<REF(CLOSE,5);
VAR80:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3) AND REFX(CLOSE,8)>REFX(CLOSE,4);
VAR81:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)<REF(CLOSE,6);
VAR82:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2) AND REFX(CLOSE,7)>REFX(CLOSE,3);
VAR83:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)<REF(CLOSE,7);
VAR84:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1) AND REFX(CLOSE,6)>REFX(CLOSE,2);
VAR85:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)<REF(CLOSE,8);
VAR86:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE AND REFX(CLOSE,5)>REFX(CLOSE,1);
VAR87:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)<REF(CLOSE,9);
VAR88:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1) AND REFX(CLOSE,4)>CLOSE;
VAR89:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)<REF(CLOSE,10);
VAR90:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2) AND REFX(CLOSE,3)>REF(CLOSE,1);
VAR91:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)<REF(CLOSE,11);
VAR92:=REFX(CLOSE,1)>REF(CLOSE,3) AND REFX(CLOSE,2)>REF(CLOSE,2);
VAR93:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)<REF(CLOSE,12);
VAR94:=REFX(CLOSE,1)>REF(CLOSE,3);
VAR95:=CLOSE>REF(CLOSE,4) AND REF(CLOSE,1)>REF(CLOSE,5) AND REF(CLOSE,2)>REF(CLOSE,6) AND REF(CLOSE,3)>REF(CLOSE,7) AND REF(CLOSE,4)>REF(CLOSE,8) AND REF(CLOSE,5)>REF(CLOSE,9) AND REF(CLOSE,6)>REF(CLOSE,10) AND REF(CLOSE,7)>REF(CLOSE,11) AND REF(CLOSE,8)>REF(CLOSE,12) AND REF(CLOSE,9)<REF(CLOSE,13);
DRAWNUMBER(VAR79 AND (VAR80 OR VAR78=0 OR (VAR78=1 AND VAR94) OR (VAR78=2 AND VAR92) OR (VAR78=3 AND VAR90) OR (VAR78=4 AND VAR88) OR (VAR78=5 AND VAR86) OR (VAR78=6 AND VAR84) OR (VAR78=7 AND VAR82)),VAR77,1),COLORMAGENTA;
DRAWNUMBER(VAR81 AND (VAR82 OR VAR78=0 OR (VAR78=1 AND VAR94) OR (VAR78=2 AND VAR92) OR (VAR78=3 AND VAR90) OR (VAR78=4 AND VAR88) OR (VAR78=5 AND VAR86) OR (VAR78=6 AND VAR84)),VAR77,2),COLORMAGENTA;
DRAWNUMBER(VAR83 AND (VAR84 OR VAR78=0 OR (VAR78=1 AND VAR94) OR (VAR78=2 AND VAR92) OR (VAR78=3 AND VAR90) OR (VAR78=4 AND VAR88) OR (VAR78=5 AND VAR86)),VAR77,3),COLORMAGENTA;
DRAWNUMBER(VAR85 AND (VAR86 OR VAR78=0 OR (VAR78=1 AND VAR94) OR (VAR78=2 AND VAR92) OR (VAR78=3 AND VAR90) OR (VAR78=4 AND VAR88)),VAR77,4),COLORMAGENTA;
DRAWNUMBER(VAR87 AND (VAR88 OR VAR78=0 OR (VAR78=1 AND VAR94) OR (VAR78=2 AND VAR92) OR (VAR78=3 AND VAR90)),VAR77,5),COLORMAGENTA;
DRAWNUMBER(VAR89 AND (VAR90 OR VAR78=0 OR (VAR78=1 AND VAR94) OR (VAR78=2 AND VAR92)),VAR77,6),COLORMAGENTA;
DRAWNUMBER(VAR91 AND (VAR92 OR VAR78=0 OR (VAR78=1 AND VAR94)),VAR77,7),COLORMAGENTA;
DRAWNUMBER(VAR93 AND (VAR94 OR VAR78<1),VAR77,8),COLORMAGENTA;
DRAWNUMBER(VAR95,VAR77,9),COLORGREEN;

通达信左峰梯主图指标公式

 

相关文章