在线检测未来函数

通达信斩妖宝刀指标公式

来源:Internet,编辑:股旁网,2018-04-12

X:=EMA(C,2)-EMA(C,7);
STICKLINE(X>0,0,-50,8,0),COLOR111233;
STICKLINE(X<=0,0,-50,8,0),COLOR333311;
买牛区:IF(REF(X,1)<-0 AND X>0,0,-50),COLORRED;
卖牛区:=IF(REF(X,1)>=0 AND X<0,-50,0),COLORCYAN;
VAR2N:=1;
V1:=(MA(((100 * (CLOSE- LLV(CLOSE,34))) / (HHV(HIGH,34)- LLV(LOW,34))),5)- 20);
V2:=(2 * ABS(V1));
空方:(0 - (IF((V1 < 0),V2,0) * VAR2N))COLORGRAY,LINESTICK;
LOWVK:=LLV(LOW,9);
HIGHVK:=HHV(HIGH,9);
RSVK:=EMA((CLOSE-LOWVK)/(HIGHVK-LOWVK)*100,3);
KK:=EMA(RSVK,3)COLORWHITE;
DK:=MA(KK,3)COLORYELLOW;
RSVQ:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
KQ:=SMA(RSVQ,3,1)COLORWHITE;
DQ:=SMA(KQ,3,1)COLORYELLOW;
J:((3 * KQ) - (2 * DQ))COLOR9F5F9F;
顶:100,COLORFF00FF;
低位金叉跟进:20,COLOR567FF0,POINTDOT,LINETHICK1;
高位死叉小心:80,COLORGREEN,LINETHICK1;
IF(J<0,J,DRAWNULL),COLORRED,LINETHICK3;
IF(KK>90,KK,DRAWNULL),COLORGREEN,LINETHICK3;
IF(DK>85,DK,DRAWNULL),COLORGREEN,LINETHICK3;
DRAWTEXT(FILTER(COUNT(KK>90 OR DK>85 AND(CROSS(DK,KK)),12)=2,8)AND CROSS(DK,KK),DK+10,'已超买'),COLORGREEN;
DRAWTEXT(FILTER(CROSS(DK,KK)AND NOT(DK<20) AND J>0.2,5),DK+0.09,'死叉卖,低位金叉前不买');
N2:=7;
LCA:=REF(CLOSE,1);
XQ:=SMA(MAX(CLOSE-LCA,0),N2,1)/SMA(ABS(CLOSE-LCA),N2,1)*100,COLORYELLOW,LINETHICK1;
魔鬼:=DRAWLINE(XQ>=HHV(XQ,N2),XQ,XQ<=LLV(XQ,N2),XQ,1),COLOR00FF00;
魔王:=DRAWLINE(XQ>=HHV(XQ,N2),XQ,XQ<=LLV(XQ,N2),1,XQ),COLOR00FF00;
TJ0:=XQ=魔王;
TJ1:=XQ=魔鬼;
TJ2:=XQ<REF(XQ,1);
TJ3:=XQ>REF(1,XQ);
JRS1:=DRAWICON(TJ1 AND TJ2,XQ,1);
JRS2:=DRAWICON(TJ0 AND TJ3,XQ,2);
DRAWICON(FILTER(JRS2>0,1),98,2);
MA5:=MA(C,5);
MA8:=MA(C,8);
MA24:=MA(C,24);
MA72:=MA(C,72);
Q1:=MA(V,5);
Q2:=MA(V,50);
Q:=Q1 > REF(Q1,1);
VARC:=1=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG
(3,5),2)<=REF(ZIG(3,5),3)){AND (MA(C,5)-L)/L>0.1};
VARD:=1=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG
(3,5),2)>=REF(ZIG(3,5),3)){ AND (H-MA(C,5))/MA(C,5)>0.1};
STICKLINE((VARC=1),(-8),0,2,0),COLOR0000FF;
STICKLINE((VARD=1),8,0,2,0),COLOR00FF00;
N:=5;
VARQ1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VARZ:=8,COLORGREEN,LINETHICK0;
上升在即:IF(CROSS(VARQ1,VARZ) AND (VARC OR REF(VARC,1)
OR REF(VARC,2) ),60,0),STICK,COLORRED,LINETHICK3;
专吸庄血:IF(VARQ1<=8,25,0),STICK,COLORWHITE,LINETHICK2;
DRAWICON(VARC ,-0.1,1);
DRAWICON(COUNT(VARC,3)=1 AND 上升在即,-0.1,13);
VARQ:=(CLOSE*2+HIGH+LOW)/4;
SK1:= EMA(VARQ,13)-EMA(VARQ,21);
SD1:= EMA(SK1,2);
短买:=CROSS(SK1,SD1);
备钱:=CROSS(ZIG(3,8),REF(ZIG(3,8),1));
备短:=(短买 AND COUNT(备钱,2)>=1);
DRAWICON(COUNT(VARC,3)=1 AND 备短,0,23);
YK1:="MACD.DIF#MONTH";
YK2:="MACD.DEA#MONTH";
YK0:=CROSS(YK1,YK2) OR YK1>YK2;
ZK1:="MACD.DIF#WEEK";
ZK2:="MACD.DEA#WEEK";
ZK0:=CROSS(ZK1,ZK2) OR ZK1>ZK2;
RK1:="MACD.DIF#DAY";
RK2:="MACD.DEA#DAY";
RK0:=CROSS(RK1,RK2) OR RK1>RK2;
RZYK:=RK0 AND ZK0 AND RK0;
魔力上翘:=20*(MA8>REF(MA8,1)),COLORLIBLUE,LINETHICK2;
魔力X:=MA24>REF(MA24,1) AND REF(MA24,1)>REF(MA24,2);
魔力X1:=MA72>REF(MA72,1)AND REF(MA72,1)>REF(MA72,2);
BBI:=(EMA(CLOSE,3)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4;
EBBI:=(EMA(C,6)+EMA(C,18)+EMA(C,54)+EMA(C,162))/4;
FF1:=EMA(C,3)>EMA(C,7) AND EMA(C,7)>EMA(C,21) AND EMA(C,21)>EMA(C,54);
主升浪:82*(BBI>EBBI AND FF1 AND RK1>RK2)POINTDOT COLORWHITE,LINETHICK4;
魔力操作区:80*(魔力上翘 AND REF(魔力上翘,1)) COLORBLUE,LINETHICK3;
魔力操作区1:78*( 魔力X OR 魔力上翘)POINTDOT COLORWHITE,LINETHICK4;
DIVE:=0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13);
CYR:=(DIVE/REF(DIVE,1)-1)*10;
MACYR:=MA(CYR,5)/10;
魔力线:=(MA8>REF(MA8,1)),COLORWHITE,LINETHICK1;
{CYR值}
DIVE1:=0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13);
CYR1:=(DIVE1/REF(DIVE1,1)-1)*100;
CYR值:=CYR1<4 AND CYR1>0.1;{CYR峰值}
{CYS峰值}
CYC13:=0.01*EXPMA(AMOUNT,13)/EXPMA(VOL,13);
CYS13:=(CLOSE-CYC13)/CYC13*100;
CYS峰:=CYS13<18 ;
{VR值}
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),26);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),26);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26);
VR:=100*(TH*2+TQ)/(TL*2+TQ);
VR值:=VR<400;{VR峰值}
{PSY值}
PSY:=COUNT(CLOSE>REF(CLOSE,1),12)/12*100;
PSY值:=PSY<82;{PSY峰值}
{RSI峰值}
LC:=REF(CLOSE,1);
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
MMS:=MA(3*RSI2-2*SMA(MAX(CLOSE-LC,0),16,1)/SMA(ABS(CLOSE-LC),16,1)*100,3);
RSI峰:=MMS<90;
{VRSI峰值}
VLC:=REF(VOL,1);
VRSI:=SMA(MAX(VOL-VLC,0),7,1)/SMA(ABS(VOL-VLC),7,1)*100;
VRSI峰:=VRSI<82;
{BIAS乖离率}
BIAS12:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS24:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIAS值:=BIAS12<25 AND BIAS24<32;{BIAS峰值}
换手1:=V/CAPITAL*100>1.5 AND DYNAINFO(8)>0;{换手率不能太小}
{峰值限制}
-50;
峰值限制:-50*(CYR值 AND CYS峰 AND VR值 AND PSY值 AND BIAS值
AND RSI峰 AND VRSI峰 AND 换手1),COLORGREEN,LINETHICK2; {指标值要求};
变仓:IF(MACYR<CYR ,0,DRAWNULL),COLORYELLOW,LINETHICK2;
空仓:IF(CYR<MACYR ,0,DRAWNULL),COLORGREEN,LINETHICK2;
持仓:IF(CYR>MACYR AND 魔力线,0,DRAWNULL),COLORRED,,LINETHICK2;

通达信斩妖宝刀指标公式

 

相关文章