在线检测未来函数

通达信强势区间指标公式

来源:Internet,编辑:股旁网,2018-04-13

M:=1;
X_1:=FINANCE(30)>=REF(FINANCE(30),130);
X_2:=X_1;
X_3:=IF(NAMELIKE(5),0,1);
X_4:=IF(NAMELIKE(6),0,1);
X_5:=DYNAINFO(17)>0;
X_6:=9500;
X_7:=EXIST((CLOSE/REF(CLOSE,1)-1)*100>5.6,60);
X_8:=DYNAINFO(4)>0;
X_9:=DYNAINFO(7)<150;
X_10:=CAPITAL/5500000<10;
X_11:=X_7 AND X_8 AND X_9 AND X_10 AND CLOSE<150 AND FINANCE(42)<X_6 AND X_3 AND X_4;
X_12:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
X_13:=DYNAINFO(5)<0.01 OR DYNAINFO(6)<0.01;
X_14:=IF(X_13,1,X_12<DYNAINFO(5)+0.01 AND X_12>DYNAINFO(6)-0.01);
X_15:=IF(X_14,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120));
X_16:=EVERY(X_15>REF(X_15,1),1);
X_17:=IF(X_16,X_15,DRAWNULL);
X_18:=STICKLINE(X_17 AND EVERY(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,
-VOL)/100),0),30)>REF(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),
0),30),1),1) AND IF(MA(WINNER(CLOSE*0.9)*100*CLOSE,3)>10,MA(WINNER(CLOSE*0.9)*100*CLOSE,3),
0)/2/8>0 AND X_11,REFDATE(HHV(HIGH,(-5)),DATE),REFDATE(LLV(LOW,(-5)),DATE),4,0);
X_19:=STICKLINE(EVERY(EMA(SLOPE(CLOSE,15)*20+CLOSE,30)>REF(EMA(SLOPE(CLOSE,15)*20+CLOSE,30)
,1),1) AND EVERY(MA(10000*CLOSE/INDEXC,10)>REF(MA(10000*CLOSE/INDEXC,10),1),1)
AND EVERY(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),0),
30)>REF(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),0),30),1),1)
AND X_11,REFDATE(HHV(HIGH,(-5)),DATE),REFDATE(LLV(LOW,(-5)),DATE),6,0);
X_20:=STICKLINE(EVERY(XMA(XMA(LOW,25),25)-(XMA(XMA(HIGH,25),25)-XMA(XMA(LOW,25),
25))*1>REF(XMA(XMA(LOW,25),25)-(XMA(XMA(HIGH,25),25)-XMA(XMA(LOW,25),25))*1,1),1)
AND COST(EMA(SLOPE(CLOSE,15)*20+CLOSE,30))>=REF(COST(EMA(SLOPE(CLOSE,15)*20+CLOSE,30)),1)
AND COST(20)>=REF(COST(20),1) AND EVERY(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),
VOL,-VOL)/100),0),30)>REF(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),
0),30),1),1) AND VOL/MA(VOL,55)*100>50 AND EVERY(EMA(EMA(CLOSE,12)-EMA(CLOSE,26),
9)>REF(EMA(EMA(CLOSE,12)-EMA(CLOSE,26),9),1),1) AND X_11,REFDATE(HHV(HIGH,(-5)),DATE),
REFDATE(LLV(LOW,(-5)),DATE),4,0);
强势区:=STICKLINE(X_11 AND EVERY(EMA(SLOPE(CLOSE,15)*20+CLOSE,30)>REF(EMA(SLOPE(CLOSE,15)*20+CLOSE,30),
1),1) AND EVERY(MA(10000*CLOSE/INDEXC,10)>REF(MA(10000*CLOSE/INDEXC,10),1),1)
AND EVERY(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),0),
30)>REF(EMA(SUM(IF(CLOSE=REF(CLOSE,1),0,IF(CLOSE>REF(CLOSE,1),VOL,-VOL)/100),0),30),1),1)
AND IF(MA(WINNER(CLOSE*0.9)*100*CLOSE,3)>10,MA(WINNER(CLOSE*0.9)*100*CLOSE,3),0)/2/8>0
AND X_18 AND X_19 AND X_20 AND X_11,REFDATE(HHV(HIGH,(-5)),DATE),REFDATE(LLV(LOW,(-5)),
DATE),4,0),COLOR001050;
STICKLINE(REF(NOT(强势区),1),0,10000,4,-1),COLORGREEN;
STICKLINE(强势区,0,10000,4,0),COLORRED;
每股总价值:IF(FINANCE(3),FINANCE(18)+FINANCE(32)+FINANCE(33)+FINANCE(34)+(FINANCE(13)+FINANCE(22)
+FINANCE(25))/FINANCE(1),DRAWNULL),COLORGREEN,NODRAW;
静值:IF(FINANCE(3),FINANCE(18)+FINANCE(32)+FINANCE(33)+FINANCE(34){+FINANCE(38)},DRAWNULL),COLORYELLOW,NODRAW;
应收款:IF(FINANCE(3),FINANCE(22)/FINANCE(1),DRAWNULL),COLORWHITE,NODRAW;
现金流:IF(FINANCE(3),FINANCE(25)/FINANCE(1),DRAWNULL),COLORMAGENTA,NODRAW;
无形资:IF(FINANCE(3),FINANCE(13)/FINANCE(1),DRAWNULL),COLORWHITE,NODRAW;

通达信强势区间指标公式

 

相关文章