在线检测未来函数

通达信末日波段主图指标公式

来源:Internet,编辑:股旁网,2018-04-16

DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);
DRAWGBK(C>0,RGB(0,0,0),RGB(00,0,0),0,'EM',0);
STICKLINE(C>O,C,O,3,0 ),COLOR000055;
STICKLINE(C>O,C,O,2.6,0 ),COLOR000077;
STICKLINE(C>O,C,O,2.1,0 ),COLOR000099;
STICKLINE(C>O,C,O,1.5,0 ),COLOR0000BB;
STICKLINE(C>O,C,O,0.9,0 ),COLOR0000DD;
STICKLINE(C>O,C,O,0.1,0 ),COLOR0000FF;
STICKLINE(C>O,H,L,0,0),COLORRED;
STICKLINE(C<O,C,O,3,0),COLOR646400;
STICKLINE(C<O,C,O,2.6,0),COLOR848400;
STICKLINE(C<O,C,O,2.1,0),COLOR9F9F00;
STICKLINE(C<O,C,O,1.5,0),COLORB0B000;
STICKLINE(C<O,C,O,0.9,0),COLORC4C400;
STICKLINE(C<O,C,O,0.1,0),COLORDBDB00;
STICKLINE(C<O,H,L,0,0),COLORDDDD00;
STICKLINE(C=O,C,O,3,0 ),COLORWHITE;
STICKLINE(C=O,H,L,0,0),COLORWHITE;
B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
末日买入:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK2;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK2;
末日卖出:HHV(MA(B2,1),13),COLORYELLOW;
VAR1:=(2*CLOSE+HIGH+LOW)/4;
VAR2:=MA(VAR1,7);
VAR3:=VAR2-MA(VAR1,7/2)<0;
VAR4:=VAR2-MA(VAR1,7/2)>0;
VAR5:=BARSLAST(VAR3);
VAR6:=0-BARSLAST(VAR4);
VAR7:=IF(VAR3<=0,VAR5,VAR6);
STICKLINE(末日卖出>B2 AND B2>SMA2,末日卖出,B2,0,1),COLORGRAY;
STICKLINE(末日卖出>SMA2 AND B2<SMA2,末日卖出,SMA2,0,1),COLORGREEN;
VAR11:=(CLOSE*2+HIGH+LOW)/4;
VAR21:=EMA(VAR11,13)-EMA(VAR11,34);
VAR31:=EMA(VAR21,5);
{STICKLINE((C>=O),OPEN,LOW,0,0),COLOR0726CA;
STICKLINE((C>=O),CLOSE,HIGH,0,0),COLOR0726CA;
STICKLINE((C<O),CLOSE,LOW,0,0),COLORDE9100;
STICKLINE((C<O),OPEN,HIGH,0,0),COLORDE9100;
STICKLINE((C<O),CLOSE,OPEN,4,0),COLORFF5B00;
STICKLINE((C<O),CLOSE,OPEN,3.4,0),COLORFF6C00;
STICKLINE((C<O),CLOSE,OPEN,2.8,0),COLORFF7B00;
STICKLINE((C<O),CLOSE,OPEN,2.2,0),COLORFF9C00;
STICKLINE((C<O),CLOSE,OPEN,1.6,0),COLORFFBE00;
STICKLINE((C<O),CLOSE,OPEN,1,0),COLORFFCC00;
STICKLINE((C<O),CLOSE,OPEN,0.3,0),COLORFFFF00;
STICKLINE((C>O),CLOSE,OPEN,4,0),COLOR070084;
STICKLINE((C>O),CLOSE,OPEN,3.4,0),COLOR0000A3;
STICKLINE((C>O),CLOSE,OPEN,2.8,0),COLOR0000B7;
STICKLINE((C>O),CLOSE,OPEN,2.2,0),COLOR0000CD;
STICKLINE((C>O),CLOSE,OPEN,1.6,0),COLOR0000E9;
STICKLINE((C>O),CLOSE,OPEN,1,0),COLOR0754E9;
STICKLINE((C>O),CLOSE,OPEN,0.5,0),COLOR076EF3;
STICKLINE((C>O),CLOSE,OPEN,0.2,0),COLOR077BF3;}
VAR2A:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3A:=((REF(VAR2A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4A:=((REF(VAR3A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5A:=((REF(VAR4A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6A:=((REF(VAR5A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7A:=((REF(VAR6A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8A:=((REF(VAR7A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9A:=((REF(VAR8A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARAA:=((REF(VAR9A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARBA:=((REF(VARAA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARCA:=((REF(VARBA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARDA:=((REF(VARCA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAREAA:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARFA:=((REF(VAREAA,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10A:=((REF(VARFA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11A:=((REF(VAR10A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12A:=((REF(VAR11A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13A:=((REF(VAR12A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14A:=((REF(VAR13A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15A:=((REF(VAR14A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16A:=((REF(VAR15A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17A:=((REF(VAR16A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18A:=((REF(VAR17A,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19A:=((REF(VAR18A,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1A:=(REF((((((((((((VAREAA OR VARFA) OR VAR10A) OR VAR11A) OR VAR12A) OR
VAR13A) OR VAR14A) OR VAR15A) OR VAR16A) OR VAR17A) OR VAR18A) OR VAR19A),1) ANDVAR2A);
{STICKLINE(VAR1A,O,O+(C-O)/3,4,0),COLOR1029FF;
STICKLINE(VAR1A,O,O+(C-O)/3,3.4,0),COLOR1040FF;
STICKLINE(VAR1A,O,O+(C-O)/3,2.8,0),COLOR1083FF;
STICKLINE(VAR1A,O,O+(C-O)/3,2.2,0),COLOR10ABFF;
STICKLINE(VAR1A,O,O+(C-O)/3,1.6,0),COLOR10D0FF;
STICKLINE(VAR1A,O,O+(C-O)/3,1,0),COLOR10FFFF;
STICKLINE(VAR1A,O,O+(C-O)/3,0.3,0),COLOR00FFFF;}
AA:=(REF((((((((((((VAR2A OR VAR3A) OR VAR4A) OR VAR5A) OR VAR6A) OR VAR7A) OR
VAR8A) OR VAR9A)OR VARAA) OR VARBA) OR VARCA) OR VARDA),1) AND VAREAA);
{STICKLINE(AA,O,O+(C-O)/3,4.3,0),COLOR009900;
STICKLINE(AA,O,O+(C-O)/3,3.2,0),COLOR00AA00;
STICKLINE(AA,O,O+(C-O)/3,2.4,0),COLOR00BB00;
STICKLINE(AA,O,O+(C-O)/3,1.7,0),COLOR00CC00;
STICKLINE(AA,O,O+(C-O)/3,1.1,0),COLOR00DD00;
STICKLINE(AA,O,O+(C-O)/3,0.5,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,0.2,0),COLOR00FF00;}
A13:=EMA(CLOSE,55);
A14:=MA(CLOSE,75);
A15:=EMA(A14,3);
A16:=EMA(A15,3);
A17:=(HIGH + LOW) / 5;
A18:=(MA(A17,4)) - (MA(A17,34));
A19:=CROSS(A18,0);
A20:=CROSS(0,A18);
A21:=BARSLAST(A19);
A22:=BARSLAST(A20);
A23:=REF(A19,1);
A24:=REF(A20,1);
A25:=BARSLAST(A23);
A26:=BARSLAST(A24);
A27:=IF((A25 < A26),(REF((HHV(HIGH,2)),A25)),(REF((LLV(LOW,2)),A26)));
A28:=(((REF(CLOSE,1)) <= (REF(A27,1))) AND (CLOSE > A27)) AND (A21 < A22);
A29:=(((REF(CLOSE,1)) >= (REF(A27,1))) AND (CLOSE < A27)) AND (A22 < A21);
A30:=A28 AND ((COUNT(A28,A21)) = 1);
A31:=A29 AND ((COUNT(A29,A22)) = 1);
A32:=A30 AND ((REF(BARSLAST(A31),1)) < (REF(BARSLAST(A30),1)));
A33:=A31 AND ((REF(BARSLAST(A31),1)) > (REF(BARSLAST(A30),1)));
DRAWTEXT(A32,SMA2*0.99,'←末日抓妖'),COLORYELLOW;
AC:=AMOUNT/(VOL);
YY:=MA(AC,13);
LLL:=(C-YY)/YY*100;
MIDC := MA(CLOSE,22);
UPPERC:= MIDC + 2*STD(C,22);
LOWERC:= MIDC - 2*STD(C,22);
BBA:=(C-LOWERC)/(UPPERC-LOWERC);
LIFENGCYC:=(REF(LLL,1)<-15 AND REF(BBA,1)<0 AND LLL>REF(LLL,1));
{STICKLINE(LIFENGCYC,LOW*0.93,LOW*0.95,6,0)COLORRED;
STICKLINE(LIFENGCYC>0,C,O,4,0),COLORRED;
STICKLINE(LIFENGCYC>0,C,O,3.4,0),COLOR1029FF;
STICKLINE(LIFENGCYC>0,C,O,2.8,0),COLOR1040FF;
STICKLINE(LIFENGCYC>0,C,O,2.2,0),COLOR1083FF;
STICKLINE(LIFENGCYC>0,C,O,1.6,0),COLOR10ABFF;
STICKLINE(LIFENGCYC>0,C,O,1,0),COLOR10D0FF;
STICKLINE(LIFENGCYC>0,C,O,0.3,0),COLOR10FFFF;}
BS:=B2>REF(B2,1) AND REF(B2<REF(B2,1),1);
DRAWICON(BS,L*0.98,1);
BX:=B2<REF(B2,1) AND REF(B2>REF(B2,1),1);
DRAWICON(BX,H*1.02,2);
HJ_1:=8;
HJ_2:=REF(HIGH,10)=HHV(HIGH,2*11);
HJ_3:=BACKSET(HJ_2,10+1);
HJ_4:=FILTER(HJ_3,10) AND HIGH=HHV(HIGH,11);
卖出:DRAWICON(HJ_4,HIGH*1.02,12);
HJ_5:=REF(LOW,10)=LLV(LOW,2*11);
HJ_6:=BACKSET(HJ_5,11);
HJ_7:=FILTER(HJ_6,10) AND LOW=LLV(LOW,11);
买入:DRAWICON(HJ_7,LOW*0.98,11);
HJ_8:=HHV(HIGH,60);
HJ_9:=CONST(HJ_8);
HJ_10:=LLV(LOW,60);
HJ_11:=CONST(HJ_10);
HJ_12:=(CLOSE+HIGH+LOW+OPEN)/4;
HJ_13:=LOW+(HJ_12-LOW)+(CLOSE-LOW);
HJ_14:=LOW+(CLOSE-HJ_12);
HJ_15:=LOW>REF(HIGH,1);
HJ_16:=HIGH<REF(LOW,1);
HJ_17:=LOW>REF(HIGH,BARSLAST(HJ_15)+1);
HJ_18:=LOW<=REF(HIGH,BARSLAST(HJ_15)+1);
HJ_19:=HIGH<REF(LOW,BARSLAST(HJ_16)+1);
HJ_20:=HIGH>=REF(LOW,BARSLAST(HJ_16)+1);
HJ_21:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
HJ_22:=SMA(HJ_21,3,1);
HJ_23:=SMA(HJ_22,3,1);
HJ_24:=3*HJ_22-2*HJ_23;
HJ_25:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
HJ_26:=SMA(HJ_25,3,1);
HJ_27:=SMA(HJ_26,3,1);
HJ_28:=3*HJ_26-2*HJ_27;
HJ_29:=IF(CROSS(HJ_28,HJ_24),HIGH,REF(HIGH,BARSLAST(CROSS(HJ_28,HJ_24))));
HJ_30:=LLV(HIGH,30);
HJ_31:=REF(HIGH,HJ_1)=HHV(HIGH,2*HJ_1+1);
HJ_32:=REF(LOW,HJ_1)=LLV(LOW,2*HJ_1+1);
HJ_33:=BACKSET(HJ_31,HJ_1+1);
HJ_34:=BACKSET(HJ_32,HJ_1+1);
HJ_35:=FILTER(HJ_33,HJ_1) AND HIGH=HHV(HIGH,HJ_1+1);
HJ_36:=FILTER(HJ_34,HJ_1) AND LOW=LLV(LOW,HJ_1+1);
HJ_37:=BARSLAST(HJ_35);
HJ_38:=BARSLAST(HJ_36);
HJ_39:=IF(HJ_35,CURRBARSCOUNT,0);
HJ_40:=IF(HJ_36,CURRBARSCOUNT,0);
HJ_41:=IF(HJ_37,REF(HJ_39,HJ_37),HJ_39);
HJ_42:=IF(HJ_38,REF(HJ_40,HJ_38),HJ_40);
HJ_43:=CONST(HJ_41);
HJ_44:=CONST(HJ_42);
HJ_45:=CONST(REF(HIGH,HJ_43-1));
HJ_46:=HJ_45;
HJ_47:=CONST(REF(LOW,HJ_44-1));
HJ_48:=REF(HJ_41,HJ_37+1);
HJ_49:=REF(HJ_42,HJ_38+1);
HJ_50:=CONST(HJ_48);
HJ_51:=CONST(HJ_49);
HJ_52:=CONST(REF(HIGH,HJ_48-1));
HJ_53:=HJ_52;
HJ_54:=CONST(REF(LOW,HJ_49-1));
HJ_55:=BACKSET(ISLASTBAR,HJ_43);
HJ_56:=BACKSET(ISLASTBAR,HJ_44);
HJ_57:=BACKSET(ISLASTBAR,HJ_48);
HJ_58:=BACKSET(ISLASTBAR,HJ_49);
HJ_59:=IF(HJ_47<=HJ_54,HJ_56,HJ_58);
HJ_60:=SUM(HJ_55,0);
HJ_61:=SUM(HJ_59,0);
HJ_62:=REF(HJ_13,1);
HJ_63:=REF(HJ_14,1);
HJ_64:=IF(ISLASTBAR,HJ_29,DRAWNULL);
HJ_65:=IF(ISLASTBAR,HJ_30,DRAWNULL);
高点压力:=DRAWLINE(CURRBARSCOUNT=HJ_50,HIGH,CURRBARSCOUNT=HJ_43,HIGH,1),COLORYELLOW,LINETHICK2;
低点支撑:=DRAWLINE(CURRBARSCOUNT=HJ_51,LOW,CURRBARSCOUNT=HJ_44,LOW,1),COLORYELLOW,LINETHICK2;
HJ_66:=CONST(MAX(MAX(MAX(HJ_9,高点压力),HJ_46),HJ_53));
HJ_67:=CONST(MIN(MIN(MIN(HJ_11,HJ_54),HJ_47),低点支撑));
HJ_68:=(高点压力+低点支撑)/2;
HJ_69:=CONST((高点压力+低点支撑)/2);
HJ_70:=IF(HJ_51<HJ_50,HJ_51,HJ_50);
HJ_71:=DRAWLINE(CURRBARSCOUNT=HJ_70,HJ_68,ISLASTBAR,HJ_69,1);
HJ_72:=INTPART(3*HJ_1/5);
HJ_73:=REF(HIGH,HJ_72)=HHV(HIGH,2*HJ_72+1);
HJ_74:=BACKSET(HJ_73,HJ_72+1);
HJ_75:=FILTER(HJ_74,HJ_72) AND HIGH=HHV(HIGH,HJ_72+1);
HJ_76:=BARSLAST(HJ_75);
HJ_77:=IF(HJ_75,CURRBARSCOUNT,0);
HJ_78:=IF(HJ_76,REF(HJ_77,HJ_76),HJ_77);
HJ_79:=CONST(HJ_78);
HJ_80:=REF(HJ_78,HJ_76+1);
HJ_81:=CONST(HJ_80);
高点压力M:DRAWLINE(CURRBARSCOUNT=HJ_81,HIGH,CURRBARSCOUNT=HJ_79,HIGH,1),COLORRED;
HJ_82:=REF(LOW,HJ_72)=LLV(LOW,2*HJ_72+1);
HJ_83:=BACKSET(HJ_82,HJ_72+1);
HJ_84:=FILTER(HJ_83,HJ_72) AND LOW=LLV(LOW,HJ_72+1);
HJ_85:=BARSLAST(HJ_84);
HJ_86:=IF(HJ_84,CURRBARSCOUNT,0);
HJ_87:=IF(HJ_85,REF(HJ_86,HJ_85),HJ_86);
HJ_88:=CONST(HJ_87);
HJ_89:=REF(HJ_87,HJ_85+1);
HJ_90:=CONST(HJ_89);
低点支撑M:DRAWLINE(CURRBARSCOUNT=HJ_90,LOW,CURRBARSCOUNT=HJ_88,LOW,1),COLORRED;
STICKLINE(HJ_57,HJ_53,HJ_53,2.5,1),COLORWHITE;
STICKLINE(HJ_55,HJ_46,HJ_46,2.3,1),COLORYELLOW;
STICKLINE(HJ_58,HJ_54,HJ_54,0.5,1),COLORMAGENTA;
STICKLINE(HJ_56,HJ_47,HJ_47,0.5,1),COLORCYAN;
STICKLINE(ISLASTBAR,HJ_64,HJ_64,120,0),COLORWHITE,LINETHICK3;
STICKLINE(ISLASTBAR,HJ_65,HJ_65,100,0),COLORGREEN,LINETHICK3;
HJ_91:=MA(EMA(WINNER(CLOSE),3),40);
HJ_92:=HJ_91>REF(HJ_91,4);
HJ_93:=VOL*5/SUM(REF(VOL,1),5)>1;
HJ_94:=VOL/CAPITAL*100>3;
HJ_95:=EMA(EMA(CLOSE,9),9);
HJ_96:=(HJ_95-REF(HJ_95,1))/REF(HJ_95,1);
HJ_97:=100*WINNER(CLOSE*0.95);
HJ_98:=HJ_92 AND HJ_93 AND HJ_94;
HJ_99:=HJ_98;
DRAWICON(CROSS(CLOSE,HJ_53) AND HJ_99,LOW-0.2,5);
DRAWICON(CROSS(CLOSE,HJ_46) AND HJ_99,LOW-0.8,5);
DRAWICON(CROSS(CLOSE,HJ_54) AND HJ_99,LOW-0.6,5);

通达信末日波段主图指标公式

 

相关文章