在线检测未来函数

通达信水晶主图指标公式

来源:Internet,编辑:股旁网,2018-04-23

顶:=HHV(HIGH,20),COLOR007FFF;
底:=LLV(LOW,20),COLORYELLOW;
A20Y:EMA(SLOPE((CLOSE+HIGH+LOW)/3,25)*8+(CLOSE+HIGH+LOW)/3,21),COLORMAGENTA;
XA1:=EMA(A20Y,3);
C20Y:EMA(XA1,3),COLORMAGENTA;
D20:IF(A20Y<REF(A20Y,1),A20Y,DRAWNULL),COLORGREEN;
XA2:=IF(XA1<REF(XA1,1),XA1,DRAWNULL);
F20:IF(C20Y<REF(C20Y,1),C20Y,DRAWNULL),COLORGREEN;
XA_1:=BARSLAST(LOW=LLV(LOW,360));
XA_2:=REF(LOW,XA_1);
XA_3:=BARSLAST(HIGH=HHV(HIGH,XA_1));
XA_4:=REF(HIGH,XA_3);
XA_5:=IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_4,XA_4)),DRAWNULL);
XA_6:=IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_2,XA_2)),DRAWNULL);
XA_7:=(XA_5+XA_6)/2;
XA_8:=XA_6+(XA_5-XA_6)*0.191;
XA_9:=XA_6+(XA_5-XA_6)*0.382;
XA_10:=XA_6+(XA_5-XA_6)*0.618;
XA_11:=XA_6+(XA_5-XA_6)*0.809;
A7A:IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_4,XA_4)),DRAWNULL),COLORRED;
A6A:IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_11,XA_11)),DRAWNULL),DOTLINE,COLORLIGRAY;
A5A:IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_10,XA_10)),DRAWNULL),DOTLINE,COLORLIGRAY;
A4A:IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_7,XA_7)),DRAWNULL),COLORMAGENTA;
A3A:IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_9,XA_9)),DRAWNULL),DOTLINE,COLORLIGRAY;
A2A:IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_8,XA_8)),DRAWNULL),DOTLINE,COLORLIGRAY;
A1A:IF(CURRBARSCOUNT<=CONST(XA_1+1),CONST(IF(1,XA_2,XA_2)),DRAWNULL),COLORGREEN;
原本线:IF(CURRBARSCOUNT<=CONST(XA_1),MA(CLOSE,XA_1),DRAWNULL),COLORRED;
原本跌:IF(CURRBARSCOUNT<=CONST(XA_1),IF(原本线<REF(原本线,1),原本线,DRAWNULL),DRAWNULL),COLORGREEN;
H本线:IF(CURRBARSCOUNT<=CONST(XA_3+1),MA(CLOSE,XA_3),DRAWNULL),COLORRED;
H本跌:IF(CURRBARSCOUNT<=CONST(XA_3+1),IF(H本线<REF(H本线,1),H本线,DRAWNULL),DRAWNULL),COLORGREEN;
XA_12:=BARSLAST(LOW=LLV(LOW,XA_3));
L本线:IF(CURRBARSCOUNT<=CONST(XA_12+1),MA(CLOSE,XA_12),DRAWNULL),COLORRED;
L本跌:IF(CURRBARSCOUNT<=CONST(XA_12+1),IF(L本线<REF(L本线,1),L本线,DRAWNULL),DRAWNULL),COLORGREEN;
XA_13:=CONST(XA_1+1);
XA_14:=(A2A+A1A)/2;
GGH1:DRAWTEXT(CURRBARSCOUNT=XA_13,XA_14,238),COLORYELLOW;
XA_15:=(A3A+A2A)/2;
GGH2:DRAWTEXT(CURRBARSCOUNT=XA_13,XA_15,239),COLORYELLOW;
XA_16:=(A4A+A3A)/2;
GGH3:DRAWTEXT(CURRBARSCOUNT=XA_13,XA_16,240),COLORYELLOW;
XA_17:=(A5A+A4A)/2;
GGH4:DRAWTEXT(CURRBARSCOUNT=XA_13,XA_17,241),COLORYELLOW;
XA_18:=(A6A+A5A)/2;
GGH5:DRAWTEXT(CURRBARSCOUNT=XA_13,XA_18,242),COLORYELLOW;
XA_19:=(A7A+A6A)/2;
GGH6:DRAWTEXT(CURRBARSCOUNT=XA_13,XA_19,243),COLORYELLOW;
XA_20:=BARSLAST(INDEXL=LLV(INDEXL,360));
XA_21:=REF(INDEXL,XA_20);
XA_22:=BARSLAST(INDEXH=HHV(INDEXH,XA_20));
XA_23:=REF(INDEXH,XA_22);
YU21:IF(CURRBARSCOUNT<=CONST(XA_20+1),CONST(IF(1,XA_23,XA_23)),DRAWNULL),COLORRED;
YU22:IF(CURRBARSCOUNT<=CONST(XA_20+1),CONST(IF(1,XA_21,XA_21)),DRAWNULL),COLORGREEN;
XA_24:=CONST(INTPART((INDEXC-YU21)/YU21*100));
YU41:CONST(INTPART((CLOSE-XA_5)/XA_5*100)),NODRAW;
PVA4:DRAWTEXT_FIX(ISLASTBAR,0.78,10,0,244),COLORWHITE;
PVA3:DRAWNUMBER_FIX(ISLASTBAR,0.84,10,0,XA_24),COLORCYAN;
PVA2:DRAWTEXT_FIX(ISLASTBAR,0.87,10,0,245),COLORYELLOW;
PVA1:DRAWNUMBER_FIX(ISLASTBAR,0.93,10,0,YU41),COLORGREEN;
XA_25:=CONST(INTPART(WINNER(CLOSE)*100));
PVA11:DRAWTEXT_FIX(ISLASTBAR,0.71,10,0,246),COLORRED;
PVA12:DRAWNUMBER_FIX(ISLASTBAR,0.76,10,0,XA_25),COLORGREEN;
XA_26:=CONST(INTPART(CLOSE*FINANCE(7)/100000000));
PVA13:DRAWTEXT_FIX(ISLASTBAR,0.63,10,0,247),COLORMAGENTA;
PVA14:DRAWNUMBER_FIX(ISLASTBAR,0.68,10,0,XA_26),COLORGREEN;
XA_27:=FILTER(MONTH=2 AND (DAY=3 OR DAY=5),2);
XA_28:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);
XA_29:=FILTER(MONTH=3 AND (DAY=5 OR DAY=7),2);
XA_30:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);
XA_31:=FILTER(MONTH=4 AND (DAY=4 OR DAY=6),2);
XA_32:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);
XA_33:=FILTER(MONTH=5 AND (DAY=6 OR DAY=8),2);
XA_34:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);
XA_35:=FILTER(MONTH=6 AND (DAY=5 OR DAY=7),2);
XA_36:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);
XA_37:=FILTER(MONTH=7 AND (DAY=6 OR DAY=8),2);
XA_38:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);
XA_39:=FILTER(MONTH=8 AND (DAY=7 OR DAY=9),2);
XA_40:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);
XA_41:=FILTER(MONTH=9 AND (DAY=7 OR DAY=9),2);
XA_42:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);
XA_43:=FILTER(MONTH=10 AND (DAY=7 OR DAY=9),2);
XA_44:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);
XA_45:=FILTER(MONTH=11 AND (DAY=7 OR DAY=9),2);
XA_46:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);
XA_47:=FILTER(MONTH=12 AND (DAY=6 OR DAY=8),2);
XA_48:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);
XA_49:=FILTER(MONTH=1 AND (DAY=5 OR DAY=7),2);
XA_50:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);
XA_51:=1.006;
XA_52:=IF(CURRBARSCOUNT<=CONST(10),CONST(10),DRAWNULL);
DRAWTEXT(XA_52 AND XA_27=1,HIGH*XA_51,248),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_28=1,HIGH*XA_51,249),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_29=1,HIGH*XA_51,250),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_30=1,HIGH*XA_51,251),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_31=1,HIGH*XA_51,252),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_32=1,HIGH*XA_51,253),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_33=1,HIGH*XA_51,254),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_34=1,HIGH*XA_51,255),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_35=1,HIGH*XA_51,256),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_36=1,HIGH*XA_51,257),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_37=1,HIGH*XA_51,258),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_38=1,HIGH*XA_51,259),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_39=1,HIGH*XA_51,260),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_40=1,HIGH*XA_51,261),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_41=1,HIGH*XA_51,262),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_42=1,HIGH*XA_51,263),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_43=1,HIGH*XA_51,264),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_44=1,HIGH*XA_51,265),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_45=1,HIGH*XA_51,266),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_46=1,HIGH*XA_51,267),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_47=1,HIGH*XA_51,268),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_48=1,HIGH*XA_51,269),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_49=1,HIGH*XA_51,270),COLORYELLOW;
DRAWTEXT(XA_52 AND XA_50=1,HIGH*XA_51,271),COLORYELLOW;
XA_53:=CLOSE>REF(CLOSE,1) AND INDEXC<REF(INDEXC,1);
FH200:DRAWTEXT(XA_53 AND CURRBARSCOUNT<=CONST(10),HIGH*1.01,272),COLORYELLOW;

通达信水晶主图指标公式

 

相关文章