在线检测未来函数

通达信均线上的量柱主图指标公式

来源:Internet,编辑:股旁网,2018-04-24

MX:=EMA(C,2);
MXA:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(MX>=MXA,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),
COLOR600020;
STICKLINE(MX<MXA,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),
COLOR404050;
DRAWKLINE(H,O,L,C);
AA:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);
趋势线:=MA((2*CLOSE+LOW+HIGH)/4,AA),LINETHICK3,COLORRED;
CC:=(CLOSE/趋势线);
MA1:=MA(CC*(2*CLOSE+HIGH+LOW)/4,3);
MAAA:=((MA1-趋势线)/趋势线)/3;
TMP:=MA1-MAAA*MA1;
JJ:IF(TMP<=趋势线,趋势线,DRAWNULL),LINETHICK3,COLORGREEN;
XJ:IF(TMP<=趋势线,TMP,DRAWNULL),LINETHICK2,COLORBROWN;
建仓:CROSS(MX,MXA),NODRAW;
SEL:=CROSS(MXA,MX);
DRAWICON(建仓,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
DRAWTEXT(建仓,L-0.68,'↖建仓持股')COLORMAGENTA;
DRAWTEXT(SEL,H+0.38,'↙清仓持币'),COLORBROWN;
STICKLINE(MX>=MXA,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(MX>=MXA,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(MX<MXA,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(MX<MXA,CLOSE,OPEN,3,1),COLORGREEN;
STICKLINE(建仓,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORBROWN;
CP:=MA(CLOSE,9),COLORCYAN,LINETHICK1;
JD:=MA(CLOSE,18),COLORMAGENTA;
DRAWICON(CROSS(CP,JD) AND MX>=MXA,JD-0.1,1);
DRAWTEXT(CROSS(CP,JD) AND MX>=MXA,JD-0.38,'↖加仓'),COLORYELLOW;
BL:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWTEXT(FILTER(BL,3),H+0.2,'↙倍量柱')COLORYELLOW;
STICKLINE(FILTER(BL,3),OPEN,CLOSE,1.5,0),COLORYELLOW;
XG:=SUMBARS(FILTER(BL,3),1);
STICKLINE(XG,REF(L,XG-1),REF(L,XG-1),10,0),COLORYELLOW;

通达信均线上的量柱主图指标公式

 

相关文章