在线检测未来函数

同花顺波段高低主图指标公式

来源:Internet,编辑:股旁网,2018-04-26

做多线:REF(EMA(C,14),1), colorred,LINETHICK1;
A1X:=(EMA(C,14)-做多线)/做多线*100,NODRAW;
STICKLINE(CROSS(A1X,0),C,O,0,1),colorred;
STICKLINE(CROSS(0,A1X),C,O,0,1) ,colorblue;
做空线:IF(A1X<0,做多线,DRAWNULL),colorgreen,LINETHICK1;
工作线:=EMA(C,14);
止盈线:=EMA(C,7),LINETHICK1,colorgray;
生命线:=EMA(C,25),coloryellow;
CC11:=A1X>=0;
CCC:=A1X<0;
STICKLINE(((CC11) AND (C >= O)),H,L,0,1),colorred;
STICKLINE(((CC11) AND (C >= O)),O,C,2,1),colorred;
STICKLINE(((CC11) AND (C <= O)),H,L,0,0),colorred;
STICKLINE(((CC11) AND (C <= O)),O,C,2,0),colorred;
STICKLINE(((CCC) AND (C >= O)),H,L,0,1),colorgreen;
STICKLINE(((CCC) AND (C >= O)),O,C,2,1),colorgreen;
STICKLINE(((CCC) AND (C <= O)),H,L,0,0),colorgreen;
STICKLINE(((CCC) AND (C <= O)),O,C,2,0),colorgreen;
看多买入线:IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL),colormagenta,LINETHICK1;
逃顶卖出线:IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL) ,colorgreen,LINETHICK1;
牛:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25),DOTLINE,coloryellow;
金钻趋势:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1,LINETHICK2,colorred;
金牛2:=EMA(金钻趋势,25),colorcyan,LINETHICK2;
ZF:=(EMA(SUM(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)),3),49) * 10)+EMA(C,20);
飞扬古:=(EMA(MA(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)),3),13) * 10000),LINETHICK0,COLORFFFFFF;
牛熊线:EMA(ZF,34),LINETHICK1,coloryellow;
D11:=牛熊线;色边框1:=IF(C>D11,H,L);
STICKLINE(金钻趋势>LOW AND 金钻趋势<HIGH,金钻趋势,MIN(MIN(OPEN,CLOSE),金钻趋势),2,0),coloryellow;
STICKLINE(金钻趋势>MIN(C,O) AND 金钻趋势<MAX(C,O),金钻趋势,MIN(OPEN,CLOSE),2,0),coloryellow;
STICKLINE(金钻趋势>HIGH,OPEN,CLOSE,2,0),coloryellow;
STICKLINE(金钻趋势>HIGH,HIGH,LOW,0,0),coloryellow;
X:=A1X>=0;
买线:=A1X;
卖线:=0;
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,2,1),colormagenta;
STICKLINE(CROSS(卖线,买线),OPEN,CLOSE,2,0),colorgreen;
NNN333:=30;
AA:=REF(H,NNN333)=HHV(H,2*NNN333+1); AA1:=REF(L,NNN333)=LLV(L,2*NNN333+1);
QY:=BACKSET(AA,NNN333+1); QY1:=BACKSET(AA1,NNN333+1);
CC:=FILTER(QY,NNN333) AND H=HHV(H,NNN333+1);
CC1:=FILTER(QY1,NNN333) AND L=LLV(L,NNN333+1);
DDD:=BARSLAST(CC); DD1:=BARSLAST(CC1);
GDTS:=IF(CC,CURRBARSCOUNT,0); DDTS:=IF(CC1,CURRBARSCOUNT,0);
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
GDCS1:=CONST(DINGBUTS); DDCS1:=CONST(DDTS1);
GDCS13:=CONST(REF(HIGH,GDCS1-1)); DDCS13:=CONST(REF(L,DDCS1-1));
DINGBUTS1:=REF(DINGBUTS,DDD+1); DDTS2:=REF(DDTS1,DD1+1);
GDCS2:=CONST(DINGBUTS1); DDCS2:=CONST(DDTS2);
GDCS23:=CONST(REF(HIGH,DINGBUTS1-1)); DDCS23:=CONST(REF(L,DDTS2-1));
XG1:=BACKSET(ISLASTBAR,GDCS1); XD1:=BACKSET(ISLASTBAR,DDCS1);
XG2:=BACKSET(ISLASTBAR,DINGBUTS1); XD2:=BACKSET(ISLASTBAR,DDTS2);
STICKLINE(XG2,GDCS23,GDCS23,1,1),colorred;
STICKLINE(XG1,GDCS13,GDCS13,1,1),colorred;
STICKLINE(XD2,DDCS23,DDCS23,1,1),colorred;
STICKLINE(XD1,DDCS13,DDCS13,1,1),colorred;
N:=20;
A1:=REF(H,N)=HHV(H,2*N+1);
B1:=FILTER(A1,N);
C1:=BACKSET(B1,N+1);
D1:=FILTER(C1,N);
A2:=REF(L,N)=LLV(L,2*N+1);
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1);
D2:=FILTER(C2,N);
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS
(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS
(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1); S1:=R1>REF(R1,1);
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1); U1:=T1>REF(T1,1);
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1);
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1);
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1);
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1);
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1);
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1);
阶段高点:REF(H,BARSLAST(S2)),colorcyan,LINETHICK2;
REF(H,BARSLAST(S3)),colorgreen,LINETHICK2;
高点2:REF(H,BARSLAST(S1)),colorgreen,LINETHICK1;
阶段1低:REF(L,BARSLAST(U1)),colormagenta,LINETHICK2;
阶段2低:REF(L,BARSLAST(U2)),colorlimagenta,LINETHICK1;
阶段3低:REF(L,BARSLAST(U4)),COLOR0000FF,LINETHICK2;

同花顺波段高低主图指标公式

 

相关文章