在线检测未来函数

均线和dmi的选股公式

来源:Internet,编辑:股旁网,2018-04-11

编写要求:

1.均线多头排列; 2.如果PDI上穿MDI,在1-5天内,ADX正好大于等于25。

股旁网解答:

MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:= DMP*100/MTR;
MDI:= DMM*100/MTR;
ADX:= EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
DT:=MA1>MA2 AND MA2>MA3;
选股:DT AND EXIST(CROSS(PDI,MDI),5)AND ADX>=25;

相关文章