在线检测未来函数

通达信底顶指标公式

来源:Internet,编辑:股旁网,2018-05-08

R1:=(CLOSE-LLV(LOW,90))/(HHV(HIGH,90)-LLV(LOW,90))*200;
R2:=EMA((CLOSE-(LLV(LOW,5)))/((HHV(HIGH,5))-(LLV(LOW,5)))*100,4)*2;
R3:=EMA(0.618*REF(R2,1)+0.382*R2,2);
R4:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
R5:=POW(MA(LOW,5),2)+MA(LOW,5);
R6:=POW(MA(HIGH,5),2)+MA(HIGH,5);
R7:=(R4-LLV(R5,64))/(HHV(R6,64)-LLV(R5,64))*150+65-10;
R8:=SMA((SMA(R7,3,1)*1.5-100),3,1);
R9:=3*(SMA(R7,3,1)*1.5-100)-2*R8;
R10:=(HIGH+LOW+CLOSE*2)/4;
R11:=(R10-(EMA(R10,13)))*100/(STD(R10,13));
R12:=EMA((EMA(R11,5)),13)+200-100;
R13:=(SMA(R1,3,1))+R2+(SMA(R7,3,1)*1.5-100)+R12;
R14:=(SMA((SMA(R1,3,1)),3,1))+R3+R8+(EMA(R12,10));
R15:=(3*(SMA(R1,3,1))-2*(SMA((SMA(R1,3,1)),3,1)))+(3*R12-2*(EMA(R12,10)))+
R9+(3*R12-2*(EMA(R12,10)));
R16:=(HIGH+LOW+CLOSE)/3;
R17:=(R16-MA(R16,34))/(0.015*AVEDEV(R16,34));
R18:=(HIGH+LOW+CLOSE+R16)/4;
R19:=(R18-(EMA(R18,24)))/(STD(R18,24))*100;
R20:=(R16-MA(R16,24))/(0.015*AVEDEV(R16,24));
R21:=(((EMA(R19,5))+R20+R17)/3+165)/4;
R22:=(R13+R14+R15*30)/32/5-15;
A1:=EMA(EMA(CLOSE,13),13);
A2:=(A1-REF(A1,1))/REF(A1,1)*6400;
A3:=100*WINNER(CLOSE*0.95);
AR1:=EMA(OPEN,7);
AR2:=EMA(AR1,21);
AR3:=CROSS(AR1,AR2);
AR5:=EMA(SMA((CLOSE-LLV(LOW,20))/(HHV(HIGH,16)-LLV(LOW,20))*100,8,1),3);
中买:IF(TROUGHBARS(3,18,1)=0 AND HIGH>LOW+0.1,60,0),COLORLIMAGENTA,LINETHICK6;
中卖:IF(PEAKBARS(2,15,1)=0,80,100),COLORRED;
全买:(ZIG(3,35)>REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)<REF(ZIG(3,35),2))
*90,STICK,COLORRED,LINETHICK6;
全卖:(ZIG(3,15)<REF(ZIG(3,15),1) AND REF(ZIG(3,15),1)>REF(ZIG(3,15),2))
*90,STICK,COLORGREEN,LINETHICK8;
V1:=ZIG(3,12);
V2:IF(REF(V1,2)>REF(V1,1) AND V1>REF(V1,1),50,0),COLORRED,LINETHICK2;
V3:IF(REF(V1,2)<REF(V1,1) AND V1<REF(V1,1),50,0),COLORGREEN,LINETHICK2;
VAR1:=ZIG(3,12)<REF(ZIG(3,12),1) AND REF(ZIG(3,12),1)>REF(ZIG(3,12),2);
VAR2:=ZIG(3,12)>REF(ZIG(3,12),1) AND REF(ZIG(3,12),1)<REF(ZIG(3,12),2);
DRAWTEXT(VAR1,80,'顶'),COLORYELLOW;
DRAWTEXT(VAR2,80,'底'),COLORMAGENTA;

通达信底顶指标公式

 

相关文章