在线检测未来函数

同花顺股价隧道主图指标公式

来源:Internet,编辑:股旁网,2018-05-10

V1:=MA(CLOSE,3);
V2:=MA(CLOSE,2*3);
V3:=MA(CLOSE,3*3);
V4:=MA(CLOSE,4*3);
V5:=MA(CLOSE,5*3);
V6:=MA((V1+V2+V3+V4+V5)/5,5);
隧DM:=IF(HOUR=0,DMA((V1+V2+V3+V4+V5)/5,5)*(1+6.5/100),DRAWNULL),COLOR00FFFF,DOTLINE;
上轨:=IF(HOUR=0,V6*(1+6.5/100),DRAWNULL),COLOR00FF00;
上分轨:=IF(HOUR=0,V6*(1+6.5/100),V6*(1+3.5/100));
下轨:=IF(HOUR=0,V6*(1-6.5/100),DRAWNULL),coloryellow;
下分轨:=IF(HOUR=0,V6*(1-6.5/100),V6*(1-3/100));
中线:=(上分轨+下分轨)/2,COLOR00FF00;
上卖:=(上分轨+中线)/2,COLORAAAAAA,DOTLINE;
下买:=(下分轨+中线)/2,COLORAAAAAA,DOTLINE;
{IF(H>=上卖 ,上卖,DRAWNULL),POINTDOT,colorwhite,LINETHICK4;}
MA3:MA(CLOSE,3),coloryellow;
一:C*1.012,NODRAW,colorred;
二:C*1.022,NODRAW,COLOR00FFFF;
三:C*1.032,NODRAW,colorwhite;
四:C*1.042,NODRAW,COLOR00FFFF;
五:C*1.052,NODRAW,colorgreen;
F:=100*(C-REF(C,1))/REF(C,1);
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
今小昨:=IF(C<REF(0,1) AND F<0,1,0);
P1:=今小昨;
今小前:=IF(C<REF(0,1) AND F<0,1,0);
P2:=今小前;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,1,0),colormagenta;
STICKLINE(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,OPEN,CLOSE,1,0),COLORAAAAAA;
A1:=CLOSE;
A2:=OPEN;
STICKLINE(A1<A2 AND F<-2.9 AND F>-5,A1+(A2-A1)/3,A1+(A2-A1)/3,1,0),colorred;
STICKLINE(A1<A2 AND F<-2.9 AND F>-5,A1+2*(A2-A1)/3,A1+2*(A2-A1)/3,1,0),colorred;
STICKLINE(A1<A2 AND F<=-5 AND F>-7,A1+(A2-A1)/2,A1+(A2-A1)/2,1,0),colorred;
STICKLINE(A1<A2 AND F<=-7 AND F>-10,A1+2*(A2-A1)/3,A1+(A2-A1)/3,3,1),colorred;
STICKLINE(A1<A2 AND F<=-9.9,A2,A1,3,0),COLOR00FF00;
STICKLINE(A1>A2 AND F>2.9 AND F<5,A2+(A1-A2)/3,A2+(A1-A2)/3,1,0),coloryellow;
STICKLINE(A1>A2 AND F>2.9 AND F<5,A2+2*(A1-A2)/3,A2+2*(A1-A2)/3,1,0),coloryellow;
STICKLINE(A1>A2 AND F>=5 AND F<7,A2+(A1-A2)/2,A2+(A1-A2)/2,1,0),coloryellow;
STICKLINE(A1>A2 AND F>=7 AND F<10,A2+2*(A1-A2)/3,A2+(A1-A2)/3,1,1),coloryellow;
STICKLINE(F>5,C,O,2.2,0),COLORFFFFFF;
STICKLINE(H>REF(C,1)*1.032,(O+C)/2,H,0.1,0),coloryellow;
DRAWNUMBER(CCI<-100 AND CCI>-128 AND REF(CCI,1)<-128,L/1.01, INTPART(CCI)),COLOR8888FF;
IF(HOUR=15,H*1.008,DRAWNULL),POINTDOT,COLOR000FFF,LINETHICK5;
IF(HOUR=15,H*1.005,DRAWNULL),POINTDOT,COLORFFF000,LINETHICK9;
IF(HOUR=15,H*1.005,DRAWNULL),POINTDOT,COLOR000FFF,LINETHICK5;
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
DRAWTEXT(FILTER(买=1,5),LOW-0.05,'↖买进'),coloryellow;
STICKLINE(买,OPEN,CLOSE,2,0),coloryellow;
{IF(HOUR!=0,REF("CC半.CC半#DAY",1),DRAWNULL),COLOROOAAAA;
CC半:"CC半.RCC半#DAY";}
{前二日底:IF(C>0,IF(HOUR!=0,"前二日底.前二日底#DAY",DRAWNULL),DRAWNULL),COLOR00FF00;};
F1:=100*(C-REF(C,1))/REF(C,1);
HT:=(H>REF(C,1)*1.032) AND C>=O ;
BZ1A:=HT AND H>REF(H,2);
BZ1:=BZ1A AND COUNT(BZ1A,3)=1;
一字:=C=O AND C=L AND C=H AND F1>9.4;
BZ2:=((BZ1 AND REF(BZ1,1)=0) OR REF(一字,1)=1) AND 一字=0;
DRAWTEXT(BZ2,L*0.99,'标'),coloryellow;

同花顺股价隧道主图指标公式

 

相关文章