在线检测未来函数

同花顺春秋老道指标公式

来源:Internet,编辑:股旁网,2018-05-22

STICKLINE(C>0,-80,-70,5,0),COLOR00008A;
STICKLINE(C>0,70,80,5,0),COLOR79B715;
STICKLINE(C>0,70,70,2,0),COLOR00FFFF;
STICKLINE(C>0,-70,-70,2,0),COLORFFFF00;
VVAR5:=LLV(LOW,75);
VVAR6:=HHV(HIGH,75);
VVAR7:=(VVAR6-VVAR5)/100;
VVAR8:=SMA((CLOSE-VVAR5)/VVAR7,20,1);
VVARA:=3*VVAR8-2*SMA(VVAR8,15,1);
主力100吸筹:=(100-VVARA),colorwhite,LINETHICK3;
STICKLINE(主力100吸筹>100,主力100吸筹,100,2.5,0),COLOR0011FF;
STICKLINE(主力100吸筹>100,主力100吸筹,100,1,0),coloryellow;
DRAWTEXT(FILTER(主力100吸筹>100,15),90,'机构建仓区'),colorred;
{}
WR1:=100-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));
WR2:=100*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13));
A:=MA(WR2,13);
春种秋收:MA(WR1-A,2),LINETHICK3;
MA2:=MA(CLOSE,10);
MA34:=MA(CLOSE,34);
VARA:=((AMOUNT)/(VOL))/(100);
VARB:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC:=((SUM(AMOUNT,7))/(VARA))/(100);
VARD:=DMA(VARB,(VOL)/(VARC));
VARE:=((CLOSE-VARD)/(VARD))*(100);
VARF:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ:=MA(VARE,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
K:=SMA(VARF,3,1);
顶:=(REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (K>79);
DRAWTEXT((REF(BIAS18,1)>=5) AND CROSS(VARJ,VARE) AND (K>79) AND 春种秋收>70,85,'秋收'),coloryellow;
80;
-80,coloryellow;
VARX:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VARX1:=SMA(VARX,3,1);
VARX2:=SMA(VARX1,3,1);
VARX3:=REF(LOW,1);
VARX4:=SMA(ABS(LOW-VARX3),3,1)/SMA(MAX(LOW-VARX3,0),3,1)*100;
VARX5:=EMA(IF(CLOSE*1.2,VARX4*10,VARX4/10),3);
VARX6:=LLV(LOW,30);
VARX7:=HHV(VARX5,30);
VARX8:=IF(LLV(LOW,58),1,0);
A9:= DATETODAY(DATE);DS:=IF(A9<9966,1,DRAWNULL);
筹码短期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,8)/(AMOUNT/VOL/100)/100));
筹码中期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100));
筹码长期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,20)/(AMOUNT/VOL/100)/100));DIF:=EMA(EMA(CLOSE,18)-EMA(CLOSE,34),11);
XSR:=1150501;XS:=IF(DATE<XSR,1,DRAWNULL);
MACD:=EMA(EMA(DIF,11),11),COLOR58FF58;
DEF:=2*(DIF-MACD),COLORFFFF00,LINETHICK0;
MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
VARR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
VARR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
VARR3:=(2*CLOSE+HIGH+LOW)/4;
VARR4:=LLV(LOW,26);
VARR5:=HHV(HIGH,34);
VARR6:=EMA((VARR3-VARR4)/(VARR5-VARR4)*100,16);
VARR7:=SMA((SMA(VARR2,3,1)+3),3,1),LINETHICK3;
VARR8:=EMA(VARR6,7);
VARR9:=SMA(VARR1,3,1);
VARR10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VARR11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VARR12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VARR13:=(VARR10+VARR11+VARR12)/3;
VARR14:=IF(VARR13<=-20,10,0);
VARR15:=HHV(VARR14,10);
VARR24:=LLV(LOW,36);
VARR25:=HHV(HIGH,30);
VARR26:=EMA((CLOSE-VARR24)/(VARR25-VARR24)*4,4)*25;
VARB27:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100)/2+22)*1;
VARB28:=(((CLOSE -(((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) / (((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) * 100);
VARB29:=IF(A9<15366,1,DRAWNULL);
AA05:=MA(C,5);
AA30:=MA(C,30);
MA05:=MA(C,5);
MA10:=MA(C,13);
MA30:=MA(C,34);
BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1)*XS;
加速度5:=EMA((速度5-REF(速度5,1)),3)*VARB29;
五日乖离率:=(C-AA05)/AA05*VARB29*100*DS;
三拾日乖离率:=(C-MA30)/MA30*100*VARB29;
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10)*XS;
牛股买入:STICKLINE(买入,-60,0,6,0),colorred;
VAR1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR2:=EMA(VAR1,30);
VAR3:=EMA(VAR2,30);
VAR4:=3*VAR2-2*VAR3;
势:=EMA(VAR4,5),colorblue,LINETHICK3;
DRAWTEXT(CROSS(10,势),69,'进'),coloryellow;
DRAWTEXT(CROSS(10,势),58,'入'),COLORFF00FF;
DRAWTEXT(CROSS(10,势),43,'异'),COLOR00C0FF;
DRAWTEXT(CROSS(10,势),31,'动'),COLORB47DFF;
DRAWTEXT(CROSS(10,势),19,'区'),COLORFFFF6F;
DRAWTEXT(ISLASTBAR,70,' 秋收'),colorgreen;
DRAWTEXT(ISLASTBAR,-70,' 春种'),COLORFF00FF;
{}
T:=(2*CLOSE+HIGH+LOW)/4;
T1:=IF(YEAR>=2999 AND MONTH>2,0,1);
T2:=LLV(LOW,5);
T3:=HHV(HIGH,4);
T4:=100*EMA(EMA((C-REF(C,1)),6),6)/EMA(EMA(ABS((C-REF(C,1))),6),6);
T5:=LLV(T4,2)=LLV(T4,7) AND COUNT(T4<0,2) AND CROSS(T4,MA(T4,2));
T6:=((EMA(CLOSE,12)-EMA(CLOSE,26))-EMA((EMA(CLOSE,12)-EMA(CLOSE,26)),9))*2;
T7:=EMA((T-T2)/(T3-T2)*100,4)*T1;
T8:=EMA(0.667*REF(T7,1)+0.333*T7,2)*T1;
T9:=CROSS(T7,T8) AND T7<30 AND REF(C<O,2);
T10:=C/REF(C,1)>1.01 AND REF(C>O AND C/REF(C,1)<1.01,1);
长线指标:IF((T9 AND T10 AND T6>REF(T6,1) AND T5),80,-80),coloryellow;
{}
VVAR1:=EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
VVAR2:=CROSS(KDJ.J,KDJ.K);
熊市专用:(VVAR1<=10 AND VVAR2)*60,colorred;
A1:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
A2:=(MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),2));
A3:=(C-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
A4:=SMA(SMA(A3,3,1),3,1);
A5:=3*SMA(A3,3,1)-2*A4;
A6:=EMA(A5,5);
A7:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
A8:=((3*SMA((((C-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)))*100),5,1))-(2*SMA(SMA((((C-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)))*100),5,1),3,1)));
财神爷:=A2<3 AND A6<3 AND A7<8.5 AND A8<5;
{}
AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
机会10风险90:=(SMA(AA5,13,8)),colorwhite,LINETHICK2;
CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
YJD:=(EMA(CS,3)-50)*2,LINETHICK2,colorwhite;
机会来了:IF(机会10风险90<10 AND YJD<-85,85,0),COLORFFFF00,LINETHICK2;
RSV1:=(CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100;
RSV2:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
短线:=SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,14);
中线:=SMA(RSV2,5,1)+2*STD(CLOSE,14);
RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
长线:=SMA(RSV3,5,1);
抄底翻倍:(短线<20 AND 中线<20 AND 长线<20 AND 机会10风险90<10)*100,LINETHICK2,coloryellow;
VA1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA
(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VA2:=EMA(VA1,8);
VA3:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA
(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势:=EMA(VA3,3)-10,COLORFF0000;
STICKLINE(趋势<=-1 AND ( 机会10风险90<10),-80,-100,2,0),COLORFF00FF;
DRAWTEXT(FILTER(趋势<=-1 AND 机会10风险90<10,15),-115,'建仓区'),colorwhite;
{}
DRAWICON(财神爷,-40,9);
DRAWICON(财神爷,-30,9);

同花顺春秋老道指标公式

 

相关文章