在线检测未来函数

通达信涨停板抄底指标公式

来源:Internet,编辑:股旁网,2018-05-29

涨停:=BETWEEN(CLOSE/REF(CLOSE,1),1.0989,1.110) AND C=H AND C>O;
{轨道}
CCO:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DDO:=DMA(CLOSE,CCO);
上轨:=(1+7/100)*DDO;
下轨:=(1-7/100)*DDO;
中轨:=(上轨+下轨)/2;
{箱体}
DFO:=(C-REF(C,1))/REF(C,1)*100<-5;
AAO:=BARSLAST(DFO);
突破箱体:=CROSS(C,REF(O,AAO));
V型反转3:=EXIST(DFO,3) AND 突破箱体;
VD1:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VD2:=(REF(VD1,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD3:=(REF(VD2,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD4:=(REF(VD3,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD5:=(REF(VD4,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD6:=(REF(VD5,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD7:=(REF(VD6,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD8:=(REF(VD7,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD9:=(REF(VD8,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD10:=(REF(VD9,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD11:=(REF(VD10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VD12:=(REF(VD11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VD13蓝:=REF(VD1 OR VD2 OR VD3 OR VD4 OR VD5 OR VD6 OR VD7
OR VD8 OR VD9 OR VD10 OR VD11 OR VD12,1) AND 涨停;
RU9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KU1:=SMA(RU9,3,1);
DU1:=KU1-REF(KU1,1);
FD1:=IF(DU1>7 AND REF(DU1,1)<0 AND (DU1-REF(DU1,1))>9,50,0);
VD14绿:=FD1=50 OR REF("KDJ.J",1)<0 AND "KDJ.J">0 AND 涨停;
VD15红:=VD13蓝 AND VD14绿 AND 涨停;
VD13蓝过滤:=IF((VD14绿),DRAWNULL,VD13蓝);
形态1:=(VD13蓝过滤 OR VD15红) AND C>O AND C<中轨;
形态2:=(VD13蓝过滤 OR VD15红) AND C>O;
急速超跌:=(C-MA(C,34))/MA(C,34)*100<-14;
实体比例2:=ABS(C-O)/C>0.07;
实体比例3:=ABS(C-O)/C>0.06;
统一价:=DYNAINFO(7)>3 AND DYNAINFO(7)<40;{股价取3至25元}
统一盘:=CAPITAL/1000000>=0.3 AND CAPITAL/1000000<9; {流通盘取0.3亿至9亿}
V手1:=BETWEEN(SUM(HSCOL,20),12,20) OR BETWEEN(SUM(HSCOL,20),23,37) OR BETWEEN(SUM(HSCOL,20),39,49)
OR BETWEEN(SUM(HSCOL,20),51,164) OR SUM(HSCOL,20)>166;
V手2:=BETWEEN(SUM(HSCOL,20),12,16) OR BETWEEN(SUM(HSCOL,20),18,19) OR BETWEEN(SUM(HSCOL,20),21,32)
OR BETWEEN(SUM(HSCOL,20),36,48) OR BETWEEN(SUM(HSCOL,20),50,60) OR BETWEEN(SUM(HSCOL,20),62,68)
OR BETWEEN(SUM(HSCOL,20),70,74) OR BETWEEN(SUM(HSCOL,20),76,102) OR BETWEEN(SUM(HSCOL,20),104,126)
OR BETWEEN(SUM(HSCOL,20),128,164) OR BETWEEN(SUM(HSCOL,20),166,267) OR BETWEEN(SUM(HSCOL,20),269,512);
V手3:=BETWEEN(SUM(HSCOL,20),0,22) OR BETWEEN(SUM(HSCOL,20),24,30) OR BETWEEN(SUM(HSCOL,20),32,130)
OR BETWEEN(SUM(HSCOL,20),132,164) OR BETWEEN(SUM(HSCOL,20),166,267) OR SUM(HSCOL,20)>269;
V手4:=BETWEEN(SUM(HSCOL,20),12,20) OR BETWEEN(SUM(HSCOL,20),23,32) OR BETWEEN(SUM(HSCOL,20),36,48)
OR BETWEEN(SUM(HSCOL,20),52,69) OR BETWEEN(SUM(HSCOL,20),71,81) OR BETWEEN(SUM(HSCOL,20),83,89)
OR BETWEEN(SUM(HSCOL,20),91,99) OR BETWEEN(SUM(HSCOL,20),101,111) OR BETWEEN(SUM(HSCOL,20),113,164)
OR BETWEEN(SUM(HSCOL,20),166,267) OR SUM(HSCOL,20)>269;
V手5:=BETWEEN(SUM(HSCOL,20),12,20) OR SUM(HSCOL,20)>23;
V手6:=BETWEEN(SUM(HSCOL,20),0,28) OR SUM(HSCOL,20)>31;
V手7:=BETWEEN(SUM(HSCOL,20),5,17) OR BETWEEN(SUM(HSCOL,20),21,22) OR BETWEEN(SUM(HSCOL,20),24,28)
OR BETWEEN(SUM(HSCOL,20),30,32) OR BETWEEN(SUM(HSCOL,20),36,60) OR BETWEEN(SUM(HSCOL,20),62,130)
OR BETWEEN(SUM(HSCOL,20),132,164) OR BETWEEN(SUM(HSCOL,20),166,267) OR SUM(HSCOL,20)>269;
{以上为选股框架 以下为选股多指标源码}
VA1:=(C-MA(C,30))/MA(C,30)*100;
VA2:=VA1<-3;
VB2:=(H-L)/L>0.07 AND (C-O)/O>0.07 AND C/REF(C,1)>1.05;
VB3:=急速超跌 AND VB2;
VL1:="BIAS.BIAS3"<-6;
VE1:=(-100)*(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3));
VE2:=CROSS(VE1,-87) AND OPEN<MA(CLOSE,5) AND CLOSE>=1.099*REF(CLOSE,1)
AND INDEXC>0.98*REF(INDEXC,1) AND CLOSE<=1.47*LLV(CLOSE,58);
VF1:=HHV(DMI.ADX,10)>65;
VF2:=IF(O<XS2.通道2 AND C>XS2.通道2 AND O<XS2.通道4 AND C>XS2.通道4 AND VF1,70,0);
V短期:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5));
V中期:=100*(C-LLV(L,8))/(HHV(C,8)-LLV(L,8));
V中期A:=100*(C-LLV(L,13))/(HHV(C,13)-LLV(L,13));
V中长期A:=100*(C-LLV(L,21))/(HHV(C,21)-LLV(L,21));
V中短:=(V短期+V中期+V中期A+V中长期A)/4;
V中长期:=100*(C-LLV(L,34))/(HHV(C,34)-LLV(L,34));
V长期:=EMA(V中长期,13);
V选股:=V长期<20 AND CROSS(V中长期,V长期);
V转1:=VE2 AND 形态1 AND 实体比例2 AND V型反转3 AND C<EMA(C,99) AND V手1 AND 统一盘 AND 统一价;
V转2:=VA2 AND 形态1 AND 实体比例3 AND V型反转3 AND V手2 AND 统一盘 AND 统一价;
V转3:=VB3 AND 形态2 AND 实体比例2 AND V手3 AND 统一盘 AND 统一价;
V转4:=VL1 AND 形态1 AND 实体比例2 AND V手4 AND 统一盘 AND 统一价;
V转5:=VF2 AND 形态2 AND 实体比例2 AND V型反转3 AND C<EMA(C,60) AND V手5 AND 统一盘 AND 统一价;
V转6:=VF2 AND 形态2 AND 实体比例2 AND REF(急速超跌,2) AND REF(急速超跌,1) AND 突破箱体 AND CROSS(C,EXPMA(C,13))
AND V手6 AND 统一盘 AND 统一价;
V转7:=V选股 AND 形态2 AND 实体比例2 AND V型反转3 AND V手7 AND 统一盘 AND 统一价;
V型反转:V转1 OR V转2 OR V转3 OR V转4 OR V转5 OR V转6 OR V转7 NODRAW};
{图标}
DRAWICON((V型反转),17,1);
{信号}
{绿色柱状}
STICKLINE(V型反转,0,8,4.5,0),COLORGREEN;
STICKLINE(V型反转,0,12,2.5,0),COLORGREEN;
STICKLINE(V型反转,0,12,2,0),COLOR006600;
STICKLINE(V型反转,0,12,1.5,0),COLOR009900;
STICKLINE(V型反转,0,12,0.1,0),COLOR00FF00;
{白色}
STICKLINE(V型反转,0,15,0.1,0),COLORWHITE;
{写字}
DRAWTEXT(V型反转,10,'---V型反转'),COLOR00FFFF;

通达信涨停板抄底指标公式

 

相关文章