在线检测未来函数

通达信力挽牛熊主图指标公式

来源:Internet,编辑:股旁网,2018-05-28

AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通1:=AA*102/100;
通2:=AA*(200-102)/100;
CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
上:(1+7/100)*DD,CIRCLEDOT,COLORYELLOW;
下:(1-7/100)*DD,CIRCLEDOT,COLOR0099FF;
中:(上+下)/2,CIRCLEDOT,COLORLIGRAY;
A0:=(L+H+C*2)/4;
A1:=EMA(A0,9)COLORWHITE,LINETHICK1;
A2:=EMA(A0,20)COLORYELLOW,LINETHICK1;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
牛:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK4;
熊:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3;
VAR1:=MA(C,11);
升势:IF(VAR1>REF(VAR1,1),VAR1,DRAWNULL),COLORMAGENTA;
跌势:IF(VAR1<REF(VAR1,1),VAR1,DRAWNULL),COLORWHITE;
疯狂线:(1+13.7/100)*DD,COLORRED,LINETHICK2;
超低线:(1-13.7/100)*DD,COLORRED,LINETHICK2;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;
STICKLINE(C/REF(C,1)<0.91,C,O,2,0),COLORGREEN;
MA18:=MA(CLOSE,18);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,7),7)/EMA(EMA(ABS(MTM),7),7);
买:=LLV(DX,3)=LLV(DX,8) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW*0.98,'★买'),COLORRED;
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1),HIGH*1.02,'★卖'),COLORGREEN;

通达信力挽牛熊主图指标公式

 

相关文章