在线检测未来函数

通达信实战型MACD指标公式

来源:Internet,编辑:股旁网,2018-05-28

SHORT:=12;
LONG:=26;
MID:=9;
DIFF:EMA(C,SHORT)-EMA(C,LONG);
DEA:EMA(DIFF,MID);
MACD:(DIFF-DEA)*2,COLORFFFF00,COLORSTICK;
A1:=BARSLAST(REF(CROSS(0, DEA),1));
A2:= BARSLAST(REF(COUNT(DEA<=0,A1+1)=A1+1 AND LLV(DIFF,5)=LLV(DIFF,A1+1) AND CROSS(DIFF,DEA),1));
A3:= BARSLAST(REF(CROSS(DIFF,DEA),1));
DIBL1:=LLV(C,A3+1)=LLV(C,A1+1) AND NOT(LLV(DIFF,A3+1)=LLV(DIFF,A1+1)) AND COUNT(DEA<=0,A2+1)=A2+1 AND CROSS(DIFF,DEA);
金叉:IF(CROSS(DIFF,DEA) AND DEA<=0 AND DIBL1=0,0,DEA),COLORYELLOW;
背离:IF(DIBL1,0,DEA),COLORRED;
B1:=BARSLAST(REF(CROSS(DEA,0),1));
B2:=BARSLAST(REF(COUNT(DEA>=0,B1+1)=B1+1 AND HHV(DIFF,5)=HHV(DIFF,A1+1) AND CROSS(DEA,DIFF),1));
B3:=BARSLAST(REF(CROSS(DEA,DIFF),1));
DINGBL1:= HHV(C,B3+1)=HHV(C,B1+1) AND NOT(HHV(DIFF,B3+1)=HHV(DIFF,B1+1)) AND COUNT(DEA>=0,B2+1)=B2+1 AND CROSS(DEA,DIFF);
死叉:IF(CROSS(DEA,DIFF) AND DEA>=0 AND DINGBL1=0,0,DEA),COLORFFFF00;
顶背离:IF(DINGBL1,0,DEA),COLORGREEN;
DIBJG:=LLV(C,A3+1)=LLV(C,A1+1) AND NOT(LLV(DIFF,A3+1)=LLV(DIFF,A1+1)) AND DIFF>REF(DIFF,1) AND COUNT(DEA<=0,A2+1)=A2+1 AND DIFF<DEA ;
DINGBJG:=HHV(C,B3+1)=HHV(C,B1+1) AND NOT(HHV(DIFF,B3+1)=HHV(DIFF,B1+1)) AND REF(DIFF,1)>DIFF AND COUNT(DEA>=0,B2+1)=B2+1 AND DIFF>DEA ;
STICKLINE(DIBJG =1 ,DEA,DIFF,2,0),COLORRED;
STICKLINE(DINGBJG =1 ,DEA,DIFF,2,0),COLORGREEN;
MB:=EMA(DIFF,20);
UB:=MB+1.9104*STD(DIFF,20);
LB:=MB-1.9104*STD(DIFF,20);
ZJS:=HHV(DEA,B1+1)/2;
ZJX:=LLV(DEA,A1+1)/2;
STICKLINE(DEA>DIFF AND DEA>0 AND DEA>ZJS, ZJS,REF(ZJS,1),1,0), COLORRED;
STICKLINE(DEA<DIFF AND DEA<0 AND DEA<ZJX,ZJX, REF(ZJX,1),1,0),COLORGREEN;

通达信实战型MACD指标公式

 

相关文章