在线检测未来函数

通达信MACD和KDJ组合指标公式

来源:Internet,编辑:股旁网,2018-05-31

HH0:=CONST(HHV(H,75));
LL0:=CONST(LLV(L,75));
MM0:=CONST((HH0+LL0)/2);
HL0:=CONST(IF(CONST(C)>=MM0,LL0-(HH0-LL0)*0.2,HH0+(HH0-LL0)*0.2));
HH1:=IF(CONST(C)<MM0,HH0*1.01,HL0);
LL1:=IF(CONST(C)>=MM0,LL0*0.99,HL0);
HL1:=(HH1+LL1)/2,COLORFFFFFF;
DIF:=EMA(CLOSE,5)-EMA(CLOSE,26);
DEA:=EMA(DIF,3);
MACD:=(DIF-DEA)*2,COLORSTICK;
STICKLINE("MACD.MACD">0,"MACD.MACD"+HL1,HL1,2,1),COLOR00FFFF;
STICKLINE("MACD.MACD">0 AND "MACD.MACD">REF("MACD.MACD",1),
"MACD.MACD"+HL1,HL1,2,0),COLORFF00FF;
STICKLINE("MACD.MACD"<0,"MACD.MACD"+HL1,HL1,2,0),COLOR00FFFF;
STICKLINE("MACD.MACD"<0 AND "MACD.MACD">REF("MACD.MACD",1),
"MACD.MACD"+HL1,HL1,2,1),COLORFF00FF;
RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9));
RSVK:=SMA(RSV1,3,1);
RSVD:=SMA(RSVK,3,1);
RSVJ:=RSVK*3-RSVD*2;
K:RSVK*3+HL1,COLORWHITE;
D:RSVD*3+HL1,COLORYELLOW;
J:RSVJ*3+HL1,COLORRED,LINETHICK2;
DRAWBAND(K,RGB(150,0,150),D,RGB(150,150,150));

通达信MACD和KDJ组合指标公式

 

相关文章