在线检测未来函数

通达信抄底买指标公式

来源:Internet,编辑:股旁网,2018-06-01

CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
DD:=DMA(CLOSE,CC);
EE:=(1-14/100)*DD;
抄底用:=BETWEEN(C,EE*0.98,EE*1.01);
TJ1:=C/MA(C,40)<0.74;
TJ2:=(H-L)/REF(C,1)>0.05;
TJ3:=COUNT(TJ2,5)>1;
宝石底:=TJ1 AND TJ2 AND TJ3;
K:=100;
VAR1C:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR2C:=DMA(CLOSE,VOL/MA(VOL,33)/33);
VAR3C:=(CLOSE-VAR1C)/VAR1C*100<-11/K*100;
VAR4C:=(VAR1C-VAR2C)/VAR2C*100<-22.3/K*100;
VAR5C:=VAR3C AND VAR4C AND (OPEN>CLOSE OR OPEN<CLOSE) AND
(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 AND
(REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) AND
(REF(OPEN,2)>REF(CLOSE,2) OR REF
(OPEN,2)<REF(CLOSE,2)) AND (REF(OPEN,3)>REF(CLOSE,3) OR REF(OPEN,3)<REF(CLOSE,3)) AND (REF
(OPEN,4)>REF(CLOSE,4) OR REF(OPEN,4)<REF(CLOSE,4)) AND (REF(OPEN,5)>REF(CLOSE,5) OR REF(OPEN,5)
<REF(CLOSE,5)) AND (REF(OPEN,6)>REF(CLOSE,6) OR REF(OPEN,6)<REF(CLOSE,6)) AND (REF(OPEN,7)>REF
(CLOSE,7) OR REF(OPEN,7)<REF(CLOSE,7));
VAR6C:=DMA(CLOSE,VOL/MA(VOL,3)/3);
VAR7C:=DMA(CLOSE,VOL/MA(VOL,33)/33);
VAR8C:=(CLOSE-VAR6C)/VAR6C*100<-5;
VAR9C:=(VAR6C-VAR7C)/VAR7C*100<-18;
VARAC:=(INDEXC-LLV(INDEXL,250))/(HHV(INDEXH,250)-LLV(INDEXL,250))*100;
VARBC:=SMA(VARAC,30,1);
VARCC:=SMA(VARBC,50,1);
VARDC:=VAR8C AND VAR9C AND (OPEN>CLOSE OR OPEN<CLOSE) AND
(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05 AND
(REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1));
VAREC:=VARDC AND COUNT(VARDC,2)=1 ;
短线黑马:=VAR5C OR VAREC,COLORRED;
N1:=9;
MTM:=C-REF(C,1);
VAR1:=100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1);
VAR2:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
EEA:=(C-REF(C,26))/REF(C,26)*10;
子墨抄底:=CROSS(RSI,20) AND VAR1<-45 AND VAR2<12 AND EEA<-2;
昨收:=REF(CLOSE,1);
趋势:=SMA(MAX(CLOSE-昨收,0),8,1)/SMA(ABS(CLOSE-昨收),8,1)*100,COLORBLUE;
黑马:=CROSS(趋势,15);
底部黑马1:抄底用 AND 宝石底,COLORFF00FF;
底部黑马2:抄底用 AND 短线黑马,COLORYELLOW;
底部黑马3:宝石底 AND 短线黑马,COLORRED;
底部黑马4:子墨抄底 AND 黑马,COLORGREEN;
底部黑马5:短线黑马 AND 黑马,COLORWHITE;
STICKLINE(底部黑马1,0,6,2,0),COLORFF00FF;
STICKLINE(底部黑马2,0,6,2,0),COLORYELLOW;
STICKLINE(底部黑马3,0,6,2,0),COLORRED;
STICKLINE(底部黑马4,0,6,2,0),COLORGREEN;
STICKLINE(底部黑马5,0,6,2,0),COLORWHITE;

通达信抄底买指标公式

 

相关文章