在线检测未来函数

通达信分仓资金主图指标公式

来源:Internet,编辑:股旁网,2018-06-06

操盘线:EMA(C,55),COLORFA05FF,LINETHICK2;
IF(操盘线>=REF( 操盘线,1),操盘线,DRAWNULL),COLORFA05FF,LINETHICK2;
IF(操盘线<REF (操盘线,1), 操盘线,DRAWNULL),COLOR399C7F,LINETHICK2;
MA1:=EMA(CLOSE,5),COLOR00FF00;
MA2:=EMA(CLOSE,10),COLORFFCC66;
MA3:=EMA(CLOSE,15);
MA4:=EMA(CLOSE,30),COLORFF00FF;
VAR1:=MAX(MA1,MAX(MA2,MAX(MA3,MA4)));
VAR2:=MIN(MA1,MIN(MA2,MIN(MA3,MA4)));
VAR3:=(VAR1-VAR2)/VAR2*1000;
VAR5:=VAR3<5;
VAR6:=COUNT(VAR5=1,5)>0;
VAR7:=CROSS(MA1,MA4);
VAR1A:=CROSS(MA(CLOSE,5),MA(CLOSE,30));
DRAWICON(VAR1A,LOW-LOW*0.01,1);
DRAWTEXT(VAR1A AND CLOSE>MA(CLOSE,250),LOW-LOW*0.03,'1/5买 '),COLORWHITE;
DRAWTEXT(VAR1A AND CLOSE>=MA(CLOSE,60) AND CLOSE<=MA(CLOSE,250),LOW-LOW*0.02,'1/3买'),COLORYELLOW;
DRAWTEXT(VAR1A AND CLOSE<MA(CLOSE,60),LOW-LOW*0.03,'1/2买 '),COLORFF00FF;
Z:=MA(C,120);
VAR4:=MA((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100,3);
D1:DRAWTEXT(CROSS(95,VAR4) AND VAR3>0.3,1.01*HIGH ,'★暴涨顶'),COLORYELLOW;
D2:DRAWTEXT( CROSS(93,VAR4) AND HHV(H,30)/LLV(L,30)>1.1 AND REF(Z,1)/Z>0.997 ,1.01*HIGH ,'★拉升顶'),COLORGREEN;
D3:DRAWTEXT(CLOSE<Z AND Z<REF(Z,1) AND REF(VAR4,1)>90 AND VAR4<REF(VAR4,1) AND REF(VAR4,1)>REF(VAR4,2) ,1.01*HIGH,'★反弹顶'),COLORWHITE;

通达信分仓资金主图指标公式

 

相关文章