在线检测未来函数

通达信股灾后箱体画线主图指标公式

来源:Internet,编辑:股旁网,2018-06-13

上证顶:=CONST(BARSLAST(DATE<=1150612));{上证指数股灾周期}
上市周期:=CONST(BARSCOUNT(C));
股灾周期:=CONST(DATETODAY(DATE)-DATETODAY(1150612));
M:=60;
N:=20;
底部:=CONST(IF(上市周期>股灾周期,LLV(L,上证顶),IF(上市周期>N,LLV(L,上市周期-N),DRAWNULL)));
底部期:=CONST(IF(上市周期>股灾周期,LLVBARS(L,上证顶),IF(上市周期>N,LLVBARS(L,上市周期-N),DRAWNULL)));
顶部:=CONST(IF(上市周期>股灾周期,REF(HHV(H,上证顶-底部期+M),底部期),IF(上市周期>N,REF(HHV(H,上市周期-底部期),底部期),DRAWNULL)));
顶部期:=CONST(IF(上市周期>股灾周期,REF(HHVBARS(H,上证顶-底部期+M),底部期)+底部期,IF(上市周期>N,REF(HHVBARS(H,上市周期-底部期),底部期)+底部期,DRAWNULL)));
新高:=CONST(IF(底部=DRAWNULL,DRAWNULL,HHV(H,底部期)));
新高期:=CONST(IF(底部=DRAWNULL,DRAWNULL,HHVBARS(H,底部期)));
大箱顶:=CONST(IF(顶部=DRAWNULL,DRAWNULL,IF(顶部/底部-1>0.2,顶部,DRAWNULL)));
大箱顶期:=CONST(IF(大箱顶=顶部,顶部期,DRAWNULL));
大箱底:=CONST(IF(底部=DRAWNULL,DRAWNULL,IF(新高/底部-1>0.2,底部,DRAWNULL)));
大箱底期:=CONST(IF(大箱底=底部,底部期,DRAWNULL));
股灾顶:IF(CURRBARSCOUNT<大箱顶期+2,大箱顶,DRAWNULL),LINETHICK2,COLORRED;
股灾底:IF(CURRBARSCOUNT<大箱底期+2,大箱底,DRAWNULL),LINETHICK2,COLORCYAN;

通达信股灾后箱体画线主图指标公式

 

相关文章