在线检测未来函数

通达信卫星升空指标公式

来源:Internet,编辑:股旁网,2018-06-15

MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA250:=MA(CLOSE,250),COLORRED;
N1:=BARSLAST(CROSS(MA5,MA10));
N2:=BARSLAST(CROSS(MA10,MA5));
多:=IF(N1<N2,N1+1,0);
空:=IF(N2<N1,N2+1,0);
QSXS:=MA5>MA20 AND MA10>MA20 AND MA20>REF(MA20,1)
AND MA30>REF(MA30,1);
点火:多*QSXS,COLORRED,LINETHICK0;
燃料:空*QSXS,COLORFFFF00,LINETHICK0;
HKFJ:=HHV(多,5)>=2 AND QSXS AND MA5>REF(MA5,1) AND MA5>MA10;
卫星升空:HKFJ*多,COLORFF00FF,LINETHICK2;{紫红线}
HKSJ:=BARSLAST(卫星升空>0 AND NOT(REF(卫星升空,1)))+1;
高度:(C/REF(C,HKSJ)-1)*100,COLOR00FFFF;
空中加燃:点火>0 AND 卫星升空=0,COLOR00FF00,POINTDOT,LINETHICK0;
N3:=BARSLAST(空中加燃)+1;
K5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.14159;
JXGD1:=K5>REF(K5,1) AND REF(K5,1)<REF(K5,2);
JXGD2:=MA5>REF(MA5,1) AND REF(MA5,1)<REF(MA5,2);
加速升空:FILTER((JXGD1 OR JXGD2) AND C>MA5 AND HKFJ,3),COLOR00FFFF,POINTDOT,LINETHICK0;
N4:=BARSLAST(加速升空);
STICKLINE(空中加燃,0,点火/10+1,4,1),COLOR00FF00;{粗绿柱}
STICKLINE(N4>0 AND N4<=5,REF(点火,N4+1),REF(点火,N4+1),4,0),COLORFFFFFF;
DRAWTEXT(加速升空,点火,'!▲'),COLOR00FFFF;

通达信卫星升空指标公式

 

相关文章