在线检测未来函数

通达信MACD+神奇数字+挖坑指标公式

来源:Internet,编辑:股旁网,2018-06-20

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
MACD2:=MACD;
MJ:=MACD;
S05:=SUM(MJ,0);
QST:=BARSLAST(MJ<0 AND REF(MJ,1)>0)+1;
QXT:=BARSLAST(MJ>0 AND REF(MJ,1)<0)+1;
S5:=IF(MJ>0,S05-REF(S05,BARSLAST(MJ<0)),S05-REF(S05,BARSLAST(MJ>0)))/10;
ST:=IF(MJ>0,REF(QST,QXT)+QXT,REF(QXT,QST)+QST);
RS5:=REF(S5,ST);
BC:IF(MJ>0 AND S5<RS5,0,IF(MJ<0 AND S5>RS5 AND DEA<0,1,0)),COLORYELLOW,VOLSTICK;
获利比:WINNER(C),NODRAW;
STICKLINE((MACD2>=0),0,MACD2,0,1),COLORRED;
STICKLINE(((MACD2>=0) AND (MACD2 < REF(MACD2,1))),0,MACD2,0,0),COLORMAGENTA;
STICKLINE((MACD2<0),0,MACD2,0,0),COLORGREEN;
STICKLINE(((MACD2<0) AND (MACD2 > REF(MACD2,1))),0,MACD2,0,1),COLORWHITE;
DRAWICON(LONGCROSS(CLOSE,MA(CLOSE,5),17),MACD2,1);
DRAWICON(LONGCROSS(MA(CLOSE,5),CLOSE,17),MACD2,2);
DRAWICON(CROSS(DIF,DEA),LLV(DIF,1),29);
DRAWICON(CROSS(DIF>=0,DIF<DEA),DIF,1);
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
DRAWICON(二次金叉,0,25);
三次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=3,60)=1;
DRAWICON(三次金叉,0,26);A1:=IF(MACD2>0,1,-1);
TJ:=MACD2>0;
T:=MACD2<0;
A:=LLV(MACD2,50)=MACD2;
DRAWICON(A AND FILTERX(A,20), MACD2,1);
DRAWTEXT(BARSLAST(TJ)=1,MACD2,'1'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=2,MACD2,'2'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=3,MACD2,'3'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=5,MACD2,'5'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=8,MACD2,'8'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=13,MACD2,'13'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=21,MACD2,'21'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=34,MACD2,'34'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=55,MACD2,'55'),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=1,MACD2,'1'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=2,MACD2,'2'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=3,MACD2,'3'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=5,MACD2,'5'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=8,MACD2,'8'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=13,MACD2,'13'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=21,MACD2,'21'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=34,MACD2,'34'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=55,MACD2,'55'),COLORGREEN;

通达信MACD+神奇数字+挖坑指标公式

 

相关文章