在线检测未来函数

同花顺量价K线主图指标公式

来源:Internet,编辑:股旁网,2018-07-10

飞龙线:(EMA(C,19)),POINTDOT,linethick8,coloryellow;
超短:MA(C,3);
主力成本线:MA(C,21);
中线:MA(C,49);
天眼:MA(C,13);
A0:="cpzb.zp";
A1:="cpzb.cp";
A2:="cpzb.DP";
STICKLINE((A2>=2.1),H,L,0.8,0),colorred;
STICKLINE(((A2>=2.1) AND (C>OPEN)),8,0),colorred;
STICKLINE(((A2>=2.1) AND (C<OPEN)),8,0),colorred;
STICKLINE(((A2>=0) AND (A2<5)),H,L,0.8,0),colorred;
STICKLINE((((A2>=0) AND (A2<5)) AND (C>REF(C,1))),O,C,8,0),colorred;
STICKLINE((((A2>=0) AND (A2<5)) AND (C<REF(C,1))),C,O,8,0),colorred;
STICKLINE(((C>=飞龙线) AND (C>OPEN)),H,L,0.5,0),colorred;
STICKLINE(((C>=飞龙线) AND (C>OPEN)),C,O,8,1),colorred;
STICKLINE(((C>=飞龙线) AND (C=OPEN)),O,C,8,1),colorred;
STICKLINE(((C>=飞龙线) AND (C<OPEN)),H,L,0.5,0),colorred;
STICKLINE(((C>=飞龙线) AND (C<OPEN)),O,C,8,0),colorred;
STICKLINE(((C<=飞龙线) AND (C>OPEN)),H,L,0.5,1),colorcyan;
STICKLINE(((C<=飞龙线) AND (C>OPEN)),O,C,8,1),colorcyan;
STICKLINE(((C<=飞龙线) AND (C=OPEN)),O,C,8,1),colorcyan;
STICKLINE(((C<飞龙线) AND (C<OPEN)),H,L,0.5,0),colorcyan;
STICKLINE(((C<飞龙线) AND (C<OPEN)),O,C,8,0),colorcyan;
DRAWTEXT(A0,L,' ̄0.98 ̄'),linethick2,ALIGN1,ColorFFFFFF;
DRAWTEXT(A0,L*0.98,' B-B'),linethick5,ALIGN1,colorFFFFFF;
DRAWTEXT(A1,H,' ̄ ̄'),linethick2,ALIGN1,colorFFFFFF;
DRAWTEXT(A1,H*1.03,' S-S'),linethick5,colorFFFFFF;
STICKLINE(A1,C,O,8,0),colorFFFF00;
STICKLINE(A1,H,L,1,0),colorFFFF00;
STICKLINE(A0,C,O,8,0),ColorFFFFFF;
STICKLINE(A0,H,L,1,0),ColorFFFFFF;
STICKLINE((A2>=10 AND A2<30),C,O,0,0),ColorFFBBFF;
STICKLINE((A2>=10 AND A2<30),C,O,8,0),colormagenta;
STICKLINE((A2>=10 AND A2<30),C,O,7,0),ColorFF22FF;
STICKLINE((A2>=10 AND A2<30),C,O,6,0),ColorFF44FF;
STICKLINE((A2>=10 AND A2<30),C,O,5,0),ColorFF66FF;
STICKLINE((A2>=10 AND A2<30),C,O,4,0),ColorFF88FF;
STICKLINE((A2>=10 AND A2<30),C,O,3,0),ColorFF99FF;
STICKLINE((A2>=10 AND A2<30),C,O,2,0),ColorFFAAFF;
STICKLINE((A2>=10 AND A2<30),C,O,1,0),ColorFFBBFF;
A3:=EMA((((SLOPE(C,21)) * 20) + C),68);
A4:=EMA(C,10);
A5:=REF(C,3);
A6:=((SMA((MAX((C - A5),0)),6,1)) / (SMA(ABS((C - A5)),6,1))) * 100;
A7:=IF(((A6 < (REF(A6,1))) AND (A6 > 79)),A6,0);
DRAWTEXT((CROSS(A4,A3)),L,''),linethick2,ALIGN1,colorred;
DRAWTEXT(A7,H,'○'),linethick3,colorgreen;
A8:=LLV(L,21);
A9:=HHV(H,21);
A10:=EMA((((CLOSE - A8) / (A9 - A8)) * 100),5);
A11:=EMA((((CLOSE - A8) / (A9 - A8)) * 50),13);
A12:=EMA(((0.667 * (REF(A10,1))) + (0.333 * A10)),2);
A13:=LLV(L,55);
A14:=HHV(H,34);
A15:=EMA((((C - A13) / (A14 - A13)) * 100),3);
A16:=(A11 + A15) / 2;
A17:=EMA(((0.667 * (REF(A15,1))) + (0.333 * A10)),2);
A18:=EMA(A16,5);
A19:=EMA(((0.667 * (REF(A18,1))) + (0.333 * A18)),2);
A20:=CROSS(A10,A11);
A21:=(CROSS(A10,A19)) AND (A19 < 30);
A22:=A21 * 0.6;
DRAWTEXT((A22 = 0.6),L,'◇'),ALIGN1,coloryellow;
DRAWTEXT((A20 = 1),L,'◇'),ALIGN1,colorwhite;
DA:(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*18+C,42);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT(bu,LOW,'买'),ALIGN1,VALIGN0,colorred,linethick3;
DRAWTEXT(bu,LOW,' ̄'),ALIGN1,VALIGN0,Color208FFF,LINETHICK8;
DRAWTEXT(sel,HIGH,' ̄'),ALIGN1,VALIGN0,ColorFFFF00,LINETHICK3;
DRAWTEXT(sel,HIGH,'卖'),ALIGN1,VALIGN2,colorgreen,linethick8;
STICKLINE(买线>=卖线,LOW,HIGH,0.1,0),colorred;
STICKLINE(买线>=卖线,CLOSE,OPEN,8,0),colorred;
STICKLINE(买线<卖线,CLOSE,OPEN,8,0),colorcyan;
STICKLINE(买线<卖线,LOW,HIGH,0.1,0),colorcyan;
STICKLINE(((买线>=卖线) AND (C>OPEN)),H,L,0.5,0),colorred;
STICKLINE(((买线>=卖线) AND (C>OPEN)),C,O,8,1),colorred;
STICKLINE(((买线>=卖线) AND (C=OPEN)),O,C,8,1),colorred;
STICKLINE(((买线>=卖线) AND (C<OPEN)),H,L,0.5,0),colorred;
STICKLINE(((买线>=卖线) AND (C<OPEN)),O,C,8,0),colorred;
STICKLINE(((买线<=卖线) AND (C>OPEN)),H,L,0.5,1),colorcyan;
STICKLINE(((买线<=卖线) AND (C>OPEN)),O,C,8,1),colorcyan;
STICKLINE(((买线<=卖线) AND (C=OPEN)),O,C,8,1),colorcyan;
STICKLINE(((买线<=卖线) AND (C<OPEN)),H,L,0.5,0),colorcyan;
STICKLINE(((买线<=卖线) AND (C<OPEN)),O,C,8,0),colorcyan;
STICKLINE(CROSS(买线,卖线),OPEN,CLOSE,8,0),coloryellow;
STICKLINE(CROSS(卖线,买线),OPEN,CLOSE,8,0),colorgreen;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'关注'),coloryellow;
DRAWTEXT(卖1>0,HIGH*1.02,'风险'),colorgreen;

同花顺量价K线主图指标公式

 

相关文章