在线检测未来函数

通达信量学分析指标公式

来源:Internet,编辑:股旁网,2018-07-13

阴短:C<REF(C,1) AND REF(C,1)*0.955>C AND V*2<REF(V,1),COLOR0066FF ;
{小倍阳}
N:=1;
AA1:=REF(CLOSE,2)<REF(OPEN,2);
AA21:=REF(CLOSE,1)<REF(OPEN,1);
AA22:=REF(CLOSE,1)>REF(OPEN,1);
AA2:=AA21 OR AA22;
AA3:=REF(VOL,1)<REF(VOL,2);
AA4:=VOL>REF(VOL,2);
AA:=AA1 AND AA2 AND AA3 AND AA4;
BB1:=VOL/REF(VOL,1)>1.8;
BB2:=VOL/REF(VOL,1)<2.5;
BB:=BB1 AND BB2;
CC:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.02;
DD:=AA AND BB AND CC;
小倍阳:EXIST(DD,N),COLORBLUE;
{长阳矮柱}
CY:=(C-REF(C,1))/REF(C,1)>=0.04;
AZ:=V/MA(V,60)<=0.5;
阳矮:CY AND AZ AND H>L,COLORLIRED;
{低位阳胜}
低位:=REF({C<O AND} KDJ.J<=20,1);{凹底}
价胜:=C>REF(MAX(C,O),1)*1.00;
量胜:=V>REF(V,1); {178448.COM WEN98编制}
低阳胜: 低位 AND 价胜 AND 量胜;
{凹口平量}
XGX7:=ABS((VOL-REF(VOL,7))/REF(VOL,7))<0.04 AND
VOL>1.8*REF(VOL,2) AND
REF(VOL,1)<REF(VOL,7) AND
REF(VOL,2)<REF(VOL,7) AND
REF(VOL,3)<REF(VOL,7) AND
REF(VOL,(7-3))<REF(VOL,7) AND
REF(VOL,(7-2))<REF(VOL,7) AND
REF(VOL,(7-1))<REF(VOL,7);
XGX8:=ABS((VOL-REF(VOL,8))/REF(VOL,8))<0.04 AND
VOL>1.8*REF(VOL,2) AND
REF(VOL,1)<REF(VOL,8) AND
REF(VOL,2)<REF(VOL,8) AND
REF(VOL,3)<REF(VOL,8) AND
REF(VOL,(8-3))<REF(VOL,8) AND
REF(VOL,(8-2))<REF(VOL,8) AND
REF(VOL,(8-1))<REF(VOL,8);
XGX9:=ABS((VOL-REF(VOL,9))/REF(VOL,9))<0.04 AND
VOL>1.8*REF(VOL,2) AND
REF(VOL,1)<REF(VOL,9) AND
REF(VOL,2)<REF(VOL,9) AND
REF(VOL,3)<REF(VOL,9) AND
REF(VOL,(9-3))<REF(VOL,9) AND
REF(VOL,(9-2))<REF(VOL,9) AND
REF(VOL,(9-1))<REF(VOL,9);
XGX10:=ABS((VOL-REF(VOL,10))/REF(VOL,10))<0.04 AND
VOL>1.8*REF(VOL,2) AND
REF(VOL,1)<REF(VOL,10) AND
REF(VOL,2)<REF(VOL,10) AND
REF(VOL,3)<REF(VOL,10) AND
REF(VOL,(10-3))<REF(VOL,10) AND
REF(VOL,(10-2))<REF(VOL,10) AND
REF(VOL,(10-1))<REF(VOL,10);
XGX11:=ABS((VOL-REF(VOL,11))/REF(VOL,11))<0.04 AND
VOL>1.8*REF(VOL,2) AND
REF(VOL,1)<REF(VOL,11) AND
REF(VOL,2)<REF(VOL,11) AND
REF(VOL,3)<REF(VOL,11) AND
REF(VOL,(11-3))<REF(VOL,11) AND
REF(VOL,(11-2))<REF(VOL,11) AND
REF(VOL,(11-1))<REF(VOL,11);
XGX12:=ABS((VOL-REF(VOL,12))/REF(VOL,12))<0.04 AND
VOL>1.8*REF(VOL,2) AND
REF(VOL,1)<REF(VOL,12) AND
REF(VOL,2)<REF(VOL,12) AND
REF(VOL,3)<REF(VOL,12) AND
REF(VOL,(12-3))<REF(VOL,12) AND
REF(VOL,(12-2))<REF(VOL,12) AND
REF(VOL,(12-1))<REF(VOL,12);
XGX30:=(C-REF(C,1))>0 AND C>O;
XGX31:=XGX7=1 OR XGX8=1 OR XGX9=1 OR XGX10=1 OR XGX11=1 OR XGX12=1;
凹平: XGX31=1 AND XGX30=1,COLORCYAN;
{地量群}
V100:= V<=LLV(V,100)*1.2 AND V>0 AND BARSCOUNT(V)>=100;
百日地量群:=COUNT(V100,5)>=3;
地群:FILTER(百日地量群,4),COLORWHITE;
{回踩黄金线}
{1.黄金柱}
JJ:=(3*C+H+L+O)/6;
VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
LJL:=FILTER(TJ1,3);
黄金线:=REF(LOW,BARSLAST(LJL));
黄金柱:=FILTER(TJ1,3);
金柱:FILTER(TJ1,3),COLORRED;
{2.倍量过左峰}
前高:=REF(HHV(C,30),1);
倍量:=VOL/REF(VOL,1)>=2.0;
倍量过左峰:=C>前高 AND 倍量;
倍过左:C>前高 AND 倍量;
{3.凹口起柱}
T7:=REF(VOL,6)/REF(VOL,7)>=2;
T6:=REF(VOL,5)/REF(VOL,6)>=2;
T5:=REF(VOL,5)/REF(VOL,4)>=1.5;
T4:=REF(VOL,4)/REF(VOL,3)>=1.5;
T3:=REF(VOL,2)/REF(VOL,3)>=1.5;
T1:=V/REF(VOL,1)>2;
T0:=C>O AND C>REF(C,1);
凹口起柱:= T7 AND T1 AND T0 OR T6 AND T1 AND T0 OR T5 AND T1 AND T0 OR T4 AND T1 AND T0
OR T3 AND T1 AND T0 ;
{凹口起柱}
AKQZ:= 黄金柱 AND 凹口起柱;
{4.前高低位}
X:=21;
TTY:=H;
AAT:=REF(TTY,X)=HHV(TTY,2*X+1);
BBT:=FILTER(AAT,X);
CCT:=BACKSET(BBT,X+1);
HD10T:=FILTER(CCT,X);
AA1T:=REF(TTY,X)=LLV(TTY,2*X+1);
BB1T:=FILTER(AA1T,X);
CC1T:=BACKSET(BB1T,X+1);
LD10T:=FILTER(CC1T,X);
前期高位:=REF(H,BARSLAST(HD10T));
前期低位:=REF(L,BARSLAST(LD10T));
{突破前高}
TPQG:= 黄金柱 AND 倍量过左峰 AND C>前期高位;
{选股}
踩金线: (COUNT(TPQG,10) OR COUNT(AKQZ,10)) AND COUNT(CROSS(黄金线*1.01,L),3)>0 AND L>=黄金线 AND C>REF(C,1) AND REF(C,2)>REF(C,1) AND COUNT(LJL,3)=0;

通达信量学分析指标公式

 

相关文章