在线检测未来函数

通达信鱼网兜鱼整合版指标公式

来源:Internet,编辑:股旁网,2018-07-16

{RSI50安全线}
LC:=REF(CLOSE,1);
RSI11:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100,COLORMAGENTA;
RSI22:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100,COLORWHITE;
RSI33:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100,COLORYELLOW,DOTLINE;
RSI50安全线:(RSI11>49 AND RSI22>49 AND RSI33>49)NODRAW,COLOR00FFFF;
STICKLINE(RSI50安全线,10,15,1,0)COLOR00FFFF;
好线:=38,COLORFF3311;
平线:=51,COLORFF1155;
深水:15,COLORFFFF80,DOTLINE;
OK:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORWHITE;
RSI2:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORWHITE;
鱼:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORRED,DOTLINE;
RSI4:=SMA(鱼,7,1),LINETHICK1,COLORWHITE;
趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17)+9,COLORFFFFFF;
趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17)+9,COLOR3377DD;
趋势C:=EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17)+18,COLORYELLOW,LINETHICK1;
A1:=MA(趋势A,7)*1.372,COLORGREEN,LINETHICK1;
A2:=A1*1.0887;
A3:=(1.5*(趋势B+RSI4)-(A2+A1))+12,COLORGREEN,LINETHICK1,DOTLINE;
鱼网:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,A3) AND A3<好线 AND RSI1<平线),48,38),COLORBLUE,LINETHICK1;
白绿线:SMA(鱼,7,1),LINETHICK1,COLORWHITE;
{LC:=REF(CLOSE,1);}
鱼网蓝柱:鱼网=48 AND CROSS(鱼,好线) AND REF(MA(C,3),1)<=MA(C,3),COLORBLUE;
STICKLINE(鱼网蓝柱,50,70,3,0)COLORBLUE;
镶黄柱:C>MA(C,3) AND C>=MA(C,7) AND EVERY(C>O,2) AND 鱼网蓝柱;
STICKLINE(镶黄柱,30,50,1,0)COLORYELLOW;
NOTEXTD101:IF(白绿线<REF(白绿线,1),白绿线,DRAWNULL),COLORGREEN;
HH:=BARSLAST(鱼<=15)<5;
深水鱼:CROSS(鱼,RSI4) AND HH AND 白绿线>15,NODRAW,COLORFFFFFF;{红鱼上穿白绿线}
STICKLINE(深水鱼,80,70,1,0)COLORFFFFFF;
{3、7日线金叉}
三七金叉:BARSLAST(鱼网蓝柱)<5 AND CROSS(MA(C,3),MA(C,7))NODRAW,COLORFF00FF;
STICKLINE(三七金叉,50,70,1,0)COLORFF00FF;
{阳后双阴}
阳后小双阴:(REF(C,2)-REF(C,3))/REF(C,2)>0.04 AND COUNT(C<REF(C,1),2)=2 AND C>MA(C,7)COLOR0080FF;
STICKLINE(阳后小双阴,70,80,1,0)COLOR0080FF;
阴线买入:C>O AND MA(C,5)<MA(C,10) AND REF(C<O,1) AND REF(C<O,2) AND REF(C<O,3) AND (REF(C,1)<REF(C,4)*0.88 OR REF(C,1)<REF(O,4)*0.88)COLORGREEN;
STICKLINE(阴线买入,70,80,1,0)COLORGREEN;

通达信鱼网兜鱼整合版指标公式

 

相关文章