在线检测未来函数

通达信叠彩线主图指标公式

来源:Internet,编辑:股旁网,2018-07-16

A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
YF:=(21*A+20*REF(A,1)+19*REF(A,2)+18*REF(A,3)+17*REF(A,4)+16*REF(A,5)+
15*REF(A,6)+14*REF(A,7)+13*REF(A,8)+12*REF(A,9)+11*REF(A,10)+
10*REF(A,11)+9*REF(A,12)+8*REF(A,13)+7*REF(A,14)+6*REF(A,15)+
5*REF(A,16)+4*REF(A,17)+3*REF(A,18)+2*REF(A,19)+ REF(A,21))/231;
HJX3:=(3*A+2*REF(A,1)+REF(A,2))/6;
Y1:EMA(HJX3,4),COLORLIGRAY;
Y2:EMA(Y1,3),COLORLIGRAY;
Y3:EMA(Y1,7),COLORLIGRAY;
IF(Y1<REF(Y1,1),Y1,DRAWNULL),COLORGREEN;
IF(Y2<REF(Y2,1),Y2,DRAWNULL),COLORGREEN;
IF(Y3<REF(Y3,1),Y3,DRAWNULL),COLORGREEN;
Y4:EMA(YF,6),COLORYELLOW;
Y5:EMA(YF,16),COLORYELLOW;
Y6:EMA(YF,36),COLORYELLOW;
Y7:EMA(YF,56),COLORMAGENTA;
Y8:EMA(YF,76),COLORMAGENTA;
Y9:EMA(YF,96),COLORMAGENTA;
IF(Y4<Y9,Y4,DRAWNULL),COLORLIBLUE;
IF(Y4<Y9,Y5,DRAWNULL),COLORLIBLUE;
IF(Y4<Y9,Y6,DRAWNULL),COLORLIBLUE;
IF(Y7>Y6,Y7,DRAWNULL),COLORGREEN;
IF(Y8>Y6,Y8,DRAWNULL),COLORGREEN;
IF(Y9>Y6,Y9,DRAWNULL),COLORGREEN;
年线:MA(CLOSE,250),COLORWHITE,POINTDOT;
DRAWICON(CROSS(C,Y9) ,L,1);
{DRAWKLINE(H,O,L,C);DRAWTEXT_FIX(1,0.65,1,0,'涨停:'),COLORRED;
DRAWTEXT_FIX(1,0.73,1,0,'跌停:'),COLORGREEN;}
DRAWNUMBER_FIX(1,0.68,1,0,CONST(BARSLAST(CLOSE/REF(CLOSE,1)>=1.095))),COLORRED;
DRAWNUMBER_FIX(1,0.76,1,0,CONST(BARSLAST(CLOSE/REF(CLOSE,1)<=0.9015))),COLORGREEN;
{股本市值}
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
{上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));}
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市天数));
{业绩综合}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));
{风险系数}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值<1.2,'重警',IF(Z值>=1.2 AND Z值<2.6,'轻警','无警'));
财务预警:=STRCAT('财务预警: ',STRCAT(预警,STRCAT('-Z值: ',CON2STR(Z值,3))));
优质资产率:=STRCAT(' 优质资产率: ',CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2));{理论上越大越好但不同行业有不同标准};
现金负债比:=STRCAT(' 现金负债比: ',CON2STR(FINANCE(25)/FINANCE(15),3));{缺长期负债或负债总额,理论上越大越好但不同行业有不同标准};
财务系数:=STRCAT('风险系数: ',STRCAT(STRCAT(财务预警,优质资产率),现金负债比));
DRAWTEXT_FIX(ISLASTBAR,0.00,0,0,股本市值),COLORLIGRAY;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.06,0,当前业绩),COLORLIGRAY;
DRAWTEXT_FIX(ISLASTBAR,0.00,0.12,0,财务系数),COLORLIGRAY;

通达信叠彩线主图指标公式

 

相关文章