在线检测未来函数

通达信小蛮腰望高指标公式

来源:Internet,编辑:股旁网,2018-07-18

VARA1:=((AMOUNT)/(VOL))/(100);
VARB1:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC1:=((SUM(AMOUNT,7))/(VARA1))/(100);
VARD1:=DMA(VARB1,(VOL)/(VARC1));
VARE1:=((CLOSE-VARD1)/(VARD1))*(100);
VARF1:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ1:=MA(VARE1,20)+STD(VARE1,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
AA1:=SMA(VARF1,3,1);
SS1:=(REF(BIAS18,1)>=5) AND CROSS(VARJ1,VARE1) AND (AA1>79);
VAR1AA:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);
VAR2AA:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
全仓买入:IF(VAR2AA AND COUNT(VAR2AA,3)=1,8,0),STICK,LINETHICK1,COLORFF00FF;
DRAWTEXT(VAR1AA,5,' 全仓卖出'),COLORYELLOW;
全仓卖出:IF(VAR1AA AND COUNT(VAR1AA,3)=1,8,0),STICK,LINETHICK1,COLORYELLOW;
DRAWTEXT(VAR2AA,5,' 全仓买入'),COLORWHITE;
STICKLINE(VAR2AA,0,5,3,0),COLOR880088;
STICKLINE(VAR1AA,0,5,4,0),COLORYELLOW;
DRAWTEXT_FIX(1,0.88,5,0,'~☆~老耿副图~☆~'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=89,6.7,'★花为媒指标适合抄底波段特征明显个股,潜伏关注:说明股价已到转折点了,暴跌
途中小心慎用!!'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=89,7.5,'★全仓卖为波浪顶部,在当天下午收盘前提示不变则全仓退出不要留恋!!'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=89,7.1,'★全仓买是踏浪最底起点,分时可逢底吸货,下午收盘前指标提示不变则可全仓买入!!'),COLOR0078FF;
VAR1:=C-REF(C,1);
VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0);
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0);
HR:=HHV(HIGH,55);
HRY:=LLV(LOW,55);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11);
花为媒:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
光头强:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
重仓:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
恭喜暴涨:花为媒+光头强+重仓=3,COLORRED;DRAWTEXT(恭喜暴涨,3,' 恭喜发财暴涨'),COLORRED;
STICKLINE(恭喜暴涨,0,3,5,0),COLORRED;
NOTEXT1:6,COLORBLACK;
Q_1:=C-REF(C,1);
Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0);
X1:=LLV(Q_2,2)=LLV(Q_2,7) ;
X2:=COUNT(Q_2<0,2);
X3:=CROSS(Q_2,MA(Q_2,2));
X4:=REF(Q_B,1)<REF(Q_B,2);
X5:=Q_A>REF(Q_B,1);
买进:=(X1 AND X2 AND X3) AND X4 AND X5;
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
花为媒买线:STICKLINE(REF(TJ,1)=0 AND TJ>=1,4.8,0,1,0),COLORRED;
DRAWTEXT(REF(TJ,1)=0 AND TJ>=1,5.3,'潜伏关注'),COLORRED;
MMM:=1;
SVOL:=INTPART(SUM(V,0)/CAPITAL);
TJ0:=SVOL>REF(SVOL,1) OR BARSSINCE(CLOSE)=0;
S1:=BARSLAST(TJ0)+1;
TJJ2:=S1<REF(S1,1);
S2:=IF(TJJ2,REF(S1,1)+1,S1);
S3:=SUM(TJJ2,0);
ZK1:="KD.K#WEEK"(9,3,3);
ZD2:="KD.D#WEEK"(9,3,3);
ZF1:="MACD.DIF#WEEK"(5,34,5);
ZA2:="MACD.DEA#WEEK"(5,34,5);
换手:=V/CAPITAL*100,LINETHICK0;
JCD:=CROSS(ZK1,ZD2) AND REF(ZD2,1)<30;
分批抄底:EXIST(JCD,MMM),COLORCYAN,NODRAW;
STICKLINE(分批抄底,0,5.4,4,0),COLORCYAN;
DRAWTEXT(分批抄底,5.5,' 分批进场'),,COLORCYAN;

通达信小蛮腰望高指标公式

 

相关文章