在线检测未来函数

通达信散户搏庄主图指标公式

来源:Internet,编辑:股旁网,2018-08-08

主线:=(MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24)+MA(CLOSE,36))/4,LINETHICK2,COLORFF00FF;
股价重心:=DMA(AMOUNT/VOL/100,VOL/CAPITAL),COLORGREEN,LINETHICK2
;MA14:=EMA(CLOSE,14);MA34:=EMA(CLOSE,26);MA54:=EMA(CLOSE,54)
;MA90:=EMA(CLOSE,90);MA120:EMA(CLOSE,120),POINTDOT,LINETHICK2,COLORWHITE;
年线:EMA(C,250),COLORYELLOW,LINETHICK2; {中短波}HZ:=EMA(CLOSE,13);
短波:EMA(HZ,1),COLOR00DD00,LINETHICK1; 中波:EMA(HZ,26),COLORRED,LINETHICK1;
均线148天:=EMA(C,148),POINTDOT,LINETHICK1,COLORGREEN;
成本:=SUM(AMOUNT,0)/SUM(VOL,0)/100,COLORYELLOW ,LINETHICK2 ;
HZ2:EMA(HZ,8),COLORGREEN,LINETHICK2;HZ4:EMA(HZ,39),COLORFF00FF,LINETHICK2;
A1:STICKLINE(HZ2<HZ4,短波,HZ4,1.5,0),COLORBLUE ;
A2:STICKLINE(短波>HZ2,短波,HZ2,3,0),COLORGREEN;
A3:STICKLINE(中波>HZ4,中波,HZ4,2,0),COLORFF00FF;
{慢速KDJ}RSV:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;FASTK:=SMA(RSV,12,1);
K:=SMA(FASTK,9,1),COLORYELLOW;D:=SMA(K,3,1),LINETHICK2,COLORBLUE;
J:=3*K-2*D,LINETHICK1,COLORGREEN;{中波}
VAR11:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75)) /(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR22:=100-VAR11; 中势线:=(-1)*(EMA(VAR22,1)-50)+42,COLORYELLOW,LINETHICK2;
TZ:=(CLOSE-LLV(LOW,331))/(HHV(HIGH,331)-LLV(LOW,331))*100;
强势线:=SMA(TZ,5,1),LINETHICK2,COLORRED;
大盘线:=70*(HHV(HIGH,39)-CLOSE)/(HHV(HIGH,39)-LLV(LOW,39)),LINETHICK1,COLOR009900;{量选}
AA:=VOL/SUM(VOL,13);BB:=DMA(C,AA);CC:=VOL/SUM(VOL,34);DD:=DMA(C,CC);{背离}
VAR00:=WINNER(CLOSE);VAR1:=FORCAST(VAR00,10); VAR2:=MA(VAR1,3); VAR3:=MA(VAR2,12);
VAR4:=MA(VAR3,16); VAR5:=MA(VAR4,31); VAR6:=MA(VAR5,55);
VAR7:=VAR5;VAR8:=VAR4>VAR2*1.11 AND VAR3>VAR2*1.095;
A:=VAR4/VAR2;B:=VAR3/VAR2;VAR9:=VAR2>VAR1*0.95;
TD:=VAR2/VAR1;VAR1H:=INDEXC; VAR2H:=MA(VAR1H,6); VAR3H:=MA(VAR1H,24);
VAR4H:=MA(VAR1H,32); VAR5H:=MA(VAR1H,62); VAR6H:=MA(VAR1H,105);
VAR7H:=VAR5H; VAR8H:=VAR4H>VAR2H*1.11 AND VAR3H>VAR2H*1.095;
VAR9H:=VAR2H>VAR1H*0.95;
PT:=(IF(H=L AND C=O AND L=C AND C>0 AND REF(H,1)=REF(L,1) AND REF(C,1)=REF(O,1) AND REF(H,1)=REF(C,1) AND REF(C,1)>0,0,1))>0;
G:=(VAR7H AND VAR8H AND VAR9H AND CLOSE/COST(8)<=0.7985 AND (COUNT(C=L,4)<3 OR C>REF(C,1)))AND PT OR VAR7 AND VAR8 AND VAR9 AND
CLOSE/COST(5)<=0.8 AND ((VAR1>OPEN OR VAR1>REF(OPEN,1) OR REF(VAR1,1)));
背离:=VAR2<REF(VAR2,1) AND A>REF(A,1);
买入信号1:=VAR1>A AND VAR2>B;买入信号2:=B>A AND 1>B AND A<1 AND H=HHV(H,21);
DRAWICON(CROSS(短波,HZ2),中波,1);
DRAWTEXT(CROSS(短波,HZ2) AND C>O AND J>K AND J>D AND 大盘线<36 AND C>HZ4,L*1.09,'●'),COLORYELLOW;DRAWTEXT(CROSS(短波,HZ2) AND C>O AND J>K
AND J>D AND 大盘线<36 AND C>HZ4,L*1.12,'做趋势'), COLORYELLOW;
DRAWTEXT(CROSS(短波,HZ2),C,'♂');DRAWTEXT(CROSS ( 中波,HZ4),C,'♂');
DRAWTEXT(CROSS ( 中波,MA120),C,'♂');DRAWTEXT(CROSS (HZ4,MA120),C,'♂');

通达信散户搏庄主图指标公式

 

相关文章