在线检测未来函数

通达信翻倍指标公式

来源:Internet,编辑:股旁网,2018-08-14

中轴线:50,COLOR8E2323,LINETHICK2;
股价趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK;
底部警戒: 10,COLORRED,LINETHICK2;
买入警戒:STICKLINE(股价趋势<=10,0,20,2,0),COLORGREEN,LINETHICK2;
买入信号: STICKLINE(CROSS(股价趋势,底部警戒),0,20,3,0),COLORRED,LINETHICK7;
顶部警戒: 90,COLORFFBB66,LINETHICK2;
卖出警戒:STICKLINE(股价趋势>=85,100,80,2,0),STICK,COLORF00FF0,LINETHICK2;
DRAWTEXT_FIX(CURRBARSCOUNT=60,0.4,0.01,0,'【有未来】'),COLORGREEN;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),100,70,3,0),COLORFFF666,LINETHICK5;
多方趋势:7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1),COLOR8811FF,LINETHICK3;
突击套利线:=14;
套利阻力线:=78.89;
抄底:=CROSS(多方趋势,突击套利线);
逃顶:=CROSS(套利阻力线,多方趋势);
DRAWICON(抄底,多方趋势,1);
DRAWICON(逃顶,多方趋势,2);
LC:=REF(CLOSE,1);
AR:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;
VARH:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARG:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARL:=BARSCOUNT(CLOSE);
买点雷达:IF(VARH< 20 AND VARG< 25 AND VARL> 50 AND AR<70,1,0)*30,LINETHICK2,COLOR0078FF;
VAR2:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1);
VAR4:=SMA(VAR3,3,1);
VAR5:=3*VAR3-2*VAR4;
底2: STICKLINE(VAR3<20 AND VAR4<20 AND CROSS(VAR5,VAR3) AND CROSS(VAR3,VAR4),20,50,2,0), COLORYELLOW,LINETHICK6;
VARB:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VARC:=SMA(VARB,5,1);
VARD:=SMA(VARC,5,1);
底5: IF(CROSS(VARC,VARD) AND VARC<20,60,0),STICK,COLORWHITE,LINETHICK2;
VAR8:=(CLOSE-LLV(LOW,60.135))/(HHV(HIGH,60.135)-LLV(LOW,60))*80;
VAR9:=SMA(VAR8,7,1);
VARA:=SMA(VAR9,5,1);
底4: IF(CROSS(VAR9,VARA) AND VAR9<20,50,0),STICK,COLORDBDB70,LINETHICK4;
VAR6:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR7:=10;
底3:= IF(CROSS(VAR6,VAR7),40,0),STICK,COLORDB7093,LINETHICK3;
VARE:=1/WINNER(CLOSE);
VARF:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR10:=100-ABS(VARF);
VAR11:=IF(VARE>5,IF(VARE<100,VARE,VAR10-10),0);
VAR12:=HHV(HIGH,25);
VAR13:=LLV(LOW,25);
VAR14:=EMA((CLOSE-VAR13)/(VAR12-VAR13)*100,5);
底6:= IF(CROSS(VAR14,VAR11),80,0),STICK,LINETHICK2,COLORRED;
底7: (CLOSE-MA(CLOSE,58))/MA(CLOSE,58)<-0.225,STICK,LINETHICK2,COLOR7093DB;
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
RSV2:=(CLOSE-LLV(LOW,37))/(HHV(HIGH,37)-LLV(LOW,37))*100;
RSV3:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
短线:=SMA(SMA(RSV1,3,1),3,1)+3*STD(CLOSE,21),COLOR00FF00,LINETHICK3;
中线:=SMA(RSV2,5,1)+2*STD(CLOSE,37),COLORRED,LINETHICK3;
长线:=SMA(RSV3,5,1),COLORYELLOW,LINETHICK3;
DRAWTEXT(CROSS(短线,长线)AND 长线<18 AND 长线>REF(长线,1)OR CROSS(长线,5),60,'翻倍'),COLORRED,LINETHICK1;
DD:=REF(COUNT(买入警戒,17)=1,1);
必买:IF(DD,90,0),COLORRED;

通达信翻倍指标公式

 

相关文章