在线检测未来函数

通达信智能四色谱主图指标公式

来源:Internet,编辑:股旁网,2018-08-14

MA1:=EMA(C,12);
MA2:=EMA(C,50);
MA3:=EMA(C,34);
MA4:=EMA(C,7);
MA5:=EMA(C,20);
MA6:=EMA(C,10);
DIFF:=EMA(CLOSE,30)-EMA(CLOSE,120);
DEA:=EMA(DIFF,9);
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
M1:MA(CLOSE,5),COLORRED,LINETHICK0;
M2:EMA(CLOSE,12),COLORRED,LINETHICK0;
M3:EMA(CLOSE,50),COLORRED,LINETHICK0;
X:=BARSLAST(REF(CROSS(C,MA(C,120)),1)) AND CROSS(MA(C,20),MA(C,120));
IF(M3<REF(M3,1),M3,DRAWNULL),COLORGREEN,LINETHICK;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,H ,L-0.01 ,0 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,H ,L-0.008 ,0 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,2.5 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,2 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,1 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,0 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,H ,L-0.008 ,0 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,2.5 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,2 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,1 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,0 ,0 ),COLORYELLOW;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,H ,L-0.008 ,0 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,H ,L-0.008 ,0 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,3 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,2.5 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,2 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,1 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,0 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,H ,L-0.008 ,0 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,2.5 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,2 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,1 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,0 ,0 ),COLORYELLOW;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,H ,L-0.008 ,0 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,H ,L-0.008 ,0 ,0 ),COLORMAGENTA;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,2.5 ,0 ),COLORMAGENTA;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,2 ,0 ),COLORMAGENTA;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,1 ,0 ),COLORMAGENTA;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,0 ,0 ),COLORMAGENTA;
VOLUME:=MA(VOL,1)/VOL;
MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);
EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,9),9);
EMVA:=MA(EMV,14);
BB:=EMV-EMVA;
BIAS :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIASMA :=MA(BIAS,6);
CC:=BIAS-BIASMA;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DD:=(K+D+J)/3;
KK:=J-DD;
DIFF2:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA2:=EMA(DIFF2,9);
SS:=DIFF2-DEA2;
AA:=MA(BB+CC+KK+SS,1)*0.01;
MID1:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:=(20*MID1+19*REF(MID1,1)+18*REF(MID1,2)+17*REF(MID1,3)+16*REF(MID1,4)+15*REF(MID1,5)+14*REF(MID1,6)+13*REF(MID1,7)+12*REF(MID1,8)+11*REF(MID1,9)+10*REF(MID1,10)+9*REF(MID1,11)+8*REF(MID1,12)+7*REF(MID1,13)+6*REF(MID1,14)+5*REF(MID1,15)+4*REF(MID1,16)+3*REF(MID1,17)+2*REF(MID1,18)+REF(MID1,20))/210,COLORGREEN{COLORRED};
马线:=MA(牛线,3),COLORMAGENTA{COLORYELLOW};
GB:=(C-牛线);
换手:=V*100/CAPITAL;
主:=MA(换手,5);
大:=MA(换手,12);
中:=MA(换手,34);
散:=MA(换手,55);
均:=(主+大+中+散)/4;
GBB:=(主-散);
GB1:=GB+GBB;
成交量:=V,COLORWHITE,LINETHICK0;
Q:=EMA(V,5);
Q1:=EMA(V,50);
OBV:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);
OBV1:=EMA(OBV,5);
OBV2:=EMA(OBV,50);
W:=(Q-Q1)*0.00001;
W1:=(OBV1-OBV2)*0.000001;
W2:=W+W1;
{R:=0;}
E:=MAX(MA(C,45),MA(C,90));
FF:=MIN(MA(C,45),MA(C,90));
C1:=10000*CLOSE/INDEXC;
O1:=10000*OPEN/INDEXO;
H1:=10000*HIGH/INDEXH;
L1:=10000*LOW/INDEXL;
LL:=IF(L1<C1 AND L1<O1,L1,MIN(C1,O1));
HH:=IF(H1>C1 AND H1>O1,H1,MAX(C1,O1));
A:=EMA(C1,5);
B:=EMA(C1,12);
D3:=EMA(C1,30);
XX:=EMA(C1,35);
F:=EMA(C1,7);
均量:=(A+B+D)/3;
VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
OBV11:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
MAOBV:=MA(OBV11,30);
MTR:=EMA(EMA(EMA(CLOSE,12),12),12);
TRIX:=(MTR-REF(MTR,1))/REF(MTR,1)*100;
MATRIX:=MA(TRIX,9) ;
MIDA:=CLOSE-MIN(REF(CLOSE,1),LOW);
MIDB:=IF(CLOSE<REF(CLOSE,1),CLOSE-MAX(REF(CLOSE,1),HIGH),0);
WAD:=SUM(IF(CLOSE>REF(CLOSE,1),MIDA,MIDB),0);
MAWAD:=MA(WAD,30);
JB:=(OBV11-MAOBV)*0.000001+(A-XX);
机构:=A-XX;
J3:=MAX(MA(C,30),MA(C,60));
K3:=MIN(MA(C,30),MA(C,60));
MID11:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:=(20*MID11+19*REF(MID11,1)+18*REF(MID11,2)+17*REF(MID11,3)+
16*REF(MID11,4)+15*REF(MID11,5)+14*REF(MID11,6)+
13*REF(MID11,7)+12*REF(MID11,8)+11*REF(MID11,9)+
10*REF(MID11,10)+9*REF(MID11,11)+8*REF(MID11,12)+
7*REF(MID11,13)+6*REF(MID11,14)+5*REF(MID11,15)+
4*REF(MID11,16)+3*REF(MID11,17)+2*REF(MID11,18)+REF(MID11,20))/210;
MADKX:=MA(DKX,5);
MDD:=(DKX-MADKX)*1.2;
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,6)-EMA(V1,55);
V3:=EMA(V2,6);
V4:=2*(V2-V3)*5.5;
V5:=(V2-V3)*0.06;
V6:=MDD+V5;
BQIUV:=(GB1);
BQIUSV:=(W2);
WWV:=(A-XX);
XEV:=(V6);
SH:=CROSS(BQIUV,0);
YZ:=CROSS(BQIUSV,0);
JG:=CROSS(WWV,0);
ZL:=CROSS(XEV,0);
EXP1:=EMA(C,5);
EXP2:=EMA(C,8);
EXP3:=EMA(C,12);
EXP4:=EMA(C,17);
EXP5:=EMA(C,21);
EXP6:=EMA(C,50);
EXP7:=EMA(C,250);
A321:=CROSS(C,EXP1);
A1:=CROSS(C,EXP2);
A2:=CROSS(C,EXP3);
A3:=CROSS(C,EXP4);
A4:=CROSS(C,EXP5);
A5:=CROSS(C,EXP6);
A6:=CROSS(C,EXP7);
M:=A321 AND A1 AND A2 AND A3 AND A4 AND A5 AND A6;
买:=SH AND BQIUSV>=0 AND WWV>=0 AND XEV>=0 OR YZ AND BQIUV>=0 AND WWV>=0 AND XEV>=0 OR JG AND BQIUSV>=0 AND BQIUV>=0 AND XEV>=0 OR ZL AND BQIUSV>=0 AND WWV>=0 AND BQIUV>=0;
MMM:=M AND 买;
STICKLINE(MMM ,C ,O ,3 ,0 ),COLORRED;
STICKLINE(MMM ,C ,O ,2 ,0 ),COLORWHITE;
STICKLINE(MMM ,C ,O ,1 ,0 ),COLORYELLOW;
STICKLINE(MMM ,C ,O ,0 ,0 ),COLORGREEN;
DRAWTEXT(CROSS(AA,0),L*0.95,' '),LINETHICK3,COLORRED;
DRAWTEXT(CROSS(0,AA),H*1.02,' '),LINETHICK3,COLORGREEN;
涨停:=IF((C-REF(C,1))/REF(C,1)>0.097,1,0);
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORMAGENTA;
HHJSJDA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
HHJSJDB:(20*HHJSJDA+18*REF(HHJSJDA,1)+18*REF(HHJSJDA,2)+17*REF(HHJSJDA,3)+16*REF(HHJSJDA,4)+15*REF(HHJSJDA,5)+14*REF(HHJSJDA,6)
+13*REF(HHJSJDA,7)+12*REF(HHJSJDA,8)+11*REF(HHJSJDA,9)+10*REF(HHJSJDA,10)+9*REF(HHJSJDA,11)+8*REF(HHJSJDA,12)
+7*REF(HHJSJDA,13)+6*REF(HHJSJDA,14)+5*REF(HHJSJDA,15)+4*REF(HHJSJDA,16)+3*REF(HHJSJDA,17)+2*REF(HHJSJDA,18)+
REF(HHJSJDA,20))/210,COLORYELLOW;
HHJSJDC:MA(HHJSJDB,5),COLORRED;

通达信智能四色谱主图指标公式

 

相关文章