在线检测未来函数

通达信四喜临门指标公式

来源:Internet,编辑:股旁网,2018-08-15

A:=MAX(MA(C,5),MA(C,10));
B:=MIN(MA(C,5),MA(C,10));
绿:C>A,COLORGREEN;
红:C<B,COLORRED;
黄:C>=B AND C<=A,COLORYELLOW;
STICKLINE(C>A,3.3,4,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<B,3.3,4,8,0),COLORRED,LINETHICK2;
STICKLINE(C>=B AND C<=A,3.3,4,8,0),COLORYELLOW,LINETHICK2;
F30A:=MAX(MA(C,10),MA(C,20));
F30B:=MIN(MA(C,10),MA(C,20));
绿灯F30:C>F30A,COLORGREEN;
红灯F30:C<F30B,COLORRED;
黄灯F30:C>=F30B AND C<=F30A,COLORYELLOW;
STICKLINE(C>F30A,2.3,3,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<F30B,2.3,3,8,0),COLORRED,LINETHICK2;
STICKLINE(C>=F30B AND C<=F30A,2.3,3,8,0),COLORYELLOW,LINETHICK2;
F60A:=MAX(MA(C,20),MA(C,28));
F60B:=MIN(MA(C,20),MA(C,28));
绿灯行F60:C>F60A,COLORGREEN;
红灯停F60:C<F60B,COLORRED;
黄灯观望F60:C>=F60B AND C<=F60A,COLORYELLOW;
STICKLINE(C>F60A,1.3,2,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<F60B,1.3,2,8,0),COLORRED,LINETHICK2;
STICKLINE(C>=F60B AND C<=F60A,1.3,2,8,0),COLORYELLOW,LINETHICK2;
FRA:=MAX(MA(C,60),MA(C,120));
FRB:=MIN(MA(C,60),MA(C,120));
绿灯行FR:C>FRA,COLORGREEN;
红灯停FR:C<FRB,COLORRED;
黄灯观望FR:C>=F30B AND C<=F30A,COLORYELLOW;
STICKLINE(C>FRA,0,1,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<FRB,0,1,8,0),COLORRED,LINETHICK2;
STICKLINE(C>=FRB AND C<=FRA,0,1,8,0),COLORYELLOW,LINETHICK2;
DPA:=MAX(MA(INDEXC,60),MA(INDEXC,120));
DPB:=MIN(MA(INDEXC,60),MA(INDEXC,120));

通达信四喜临门指标公式

 

相关文章