在线检测未来函数

通达信mkd成交量指标公式

来源:Internet,编辑:股旁网,2018-09-10

虚拟成交:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,虚拟成交,0,-1,-1),COLORC0C0C0;
量高:HHV(V,120)*0.382,COLORCYAN,DOTLINE;
量比:V/REF(V,1),NODRAW,COLOR0000FF;
STICKLINE(IF(V>REF(HHV(V,239),1),0.99,1)<1,V,0,-1,1),COLORDD00DD;
STICKLINE(IF(V>REF(HHV(V,239),1),0.99,1)<1 AND O>C,V,0,-1,0),COLORDD00DD;
STICKLINE(IF(V<REF(LLV(V,119),1),0.99,1)<1,V,0,-1,0),COLOR00DD00;
STICKLINE(IF(V<REF(LLV(V,239),1),0.99,1)<1,V,0,-1,0),COLORDD0000;
STICKLINE(V/REF(V,1)>2 ,0,V/2,2,0),COLORDDDDDD;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA),STICK;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
STICKLINE(DIF>=DEA,0,VOL,3,-1),COLORRED;
STICKLINE(DIF<=DEA,0,VOL,3,-1),COLORGREEN;
STICKLINE(J>D,VOL/2,VOL,3,-1),COLORRED;
STICKLINE(J<D,VOL/2,VOL,3,-1),COLORGREEN;
{STICKLINE(((MACD<=0) AND (MACD > REF(MACD,1))),0,VOL/8,2,0),COLORMAGENTA;
STICKLINE((MACD>=0) AND MACD>REF(MACD,1),0,VOL/8,2,0),COLORRED;}
0.COLORLIBLUE;
MAC5:=SUM(C*V,5)/SUM(V,5);
红色持股:=C>MAC5 AND MACD>REF(MACD,1)AND DIF>=REF(DIF,1) AND J>REF(J,1) AND DIF>DEA AND J>D,COLOR0000CC;
STICKLINE(红色持股,0,VOL/4,2.8,0),COLORYELLOW;
STICKLINE(红色持股,0,VOL/4,1.5,0),COLOR11BBBB;
STICKLINE(红色持股,0,VOL/4,0.8,0),COLOR11DDDD;
STICKLINE(红色持股,0,VOL/4,0.1,0),COLOR11FFFF;

通达信mkd成交量指标公式

 

相关文章