在线检测未来函数

通达信起爆大主图指标公式

来源:Internet,编辑:股旁网,2018-09-12

DRAWGBK(1,RGB(0,0,0),RGB(0,0,0),0,'BJ1',0);
N:=120;
K:=BARSLAST(CURRBARSCOUNT=N);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0)),NODRAW;{高点}
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0)),NODRAW;{低点}
KJ:=GD-DD;{高低点差值=分区高度}
GD4:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL);
高区:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLORRED,LINETHICK2,NODRAW;
低区:IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2,NODRAW;
平衡:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
低:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;
高:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;
强势: IF(CURRBARSCOUNT<=N/2,DD+KJ*0.382,DRAWNULL),COLORFF00FF;
突破:IF(CURRBARSCOUNT<=N/2,DD+KJ/2,DRAWNULL),COLOR0000FF;
警示:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;
低涨:IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天数:BARSLAST(L=DD),COLORCYAN,NODRAW;
顶点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT,NODRAW;
低点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT,NODRAW;
STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;
DRAWBAND(高区,RGB(0,0,0),平衡,RGB(0,0,0));
DRAWBAND(平衡,RGB(0,0,0),低区,RGB(0,0,0));
DRAWBAND(警示,RGB(128,58,0),突破,RGB(0,0,0));
DRAWBAND(突破,RGB(68,0,0),强势,RGB(0,0,0));
STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080,NODRAW;
STICKLINE(CURRBARSCOUNT<=N/2,强势,强势,2,0),COLOR1E1E1E;
STICKLINE(CURRBARSCOUNT<=N/2,突破,突破,2,0),COLOR1E1E1E;
STICKLINE(CURRBARSCOUNT<=N/2,警示,警示,2,0),COLOR1E1E1E;
DRAWTEXT(CURRBARSCOUNT=10,警示,'警示-0.618'),COLOR00FFFF,NODRAW;
DRAWTEXT(CURRBARSCOUNT=10,突破,'突破-0.500'),COLOR00FFFF,NODRAW;
DRAWTEXT(CURRBARSCOUNT=10,强势,'强势-0.382'),COLOR00FFFF,NODRAW;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.09,'【风险区】--高抛避险'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.3,'【警示区】--逢高减仓'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.55,'【拉升区】--强势畜锐'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/10,'【低吸区】--大胆买入'),COLORFFFFFF;
第一防线:REFDATE(低,DATE),DOTLINE,COLORYELLOW,NODRAW;
{今日保护价: (REF(C,2)+REF(C,1)+O)/3 ,COLORCC3299;}
DRAWKLINE(H,O,L,C);
{STICKLINE(上轨>下轨,上轨,下轨,5,0),COLOR555555;}
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;
STICKLINE(C>=O ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(C>=O ,OPEN,CLOSE,3.1,0 ),COLOR000033;
STICKLINE(C>=O,OPEN,CLOSE,2.7,0 ),COLOR000066;
STICKLINE(C>=O ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(C>=O ,OPEN,CLOSE,1.5,0 ),COLOR0000CC;
STICKLINE(C>=O ,OPEN,CLOSE,0.9,0 ),COLOR0000FF;
STICKLINE(C>=O ,OPEN,CLOSE,0.3,0 ),COLORCC66FF;
STICKLINE(C<O ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(C<O ,OPEN,CLOSE,3.1,0 ),COLOR990000;
STICKLINE(CLOSE<O ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE<O ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE<O ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE<O ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE<O ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
CC:IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLOR000000,NODRAW;
DRAWNUMBER(ISLASTBAR ,C,C),COLORWHITE;
AAA:=CONST(HHV(H,50));
F:=100*(C-REF(C,1))/REF(C,1);
博尔:=IF(C<REF(O,1) AND F<0,1,0);
P1:=博尔;
量化:=IF(C<REF(O,2) AND F<0,1,0);
P2:=量化;
STICKLINE(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,OPEN,CLOSE,3,0),COLOR0055FF;

通达信起爆大主图指标公式

 

相关文章