在线检测未来函数

通达信黄金分割下降主图指标公式

来源:Internet,编辑:股旁网,2018-09-14

N:=75;N1:=5;N2:=10;
{N为多少天内的高低值,N1、N2为短长撑压取点参数}
A1:=REF(H,N1)=HHV(H,2*N1+1);
B1:=FILTER(A1,N1);
C1:=BACKSET(B1,N1+1);
D1:=FILTER(C1,N1);
E1:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
F1:=E1>REF(E1,1);
短压:DRAWLINE(D1,H,F1,H,1),COLORCYAN;
A2:=REF(L,N1)=LLV(L,2*N1+1);
B2:=FILTER(A2,N1);
C2:=BACKSET(B2,N1+1);
D2:=FILTER(C2,N1);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
短支:DRAWLINE(D2,L,F2,L,1),COLORLIRED;
AA1:=REF(H,N2)=HHV(H,2*N2+1);
BB1:=FILTER(AA1,N2);
CC1:=BACKSET(BB1,N2+1);
DD1:=FILTER(CC1,N2);
EE1:=BACKSET(ISLASTBAR,BARSLAST(DD1)+1);
FF1:=EE1>REF(EE1,1);
长压:DRAWLINE(DD1,H,FF1,H,1),COLORGREEN;
AA2:=REF(L,N2)=LLV(L,2*N2+1);
BB2:=FILTER(AA2,N2);
CC2:=BACKSET(BB2,N2+1);
DD2:=FILTER(CC2,N2);
EE2:=BACKSET(ISLASTBAR,BARSLAST(DD2)+1);
FF2:=EE2>REF(EE2,1);
长支:DRAWLINE(DD2,L,FF2,L,1),COLORRED;
高:=REFDATE(HHV(H,N),DATE);
低:=REFDATE(LLV(L,N),DATE);
H1:=高-(高-低)*0.236;
H2:=高-(高-低)*0.382;
H3:=高-(高-低)*0.500;
H4:=高-(高-低)*0.618;
H5:=高-(高-低)*0.809;
DRAWTEXT(CURRBARSCOUNT=1,高,'前高'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,H5,'80.9'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=1,H4,'61.8'),COLORGRAY;
DRAWTEXT(CURRBARSCOUNT=1,H3,'50.0'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,H2,'38.2'),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=1,H1,'23.6'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,低,'前低'),COLORRED;
STICKLINE(CURRBARSCOUNT=13,高,高,100,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=13,H1,H1,100,-1),COLORCYAN;
STICKLINE(CURRBARSCOUNT=13,H2,H2,100,-1),COLORGRAY;
STICKLINE(CURRBARSCOUNT=13,H3,H3,100,-1),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=13,H4,H4,100,-1),COLORLIRED;
STICKLINE(CURRBARSCOUNT=13,H5,H5,100,-1),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=13,低,低,100,-1),COLORRED;

通达信黄金分割下降主图指标公式

 

相关文章