在线检测未来函数

通达信量柱划线主图指标公式

来源:Internet,编辑:股旁网,2018-09-19

阳线:=C>O;
实顶:=IF(阳线,C,O);
实底:=IF(阳线,O,C);
三日最低价:=MIN(MIN(L,REF(L,1)),REF(L,2));
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3);
三日前倍量柱:=REF(VOL,3)>1.9*REF(VOL,4) AND REF(阳线,3);
SZ:=REF(L,3)>REF(H,4);
黄金柱:=三日不破 AND 三日量缩 AND 三日前倍量柱;
TKBLHJZ:=黄金柱 AND SZ;
ZHJZ:=黄金柱;
BLHJZ11:=黄金柱 AND 三日最低价>REF(实顶,3);
BLHJZ12:=黄金柱 AND 三日最低价<=REF(实顶,3) AND 三日最低价>REF(实底,3);
BLHJZ13:=黄金柱 AND 三日最低价<=REF(实底,3) AND 三日最低价>=REF(L,3);
BACKSET0:=BACKSET(ZHJZ,4);
BACKSET1:=BACKSET(黄金柱,4);
BACKSET11:=BACKSET(BLHJZ11,4);
BACKSET12:=BACKSET(BLHJZ12,4);
BACKSET13:=BACKSET(BLHJZ13,4);
TKBLHJZ1:=BACKSET(TKBLHJZ,4);
FILTER0:=FILTER(BACKSET0,3),NODRAW;
FILTER1:=FILTER(BACKSET1,3),NODRAW;
FILTER11:=FILTER(BACKSET11,3),NODRAW;
FILTER12:=FILTER(BACKSET12,3),NODRAW;
FILTER13:=FILTER(BACKSET13,3),NODRAW;
TKBLHJZ11:=FILTER(TKBLHJZ1,3),NODRAW;
K0:=SUMBARS(FILTER0,1);
K1:=SUMBARS(FILTER1,1);
K11:=SUMBARS(FILTER11,1);
K12:=SUMBARS(FILTER12,1);
K13:=SUMBARS(FILTER13,1);
TKK111:=SUMBARS(TKBLHJZ11,1);
倍量黄金:=COUNT(FILTER1,4)>=1,COLORYELLOW NODRAW;
STICKLINE(K0,REF(三日最低价,K1-4),REF(三日最低价,K1-4),25,0),COLORYELLOW;
STICKLINE(FILTER11 OR FILTER12 OR FILTER13,IF(O<C,L,DRAWNULL),IF(O<C,H,DRAWNULL),0,0),COLORYELLOW;
STICKLINE(FILTER11 OR FILTER12 OR FILTER13,IF(O>C,L,DRAWNULL),IF(O>C,H,DRAWNULL),0,0),COLORGREEN;
STICKLINE(FILTER11 OR FILTER12 OR FILTER13,OPEN,CLOSE,1,0),COLORYELLOW;

通达信量柱划线主图指标公式

 

相关文章