在线检测未来函数

通达信波段起指标公式

来源:Internet,编辑:股旁网,2018-09-21

价:EMA(MA((((C-REF(C,1))+(H-REF(H,1))+(L-REF(L,1)))/3)/C,5),1)*500;
价5:MA(价,5);
量:=EMA(MA((V-REF(V,1))/V,5),1)*50;
量5:=MA(量,5);
角:=1>(ATAN((C/REF(C,1)-1)*100)*180/3.14115926)>-1;
STICKLINE(CROSS(价,价5),-0.1,价,3,0),COLORFF00FF;
W:=(C/REF(C,1))>1.01;
横盘:=REF(((HHV(价,3)-LLV(价,3))/LLV(价,3)),1)<=(0.00/100) AND REF(((HHV(价5,3)-LLV(价5,3))/LLV(价5,3)),1)<=(0.00/100) ;
横盘1:= REF(((HHV(H,3)-LLV(L,3))/LLV(L,3)),1)<=(4/100);
量横盘:=REF(((HHV(量,3)-LLV(量,3))/LLV(量,3)),1)<=(0.00/100) AND REF(((HHV(量5,3)-LLV(量5,3))/LLV(量5,3)),1)<=(0.00/100);
量比:=((量+REF(量,1)+REF(量,2))/(量5+REF(量5,1)+REF(量5,2)))>0.5;
STICKLINE(横盘 AND 量比 AND 量横盘 AND 角 AND 横盘1,量5,价,1,0),COLORWHITE ;
A:=COUNT(0.00<=价<=0.02 AND 0.00<=价5<=0.02,CROSS(价,价5))=1 ,COLORYELLOW ;
B:=COUNT(量5>-0.15 AND 量>-0.15,MA(A,3))=1,COLORBLUE ;
D:=IF(量5>-0.15 AND 量>-0.15 AND REF(A,2) AND W,1,0.5),COLORWHITE ;
E:=IF(量5>-0.15 AND 量>-0.15 AND REF(A,3) AND W,1,0.5),COLORWHITE ;
F:=IF(量5>-0.15 AND 量>-0.15 AND REF(A,1) AND W,1,0.5),COLORWHITE ;
G:=横盘 AND 量比 AND 量横盘 AND 角 AND 横盘1;
买:=IF(CROSS(量,价) AND REF(G,1),1,DRAWNULL);
STICKLINE(买,量,价,3,0),COLORRED ;
STICKLINE(COUNT(横盘 AND 量比 AND 量横盘 AND 角 AND 横盘1,3)>2,量,价/2,5,0),COLORMAGENTA;
DRAWTEXT(COUNT(横盘 AND 量比 AND 量横盘 AND 角 AND 横盘1,3)>2,量,'波段起'),COLORMAGENTA;

通达信波段起指标公式

 

相关文章