在线检测未来函数

通达信MACD短期指标公式

来源:Internet,编辑:股旁网,2018-09-24

SHORT:=12;
LONG:=26;
MID:=9;
DIFF :(EMA(C,SHORT) - EMA(C,LONG))*1000;
DEA :EMA(DIFF,MID);
MACD :2*(DIFF-DEA),COLORSTICK;
A0:=BARSLAST(REF(CROSS(DEA,0),1));
A1:=BARSLAST(CROSS(DEA,DIFF));
A2:=REF(BARSLAST(CROSS(DEA,DIFF)),A1+1);
A3:=REF(BARSLAST(CROSS(DEA,DIFF)),A2+A1+2);
A4:=REF(BARSLAST(CROSS(DEA,DIFF)),A3+A2+A1+3);
A5:=REF(BARSLAST(CROSS(DEA,DIFF)),A4+A3+A2+A1+4);
A11:=LLV(C,A1)<REF(LLV(C,A1+1),A1+1) AND LLV(DIFF,A1)>REF(LLV(DIFF,A1+1),A1+1);
A22:=LLV(C,A1)<REF(LLV(C,A1+A2+2),A1+A2+2) AND
LLV(DIFF,A1)>REF(LLV(DIFF,A1+A2+2),A1+A2+2);
A33:=LLV(C,A1)<REF(LLV(C,A1+A2+A3+3),A1+A2+A3+3) AND
LLV(DIFF,A1)>REF(LLV(DIFF,A1+A2+A3+3),A1+A2+A3+3);
A44:=LLV(C,A1)<REF(LLV(C,A1+A2+A3+A4+4),A1+A2+A3+A4+4) AND
LLV(DIFF,A1)>REF(LLV(DIFF,A1+A2+A3+A4+4),A1+A2+A3+A4+4) AND A11 AND A22 AND A33;
A55:=LLV(C,A1)<REF(LLV(C,A1+A2+A3+A4+A5+5),A1+A2+A3+A4+A5+5) AND
LLV(DIFF,A1)>REF(LLV(DIFF,A1+A2+A3+A4+A5+5),A1+A2+A3+A4+A5+5) AND A11 AND A22 AND A33
AND A44;
DIBL:=(A11 OR A22 OR A33 OR A44 OR A55) AND DIFF<0 AND REF(COUNT(MACD<0,2)=2,1) AND CROSS(DIFF,DEA);
DIBL1:=(A11 OR A22 OR A33 OR A44 OR A55) AND DIFF<0 AND DIFF<DEA AND DIFF>REF(DIFF,1)
AND DIFF>REF(DIFF,2);
背离:IF(DIBL,0,DEA),COLORRED;
IF(DIFF<0 AND CROSS(DIFF,DEA) AND DIBL=0,0,DEA),COLORYELLOW;
B0:=BARSLAST(REF(CROSS(0,DEA),1));
B1:=BARSLAST(CROSS(DIFF,DEA));
B2:=REF(BARSLAST(CROSS(DIFF,DEA)),B1+1);
B3:=REF(BARSLAST(CROSS(DIFF,DEA)),B1+B2+2);
B4:=REF(BARSLAST(CROSS(DIFF,DEA)),B1+B2+B3+3);
B5:=REF(BARSLAST(CROSS(DIFF,DEA)),B1+B2+B3+B4+4);
B11:=HHV(C,B1)>REF(HHV(C,B1+1),B1+1) AND HHV(DIFF,B1)<REF(HHV(DIFF,B1+1),B1+1);
B22:=HHV(C,B1)>REF(HHV(C,B1+B2+2),B1+B2+2) AND
HHV(DIFF,B1)<REF(HHV(DIFF,B1+B2+2),B1+B2+2);
B33:=HHV(C,B1)>REF(HHV(C,B1+B2+B3+3),B1+B2+B3+3) AND
HHV(DIFF,B1)<REF(HHV(DIFF,B1+B2+B3+3),B1+B2+B3+3);
B44:=HHV(C,B1)>REF(HHV(C,B1+B2+B3+B4+4),B1+B2+B3+B4+4) AND
HHV(DIFF,B1)<REF(HHV(DIFF,B1+B2+B3+B4+4),B1+B2+B3+B4+4) AND B11 AND B22 AND B33;
B55:=HHV(C,B1)>REF(HHV(C,B1+B2+B3+B4+B5+5),B1+B2+B3+B4+B5+5) AND
HHV(DIFF,B1)<REF(HHV(DIFF,B1+B2+B3+B4+B5+5),B1+B2+B3+B4+B5+5) AND B11 AND B22 AND B33
AND B44;
DINGBL:=(B11 OR B22 OR B33 OR B44 OR B55) AND DIFF>0 AND REF(COUNT(MACD>0,2)=2,1) AND CROSS(DEA,DIFF);
DINGBL1:=(B11 OR B22 OR B33 OR B44 OR B55) AND DIFF>0 AND DEA<DIFF AND DIFF<REF(DIFF,1)
AND DIFF<REF(DIFF,2);
顶背离:IF(DINGBL,0,DEA),COLORGREEN;
IF(DIFF>0 AND CROSS(DEA,DIFF) AND DINGBL=0,0,DEA),COLORBLUE;
STICKLINE(DIBL1,DIFF,DEA,2,0),COLORRED;
STICKLINE(DINGBL1,DIFF,DEA,2,0),COLORGREEN;
MB:=EMA(DIFF,20);
UB:=MB+1.9104*STD(DIFF,20),COLORYELLOW,POINTDOT;
LB:=MB-1.9104*STD(DIFF,20),COLORLIBLUE,POINTDOT;
ZJS:=HHV(DEA,B0)/2;
ZJX:=LLV(DEA,A0)/2;
IF(DEA>DIFF AND DIFF>0 ,ZJS,DRAWNULL),COLORRED;
IF(DEA<DIFF AND DIFF<0 ,ZJX,DRAWNULL),COLORGREEN;

通达信MACD短期指标公式

 

相关文章