在线检测未来函数

通达信财神大道主图指标公式

来源:Internet,编辑:股旁网,2018-09-26

{使用说明:当K线全部收红的时候,只是持股阶段,该段时间一定是在红进绿退线的顶部,处于强势上攻阶段,但是当K线开始变颜色,也就是我们看到的变为一半紫色,一半蓝色的时候,该短时期 此案持股者的卖出时机,同时,当K线变为半红半黄的时间段,这里是超级短线的买进时机!后面我们看到,当蓝紫K线跌破红进绿退线和变色趋势线的时候,一定要注意,第一时间卖出!但是中线投资者注意,跌破红线的时候可以关注有没有跌破底部的变色趋势线!没有跌破可继续持有!}

COLORYELLOWJRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
红红火火:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
下跌趋势:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
短线信号:VAR19,COLOR33AACC,NODRAW;
危险信号:VAR1A,COLORFF99FF,NODRAW;
红进绿退:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF;
变色趋势:MA(CLOSE,10),CIRCLEDOT;
IF(红进绿退>REF(红进绿退,1),红进绿退,DRAWNULL),LINETHICK2,COLOR0000FF;
IF(红进绿退<REF(红进绿退,1),红进绿退,DRAWNULL),COLOR00FF00;
IF(变色趋势>REF(变色趋势,1),变色趋势,DRAWNULL),LINETHICK1,COLORFF00FF;
IF(变色趋势<REF(变色趋势,1),变色趋势,DRAWNULL),COLOR669933;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红红火火,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(红红火火,CLOSE,O,2,0),COLOR000088;
STICKLINE(红红火火,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(红红火火,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(红红火火,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(下跌趋势,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(下跌趋势,CLOSE,O,2,0),COLOR888800;
STICKLINE(下跌趋势,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(下跌趋势,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(下跌趋势,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(短线信号,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(短线信号,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短线信号,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短线信号,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(短线信号,O,O+CO/3,0,0),COLOR33EEEE;
DRAWTEXT(短线信号,REF(CLOSE,1)-0.2,' '),COLORRED;
STICKLINE(危险信号,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(危险信号,O,O+CO/3,2,0),COLOR880088;
STICKLINE(危险信号,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(危险信号,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(危险信号,O,O+CO/3,0.5,0),COLOREE00EE;
DRAWTEXT(危险信号,REF(CLOSE,1)+0.5,' '),COLORGREEN;

通达信财神大道主图指标公式

 

相关文章