在线检测未来函数

通达信爆发介入点指标公式

来源:Internet,编辑:股旁网,2018-10-09

LZ:DYNAINFO(3)*1,COLORFFFF00,POINTDOT;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*2;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*2;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*2;
AA1:IF(RSI1<RSI2 OR RSI1<RSI3 OR RSI2<RSI3,RSI3,RSI1)+LZ,COLORRED;
AA2:IF(RSI1<RSI2 OR RSI1<RSI3 OR RSI2<RSI3,RSI3,RSI2)+LZ,COLORYELLOW;
AA3:RSI3+LZ,COLORBLUE;
DRAWBAND(AA1,RGB(180,0,0),AA3,RGB(0,0,0));
DRAWBAND(AA2,RGB(180,190,0),AA3,RGB(0,0,0));
STICKLINE(AA1>AA3,LZ,LZ*1.002,5,0),COLOR00FF00;
STICKLINE(AA1>AA3,LZ,LZ*0.998,5,0),COLORFF00FF;
AAB:=AA1>AA3 AND C>=O;
BBBB:=AA1>AA3 AND C<O;
DDB:=AA1=AA3 AND C>=O;
EEB:=AA1=AA3 AND C<O;
STICKLINE(AAB,C,O,3.4,0),COLOR000088;
STICKLINE(AAB,C,O,3.0,0),COLOR000099 ;
STICKLINE(AAB,C,O,2.4,0),COLOR0000AA;
STICKLINE(AAB,C,O,2.0,0),COLOR0000BB ;
STICKLINE(AAB,C,O,1.2,0),COLOR0000DD;
STICKLINE(AAB,C,O,0.6,0),COLOR0000EE;
STICKLINE(AAB,H,L,0,0),COLOR0000FF;
STICKLINE(BBBB,C,O,3.4,0),COLOR008888;
STICKLINE(BBBB,C,O,3.0,0),COLOR009999;
STICKLINE(BBBB,C,O,2.4,0),COLOR00AAAA;
STICKLINE(BBBB,C,O,2.0,0),COLOR00BBBB;
STICKLINE(BBBB,C,O,1.2,0),COLOR00DDDD;
STICKLINE(BBBB,C,O,0.6,0),COLOR00EEEE;
STICKLINE(BBBB,H,L,0,0),COLOR00FFFF;
STICKLINE(DDB,C,O,3.4,0),COLOR880088;
STICKLINE(DDB,C,O,3.0,0),COLOR990099;
STICKLINE(DDB,C,O,2.4,0),COLORAA00AA;
STICKLINE(DDB,C,O,2.2,0),COLORBB00BB;
STICKLINE(DDB,C,O,1.2,0),COLORDD00DD;
STICKLINE(DDB,C,O,0.6,0),COLOREE00EE;
STICKLINE(DDB,H,L,0,0),COLORFF00FF;
STICKLINE(EEB,C,O,3.4,0),COLOR888800;
STICKLINE(EEB,C,O,2.8,0),COLOR999900;
STICKLINE(EEB,C,O,2.2,0),COLORAAAA00;
STICKLINE(EEB,C,O,1.2,0),COLORCCCC00;
STICKLINE(EEB,C,O,0.6,0),COLORFFFF00;
STICKLINE(EEB,H,L,0,0),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.0,0,'【彩色K线】★★红色--火山喷发阳线★★黄色--火山喷发阴线
★★粉色--火山平息阳线★★青色--火山平息阴线★★ '),COLORFFFF00;

通达信爆发介入点指标公式

 

相关文章