在线检测未来函数

同花顺生死魔线指标公式

来源:Internet,编辑:股旁网,2018-10-12

P:=10;Q:=5;
V1:=((CLOSE + (4 * HIGH)) / 5);
V2:=LLV(V1,30);
生死线:=V2 * 0.98,LINETHICK2,color0000FF;
主线:=(WMA(CLOSE,P) * 0.99);
VAR1:=POW((CLOSE - 主线),1);
VAR2:=MA(VAR1,3);
VAR3:=SQRT(VAR2);
阻力线:=(主线 + (1.96 * VAR3));
支撑线:=(主线 - (1.96 * VAR3));
DRAWTEXT(主线 > REF(主线,1),主线,'o'),colorred;
DRAWTEXT(((主线 > REF(主线,1)) AND (REF(主线,1) < REF(主线,2))),(主线 * 0.99),'o'),color00EEFF;
魔中轨:MA(CLOSE,24);
VAR1:=REF(CLOSE,1);
VAR2:=((SMA(MAX((CLOSE - VAR1),0),6,1) / SMA(ABS((CLOSE - VAR1)),6,1)) * 100);
DRAWTEXT(CROSS(80,VAR2),(HIGH * 1.02),'顶 '),LINETHICK2,color00EEFF;
阻挡:=(SMA(HIGH,13,2) * 1.04);
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,4,0),colorFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),color0000DD;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,1,0),color00FFFF;
STICKLINE((CLOSE <= OPEN),CLOSE,OPEN,4,0),colorDDCC99;
STICKLINE((CLOSE <= OPEN),HIGH,LOW,1,0),colorFFFF00;
STICKLINE((CLOSE < OPEN),HIGH,LOW,1,0),color008800;
STICKLINE((CLOSE < OPEN),HIGH,LOW,4,0),color00FF00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,4,0),color00BB00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,1,0),color00FF00;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,1,0),color0000FF;
STICKLINE((CLOSE >= OPEN),HIGH,LOW,0,0),color00EEFF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4,0),color0066FF;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color00EEFF;
STICKLINE((CLOSE < OPEN),HIGH,LOW,1,0),color008800;
STICKLINE((CLOSE < OPEN),HIGH,LOW,0,0),color00FF00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,4,0),color00BB00;
STICKLINE((CLOSE < OPEN),CLOSE,OPEN,1,0),color00EE00;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 阻挡)) AND (CLOSE < 阻挡)),OPEN,LOW,0.7,0),colorFF0000;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 阻挡)) AND (CLOSE < 阻挡)),CLOSE,HIGH,0.7,0),colorFF0000;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 阻挡)) AND (CLOSE < 阻挡)),CLOSE,OPEN,6,0),colorFF0000;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 阻挡)) AND (CLOSE < 阻挡)),CLOSE,OPEN,4,0),colorFF0000;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > 阻挡)) AND (CLOSE < 阻挡)),CLOSE,OPEN,2,0),colorFF0000;
DRAWTEXT((((CLOSE < REF(CLOSE,1)) AND (HIGH > 阻挡)) AND (CLOSE < 阻挡)),(HIGH * 1.02),'$'),color00ff00;
VAR1:=((EMA(CLOSE,3) - EMA(CLOSE,6)) - ((EMA(CLOSE,6) - EMA(CLOSE,12)) * (0 - 100)));
VAR2:=EMA(VAR1,3);
VAR3:=((EMA(CLOSE,3) - EMA(CLOSE,6)) - ((EMA(CLOSE,24) - EMA(CLOSE,36)) * (0 - 100)));
VAR4:=EMA(VAR3,9);
VAR5:=CROSS(VAR1,VAR2);
VAR6:=CROSS(VAR2,VAR1);
STICKLINE(VAR5,OPEN,CLOSE,10,0),color00FFFF;
STICKLINE(VAR5,OPEN,(CLOSE - ((CLOSE - OPEN) * 0.33)),10,0),colorFF00FF;
STICKLINE(VAR5,OPEN,(CLOSE - ((CLOSE - OPEN) * 0.66)),10,0),LINETHICK2,color0000FF;
趋势线:=((3 * SMA((((CLOSE - LLV(LOW,28)) / (HHV(HIGH,28) - LLV(LOW,28))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
短期乖离率:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * 100);
A3:=REF(CLOSE,1);
A4:=((SMA(MAX((CLOSE - A3),0),8,1) / SMA(ABS((CLOSE - A3)),8,1)) * 100);
DRAWTEXT(CROSS(21,A4),(LOW * 0.99),'买');
KS:=(((CLOSE - MA(CLOSE,13)) / MA(CLOSE,13)) * (0 - 100));
RKS:=REF(KS,1);
FT:=((((RKS / KS) >= 1.23) AND (RKS >= 8)) AND ((CLOSE / REF(CLOSE,1)) >= 1.02));
反弹:STICKLINE(FT,HIGH,LOW,0,1),LINETHICK2,colorFF00FF;
STICKLINE(FT,OPEN,CLOSE,8,1),LINETHICK2,colorFF00FF;
DRAWTEXT(FT,LOW,'T'),colorFF00FF;

同花顺生死魔线指标公式

 

相关文章