在线检测未来函数

通达信涨停奴龙选股指标公式

来源:Internet,编辑:股旁网,2018-10-19

N2:=25;
M1:=6;
M:=20;
X_1:=(1+M1/100)*MA(CLOSE,N2);
X_2:=MA(CLOSE,5);
X_3:=X_2;
X_4:=X_3*1.1;
X_5:=REF(CLOSE,1)*1.098-CLOSE<0.01;
X_6:=HIGH<X_4 AND X_5 AND OPEN/X_1<1.03 AND NOT(HIGH=OPEN);
X_7:=REF(CLOSE,3)*1.098-REF(CLOSE,2)<0.01;
X_8:=OPEN<REF(CLOSE,3)*1.07;
X_9:=X_6 AND X_8 AND X_7 AND CLOSE>REF(OPEN,2);
X_10:=REF(CLOSE,4)*1.098-REF(CLOSE,3)<0.01;
X_11:=OPEN<REF(CLOSE,4)*1.07;
X_12:=X_6 AND X_11 AND X_10 AND CLOSE>REF(OPEN,3);
X_13:=REF(CLOSE,5)*1.098-REF(CLOSE,4)<0.01;
X_14:=OPEN<REF(CLOSE,5)*1.07;
X_15:=X_6 AND X_14 AND X_13 AND CLOSE>REF(OPEN,4);
X_16:=REF(CLOSE,6)*1.098-REF(CLOSE,5)<0.01;
X_17:=OPEN<REF(CLOSE,6)*1.07;
X_18:=X_6 AND X_17 AND X_16 AND CLOSE>REF(OPEN,5);
X_19:=X_9 OR X_12 OR X_15 OR X_18;
X_20:=HIGH<X_4 AND X_5 AND NOT(HIGH=OPEN);
X_21:=MA(CLOSE,5);
X_22:=MA(CLOSE,24);
X_23:=MA(CLOSE,55);
X_24:=MA(CLOSE,144);
X_25:=MA(CLOSE,233);
X_26:=MA(CLOSE,377);
X_27:=CLOSE>X_21 AND CLOSE>X_22 AND CLOSE>X_23 AND CLOSE>X_24 AND CLOSE>X_25 AND CLOSE>X_26;
X_28:=WINNER(CLOSE)*100;
X_29:=X_28>=95;
X_30:=X_22/REF(X_22,1)>1 AND OPEN/X_22<=1.02;
X_31:=WINNER(CLOSE)*100;
X_32:=X_31>=99;
X_33:=OPEN/X_1<1.01;
X_34:=X_32 AND X_33 AND X_6 AND X_27;
X_35:=X_27 AND X_29 AND X_30 AND X_6;
X_36:=X_34 OR X_35;
X_37:=HIGH<X_4 AND X_5 AND NOT(HIGH=OPEN) AND X_22/REF(X_22,1)>1;
X_38:=REF(CLOSE,3)/REF(CLOSE,2)>=1.08;
X_39:=REF(OPEN,2)>REF(CLOSE,2) AND REF(OPEN,2)>X_22 AND REF(CLOSE,2)<X_22;
X_40:=X_37 AND OPEN/X_22<1.01 AND CLOSE>X_22;
X_41:=X_38 AND X_39 AND X_40;
X_42:=REF(CLOSE,4)/REF(CLOSE,3)>=1.08;
X_43:=REF(OPEN,3)>REF(CLOSE,3) AND REF(OPEN,3)>X_22 AND REF(CLOSE,3)<X_22;
X_44:=X_42 AND X_43 AND X_40;
X_45:=REF(CLOSE,5)/REF(CLOSE,4)>=1.08;
X_46:=REF(OPEN,4)>REF(CLOSE,4) AND REF(OPEN,4)>X_22 AND REF(CLOSE,4)<X_22;
X_47:=X_45 AND X_46 AND X_40;
X_48:=REF(CLOSE,6)/REF(CLOSE,5)>=1.08;
X_49:=REF(OPEN,5)>REF(CLOSE,5) AND REF(OPEN,5)>X_22 AND REF(CLOSE,5)<X_22;
X_50:=X_48 AND X_49 AND X_40;
X_51:=X_41 OR X_44 OR X_47 OR X_50;
HMYLONG:X_51 OR X_36 OR X_19;

通达信涨停奴龙选股指标公式

 

相关文章