在线检测未来函数

通达信神MACD指标公式

来源:Internet,编辑:股旁网,2018-11-09

快速线:EMA(CLOSE,12) - EMA(CLOSE,26),COLOR33FF33,LINETHICK1;
慢速线:EMA(快速线,9),COLORYELLOW,LINETHICK1;
MACD1:=2*(快速线-慢速线),STICK;
MACD2:=EMA(MACD1,3);
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORGREEN;
STICKLINE(MACD1<MACD2,0,MACD1,2,0),COLORCBCBC0;
STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;
MACD:MACD1,NODRAW,COLORMAGENTA;
DRAWICON(CROSS(快速线,0),0-0.01,1);
DRAWICON(CROSS(慢速线,快速线),慢速线-0.01,2);
强:IF(快速线>=慢速线,快速线,DRAWNULL),COLORRED,LINETHICK1;
弱:IF(慢速线>=快速线,慢速线,DRAWNULL),COLORFF9900,LINETHICK1;

通达信神MACD指标公式

 

相关文章