在线检测未来函数

通达信MACD时间周期指标公式

来源:Internet,编辑:股旁网,2018-11-12

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9) LINETHICK1 COLOR00FFFF ;
DEA1:EMA(DIF,9) LINETHICK2 COLOR006EE4 ;
MACD:(DIF-DEA)*2,COLORSTICK;
红面积:IF(DIF>DEA,SUM(MACD,BARSLAST(CROSS(DIF,DEA))),DRAWNULL),NODRAW,COLORLIRED;
绿面积:IF(DIF<DEA,SUM(MACD,BARSLAST(CROSS(DEA,DIF))),DRAWNULL),NODRAW,COLORGREEN;
DRAWNUMBER(CROSS(DIF,DEA),DEA,REF(绿面积,1)),COLORGREEN;
DRAWNUMBER(CROSS(DEA,DIF),DEA*1.1,REF(红面积,1)),COLORLIRED;
DRAWNUMBER(DIF>DEA,MACD,BARSLAST(CROSS(DIF,DEA))+1),COLORRED;
DRAWNUMBER(DIF<DEA,MACD,BARSLAST(CROSS(DEA,DIF))+1),COLORCYAN;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=7,0,MACD,1,0),COLOR00ECFD;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=7,0,MACD,1.5,0),COLOR00B5F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=7,0,MACD,2,0),COLOR0084F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=15,0,MACD,1,0),COLOR00ECFD;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=15,0,MACD,1.5,0),COLOR00B5F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=15,0,MACD,2,0),COLOR0084F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=28,0,MACD,1,0),COLOR00ECFD;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=28,0,MACD,1.5,0),COLOR00B5F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=28,0,MACD,2,0),COLOR0084F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=36,0,MACD,1,0),COLOR00ECFD;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=36,0,MACD,1.5,0),COLOR00B5F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=36,0,MACD,2,0),COLOR0084F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=48,0,MACD,1,0),COLOR00ECFD;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=48,0,MACD,1.5,0),COLOR00B5F3;
STICKLINE(COUNT(DIF>DEA,BARSLAST(CROSS(DIF,DEA))+1)=48,0,MACD,2,0),COLOR0084F3;
STICKLINE(COUNT(DIF<DEA,BARSLAST(CROSS(DIF,DEA))+1)=7,0,MACD,1,0), COLORE47833;
STICKLINE(COUNT(DIF<DEA,BARSLAST(CROSS(DIF,DEA))+1)=15,0,MACD,1,0), COLORE47833;
STICKLINE(COUNT(DIF<DEA,BARSLAST(CROSS(DIF,DEA))+1)=28,0,MACD,1,0) COLORE47833;
STICKLINE(COUNT(DIF<DEA,BARSLAST(CROSS(DIF,DEA))+1)=36,0,MACD,1,0), COLORE47833;
STICKLINE(COUNT(DIF<DEA,BARSLAST(CROSS(DIF,DEA))+1)=48,0,MACD,1,0), COLORE47833;
IF(DIF>REF(DIF,1),DIF,DRAWNULL) CIRCLEDOT LINETHICK3 COLOR2424FF;
IF(DIF>REF(DIF,1),DIF,DRAWNULL) CIRCLEDOT LINETHICK1 COLOR6666FF;
IF(DIF<REF(DIF,1),DIF,DRAWNULL) CIRCLEDOT LINETHICK3 COLORFF8800;
IF(DIF<REF(DIF,1),DIF,DRAWNULL) CIRCLEDOT LINETHICK1 COLORFFFF00;

通达信MACD时间周期指标公式

 

相关文章