在线检测未来函数

通达信类似创投概念股盘中抓涨停选股指标公式

来源:Internet,编辑:股旁网,2018-11-13

目标概念:=FINDSTR(GNBLOCK,'创投概念');{炒股者自己可以任意修改单引号里面的概念}
LBS:=3;
不停牌:=DYNAINFO(4)>0;
去ST:=NOT(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S'));{去除ST}
LONG:=26;SHORT:=12;
MID:=9; M:=3;
WXS:=(LONG-SHORT)/2;
CC:=IF(C>=O,(C*2+H)/3,(C*2+L)/3);
DF:=WXS*(EMA(CC,SHORT)-REF(EMA(CC,SHORT),1));
DIF:=EMA(DF,LONG);
DEA:=EMA(DIF,MID);
K:=SMA(DF,M,1)*1;
D:=SMA(K,M,1);
XDV:=100*3500*V/INDEXV;
XD量:=XDV>REF(MA(XDV,60),1)*LBS AND XDV>REF(XDV,1)*LBS ;
基本模式:= K>=REF(K,1) AND K>DIF AND DIF>0;
模式1:=K>D AND 基本模式; {K线在60日均线上保持上行}
模式51:=CROSS(K,D) ;
模式52:=K>D AND REF(K,1)<REF(K,2);
模式5:=(模式51 OR 模式52) AND 基本模式 ; {K线在60日均线上运行K向上运行}
模式6:=( CROSS(K,D) OR CROSS(K,DIF)) AND DIF>0 AND DIF< DEA AND ABS(DIF-DEA)< ABS(REF(DIF,1)-REF(DEA,1));
{K线在60日均线上运行KD金叉或KDIF再度金叉,空中加油的极猛形态}
模式7:=(DIF>DEA OR CROSS(DIF,DEA)) AND DIF<=0 AND K>=REF(K,1) AND K>D AND K>DIF ; {K线在60日均线下的弱反弹形态}
模式22:=IF(DIF>0,模式1 OR 模式5 OR 模式6, 模式7);
XG: 不停牌 AND 去ST AND XD量 AND 模式22 AND 目标概念 ;

通达信类似创投概念股盘中抓涨停选股指标公式

 

相关文章